[PATCH 3/3] gnu: Add shiru-lv2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Leo Famulari
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
Merged with
A
A
Alexandros Theodotou wrote on 6 Apr 2020 16:16
(name . Guix patches)(address . guix-patches@gnu.org)
053db596207697e4b7d32b55a965b2ba88beca75.camel@zrythm.org
Hi,

This patch adds shiru plugins (unofficial LV2 port). No tag is
available yet and I'm using the date instead of a commit in the version
so new versions can be detected easily.

Thanks,
Alex
From d4bf736c099c526f0b77b3bab0f8debf149ce5be Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Mon, 6 Apr 2020 15:10:06 +0100
Subject: [PATCH 3/3] gnu: Add shiru-lv2.

* gnu/packages/music.scm (shiru-lv2): New variable.
---
gnu/packages/music.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e2a3d84572..85e5fa20cb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5387,3 +5387,33 @@ filtered, pitch shifted and ultimately disintegrated. This is an unofficial
port of the Regrader plugin created by Igorski. It is available as an LV2
plugin and a standalone JACK application.")
(license license:expat)))
+
+(define-public shiru-lv2
+ (package/inherit dragonfly-reverb
+ (name "shiru-lv2")
+ (version "0.0.0-20200406")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/linuxmao-org/shiru-plugins.git")
+ (commit "08853f99140012234649e67e5647906fda74f6cc")
+ ;; Bundles a specific commit of the DISTRHO plugin framework.
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00rf6im3rhg98h60sgl1r2s37za5vr5h14pybwi07h8zbc8mi6fm"))))
+ (inputs
+ `(("cairo", cairo)
+ ("glu", glu)
+ ("jack", jack-1)
+ ("lv2", lv2)
+ ("mesa", mesa)
+ ("pango", pango)))
+ (synopsis "Audio plugin collection")
+ (description "Shiru plugins is a collection of audio plugins created
+by Shiru, ported to LV2 by the Linux MAO project using the DISTRHO plugin
+framework.")
+ (home-page "http://shiru.untergrund.net/software.shtml")
+ (license license:wtfpl2)))
--
2.26.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6LOawACgkQAi6uQjE9
cPMkrgf+LKtajuPAPp9tkHOQ0iYb/MKAX1esnPIzaHBJ+iGsLEvlaa3AjiHOuVIr
F/wSEawkd27wJuEpNkB/qb8EGEO+S3mH4bh4hPRNdR1lfA0TpDhhn2JfGJPi98Ur
0gZYIRT0tqglDhxAxBsb1miqBhybyzoFjcG+4bEs4p1i08Bo1oDWEExyERK+zGRg
VEgmoFFfSKTpz1lQ/4sa+TvcmtuXboBmAfHU03JJzkNi974MEOELYIT1ySYMMuoU
jtDlvp+MyckTlqqhm4YpRGRx90E+ktNon3Cbww9DIhzjJr2/UoC3wv5pBbsBorRv
Qy19i4Y/6kYbfSSbTnItigMuQFppxw==
=SDe+
-----END PGP SIGNATURE-----


A
A
Alexandros Theodotou wrote on 6 Apr 2020 23:28
(address . 40468@debbugs.gnu.org)
e43d20b120dd66887e587ac9d157dd7d7df4e411.camel@zrythm.org
From 83ba8ba27d6b6f75eb8cbcbcdf19369903602249 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Mon, 6 Apr 2020 22:26:45 +0100
Subject: [PATCH 3/3] gnu: Add shiru-lv2.

* gnu/packages/music.scm (shiru-lv2): New variable.
---
gnu/packages/music.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e2a3d84572..78a799a53a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5387,3 +5387,35 @@ filtered, pitch shifted and ultimately disintegrated. This is an unofficial
port of the Regrader plugin created by Igorski. It is available as an LV2
plugin and a standalone JACK application.")
(license license:expat)))
+
+(define-public shiru-lv2
+ (let ((commit "08853f99140012234649e67e5647906fda74f6cc")
+ (revision "1"))
+ (package/inherit dragonfly-reverb
+ (name "shiru-lv2")
+ (version (git-version "0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/linuxmao-org/shiru-plugins.git")
+ (commit commit)
+ ;; Bundles a specific commit of the DISTRHO plugin framework.
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00rf6im3rhg98h60sgl1r2s37za5vr5h14pybwi07h8zbc8mi6fm"))))
+ (inputs
+ `(("cairo", cairo)
+ ("glu", glu)
+ ("jack", jack-1)
+ ("lv2", lv2)
+ ("mesa", mesa)
+ ("pango", pango)))
+ (synopsis "Audio plugin collection")
+ (description "Shiru plugins is a collection of audio plugins created
+ by Shiru, ported to LV2 by the Linux MAO project using the DISTRHO plugin
+ framework.")
+ (home-page "http://shiru.untergrund.net/software.shtml")
+ (license license:wtfpl2))))
--
2.26.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6LnwMACgkQAi6uQjE9
cPNI2ggArbw0/2/jUYVy1kP3PoNeejcMnEi40F/Yakfwnp9Z7HCKWq3oarfP/Ent
2QSH6JwYOfdRGxDUZMdSfp14srqwTHkWIWP+pSvYCjjmauUOdVnXOJA2vn9T0kd8
fgerzyJhLjVM54ub/K/TbapAnYt/PzyFd2jtMsFVeAx28sn98qhGUiztltnyWeav
R2DNlFVaLP5VyGG8d5zPQgnAlnH/HS4Yh8xU1b8Oxv+c0BmkGWd0EAMAOJzExoVj
rDU/a4/Jdy/9Hijwb9qLF+rDakRk/eOXdiEszVIJx8H74KrI7nH0+ZKrlNV1sJB+
oeo2TUn+pXwATSSyt698anunkKR/3A==
=zO4E
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 7 Apr 2020 20:25
Re: [bug#40468] [PATCH 3/3] gnu: Add shiru-lv2.
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40468@debbugs.gnu.org)
20200407182511.GA9039@jasmine.lan
On Mon, Apr 06, 2020 at 10:28:35PM +0100, Alexandros Theodotou wrote:
Toggle quote (2 lines)
> * gnu/packages/music.scm (shiru-lv2): New variable.

Thanks!

Toggle quote (5 lines)
> +(define-public shiru-lv2
> + (let ((commit "08853f99140012234649e67e5647906fda74f6cc")
> + (revision "1"))
> + (package/inherit dragonfly-reverb

If inheriting, we should use the regular inherit procedure, like this:

(package
(inherit dragonfly-reverb)
...)

package/inherit is for special cases related to grafting and replacement
packages. [0]

Anyways, it looks like the inherited fields are build-system,
native-inputs, and arguments. Is the idea that there is some build
complication common to the LV2 plugins that we don't want to copy
around? Maybe we could make a build system for them.

Does it work to inherit the custom install phase from dragonfly-reverb?
It seems like the install-file procedures would not apply here.

What do you think? Sorry if I've missed something.

[0]
A
A
Alexandros Theodotou wrote on 7 Apr 2020 21:09
(name . Leo Famulari)(address . leo@famulari.name)(address . 40468@debbugs.gnu.org)
224c908df7cf2e32dff2bd31e5050dd4d552093a.camel@zrythm.org
Hi Leo,

Toggle quote (4 lines)
> package/inherit is for special cases related to grafting and
> replacement
> packages. [0]

Thank you, I initially thought it was just a shorthand.

Toggle quote (8 lines)
> Is the idea that there is some build
> complication common to the LV2 plugins that we don't want to copy
> around? Maybe we could make a build system for them.
>
> Does it work to inherit the custom install phase from dragonfly-
> reverb?
> It seems like the install-file procedures would not apply here.

Plugins that use the DISTRHO plugin framework (
https://github.com/DISTRHO/DPF)use the same build/install procedure,
unless the author makes changes to the Makefiles (like in the case of
the zam-plugins package). Dragonfly reverb and shiru plugins both use
DPF as-is, so the build/install procedures are exactly the same - built
plugins will be produced inside "bin" as binaries, lv2 plugins and vst
plugins.

There are more DPF-based plugins I plan to package that leave the the
DPF Makefiles as-is so I thought inheriting from dragonfly-reverb would
be a nice way to do it.

Thanks,
Alex

On Tue, 2020-04-07 at 14:25 -0400, Leo Famulari wrote:
Toggle quote (34 lines)
> On Mon, Apr 06, 2020 at 10:28:35PM +0100, Alexandros Theodotou wrote:
> > * gnu/packages/music.scm (shiru-lv2): New variable.
>
> Thanks!
>
> > +(define-public shiru-lv2
> > + (let ((commit "08853f99140012234649e67e5647906fda74f6cc")
> > + (revision "1"))
> > + (package/inherit dragonfly-reverb
>
> If inheriting, we should use the regular inherit procedure, like
> this:
>
> (package
> (inherit dragonfly-reverb)
> ...)
>
> package/inherit is for special cases related to grafting and
> replacement
> packages. [0]
>
> Anyways, it looks like the inherited fields are build-system,
> native-inputs, and arguments. Is the idea that there is some build
> complication common to the LV2 plugins that we don't want to copy
> around? Maybe we could make a build system for them.
>
> Does it work to inherit the custom install phase from dragonfly-
> reverb?
> It seems like the install-file procedures would not apply here.
>
> What do you think? Sorry if I've missed something.
>
> [0]
> https://guix.gnu.org/manual/en/html_node/Security-Updates.html
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6Mz+sACgkQAi6uQjE9
cPNxNgf+NpxlQY8xu+W5Pchgp9Xjt7H6/CWGkwYImFjAU+F/3YqGYoy0MJ0WxI8F
pVmVvl8d2ixX5x3Ejnx8bbL0vxwrQdmEjUqgM8IzIenjepW+bfPvspcVXcAmd/7A
QJuNRTcgnC8FgAoyVUslxPyBCR2MHhF4JNA7ZQODU7UymSbdSA1KrqGvGrYlmwLx
cQp4k7GF/9kKmMts1JZoFCe68/5UK5PQ3RuSt0yyG4KhB9Sco861GJQVwgrF8nuP
95C5CSo7k8ak8RfEzcJR7AKXiJVp1wT9V4gaUCiK6fOyasA6bihmqyIQjfvbC5jN
8ELf0QymW5cMviLfMWEaVJA2xdcI5w==
=3JmO
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 7 Apr 2020 21:41
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40468@debbugs.gnu.org)
20200407194138.GA14915@jasmine.lan
On Tue, Apr 07, 2020 at 08:09:31PM +0100, Alexandros Theodotou wrote:
Toggle quote (12 lines)
> Plugins that use the DISTRHO plugin framework (
> https://github.com/DISTRHO/DPF) use the same build/install procedure,
> unless the author makes changes to the Makefiles (like in the case of
> the zam-plugins package). Dragonfly reverb and shiru plugins both use
> DPF as-is, so the build/install procedures are exactly the same - built
> plugins will be produced inside "bin" as binaries, lv2 plugins and vst
> plugins.
>
> There are more DPF-based plugins I plan to package that leave the the
> DPF Makefiles as-is so I thought inheriting from dragonfly-reverb would
> be a nice way to do it.

Okay, feel free to write the packages in whatever way works for you.

Toggle quote (4 lines)
> > Does it work to inherit the custom install phase from dragonfly-
> > reverb?
> > It seems like the install-file procedures would not apply here.

However, I tried building it from the patch and the install phase does
fail there.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAl6M13IACgkQJkb6MLrK
fwj68hAAuRp/zoXMw9FbLSzLcTDgAsWdYsZcvyYvWyrbA6meHy0bxAivMUPNfRMp
TIakvq3m5KtYrJgIE6+uaAkt4PJrY94pHHpVK0oPewQxc59rOghk+E7JszF5z1IT
hysyoKv9nIPv7OkO+O6qgNFNqe7zYXW5XGzbS3zq1wBFRVEJCi5DEBjmPyk5rBCP
Yjj8f6+szJK+LUG0Eu4pxjhF4BDHKFlaPh+aoI2WaoZIOTDPUtyTCjp4eK64zNvQ
6bfJV6hkz5bqkyuvckIaEEQMThsEdP/CttcG+3sHOqkqeJ+2OY+TIKsqe8+SBDOC
PoKgsn3oO+omItUK+//oW/frCc/NTMGlWBoE2rxyhFmzCw7+TUYT5dBqZ0tKLtX/
saImg9xYvPvXUbOCHVT/d7OREvF4ryKW4TBR5Td88v3YPvBOHEfQsyEkuIKvHylk
lpynvuj28oImCI36o8wJUAOF8f09fCuA9QTSEJbACI4r+QzPmixfh8sqRWLiuU8r
5ROHOst4nryX/znUCy7mIwNdg9VTi/PcGsr/vUzimvBHShIq9idwtWN6Uaqcob1I
9ndydpw7udiMz/LobSXcQowqGGd2mI1HbGEzvq2RwwCbAvbedbRPBj4C9Q52Gp/9
2IJtWFWxKQ1gKxA2z8ZneyeGn1d6x1MCQ3+V6SzbbylYwY4h9xA=
=zWIk
-----END PGP SIGNATURE-----


A
A
Alexandros Theodotou wrote on 7 Apr 2020 22:04
(name . Leo Famulari)(address . leo@famulari.name)(address . 40468@debbugs.gnu.org)
1fe07e3677e852cd9d502b68e4659879fc21e6b0.camel@zrythm.org
Toggle quote (8 lines)
> > > Does it work to inherit the custom install phase from dragonfly-
> > > reverb?
> > > It seems like the install-file procedures would not apply here.
>
> However, I tried building it from the patch and the install phase
> does
> fail there.

Did you build it after applying the previous 2 patches?

This is supposed to be merged after those changes. The first patch
(40466) changes the install procedure in dragonfly-reverb, which is
inherited here.
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6M3NgACgkQAi6uQjE9
cPMRxwf9F/kziMx9J970B00/0j1u5sU+xbmpmSBm+WEKsPLRU71UsR1g8X5dlRn9
LUJIw1Ruk684hSNuRFMtZ42ESjrhIxLqu/jQfOqBsrm5eudtwQrVs1d7LnouYnAT
2MpxhJOoD692MmmwPEsmcXssVTaUJTBTg5SDVJlqyvZ8hc/BGGuVkHVhcczo0Fqt
S2H2wFHzNwg2amyROyd99p7XaF8GZCxJ5Qz259JP3LksU3n8vjEdS9raMVWE6KGJ
50JvL/v9T1e6tT3V9IOI7HDZcyDCUEelTq7TwR/TeHuYu3NZE8OlktoAcfUJApwI
UD6sGM59Mt3aFZRDn0o2R5GihdYpCw==
=GJWr
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 7 Apr 2020 22:08
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40468@debbugs.gnu.org)
20200407200855.GA15764@jasmine.lan
On Tue, Apr 07, 2020 at 09:04:40PM +0100, Alexandros Theodotou wrote:
Toggle quote (16 lines)
> > > > Does it work to inherit the custom install phase from dragonfly-
> > > > reverb?
> > > > It seems like the install-file procedures would not apply here.
> >
> > However, I tried building it from the patch and the install phase
> > does
> > fail there.
>
> Did you build it after applying the previous 2 patches?
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=40466 and
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=40467
>
> This is supposed to be merged after those changes. The first patch
> (40466) changes the install procedure in dragonfly-reverb, which is
> inherited here.

Ah, no, I didn't realize they were related.

It's annoyingly tricky, but patches that depend on each should be in the
same bug ticket. This can be accomplished by first sending an intro
message to get a bug number, then sending the patch series to e.g.
<NNN@debbugs.gnu.org>.

I'll merge them now.
L
L
Leo Famulari wrote on 7 Apr 2020 22:09
(no subject)
(address . control@debbugs.gnu.org)
20200407200941.GA26185@jasmine.lan
merge 40466 40467 40468
A
A
Alexandros Theodotou wrote on 7 Apr 2020 22:14
Re: [bug#40468] [PATCH 3/3] gnu: Add shiru-lv2.
(name . Leo Famulari)(address . leo@famulari.name)(address . 40468@debbugs.gnu.org)
250a18c24170d892e92560d378127a9d06a947ea.camel@zrythm.org
Toggle quote (8 lines)
> It's annoyingly tricky, but patches that depend on each should be in
> the
> same bug ticket. This can be accomplished by first sending an intro
> message to get a bug number, then sending the patch series to e.g.
> <NNN@debbugs.gnu.org>.
>
> I'll merge them now.

Ah okay, thank you for letting me know. I'll send such patches in the
same ticket from now on.

Thanks,
Alex
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6M3y8ACgkQAi6uQjE9
cPMv/Qf+LHLJ5fR2ta79aqEAYzRyMAtF/z75PhLI08vII3TVB6mP/SAJ/YjH6fZ8
8W78TLC0rhP4rj847C6Wux5nyZRot8EC+4kxPTRbQWIP71eBDGaiGiqTxVgwsAe0
2/9btgIW9EvLvuVfdznWu/xYwy6oh0WbjNAlGasrPae5amEZAtppQMyr82GIVk7o
f/Mcnjt3jV/8tWcWSlFzXdcw+jC0tAIO285BQcepYG89yMRGjAx8Ra8CXR72b3Es
HhbcbCYPV4V3jodx1vIPvU9S6xc7oPxyGAAG5MqA1NPQKAVlmU5+qhwivY2z1B2H
1dOh7X8Uz5XknE0Btva+XGLfjXvqVQ==
=VE8u
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 8 Apr 2020 17:41
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40468@debbugs.gnu.org)
20200408154155.GA26684@jasmine.lan
On Tue, Apr 07, 2020 at 09:04:40PM +0100, Alexandros Theodotou wrote:
Toggle quote (4 lines)
> This is supposed to be merged after those changes. The first patch
> (40466) changes the install procedure in dragonfly-reverb, which is
> inherited here.

In general, I think that using syntactic inheritance to factorize build
phases is not the right way to go here. It can cause a big headache
later when the time comes to adjust things, and it removes the
advantages of Guix tools such as `guix graph` and `guix refresh`.

I think the better options are to create a new lv2-build-system that
inherits from gnu-build-system and replaces the install phase, or to
just copy and paste the code around. It depends on how many of these
packages we plan to add.

Let me know if you need help with any of that! The font-build-system is
a concise example of making a new build system based on the
gnu-build-system.
A
A
Alexandros Theodotou wrote on 8 Apr 2020 17:58
(name . Leo Famulari)(address . leo@famulari.name)(address . 40468@debbugs.gnu.org)
cdcb951d914a8ca4590a76e00da98050cb3ac6e9.camel@zrythm.org
I'd say the eventual amount of packages that would use such a build
system are between 5-10. Should I go ahead and make a dpf-build-system
or do you think we should just copy the code around since it's not that
many packages?

By the way, we used inheritance in the case of other packages such as
gx-* and vl1-emulator/regrader/fogpad, although those are from the same
upstream so maybe it's reasonable there.

On Wed, 2020-04-08 at 11:41 -0400, Leo Famulari wrote:
Toggle quote (20 lines)
> On Tue, Apr 07, 2020 at 09:04:40PM +0100, Alexandros Theodotou wrote:
> > This is supposed to be merged after those changes. The first patch
> > (40466) changes the install procedure in dragonfly-reverb, which is
> > inherited here.
>
> In general, I think that using syntactic inheritance to factorize
> build
> phases is not the right way to go here. It can cause a big headache
> later when the time comes to adjust things, and it removes the
> advantages of Guix tools such as `guix graph` and `guix refresh`.
>
> I think the better options are to create a new lv2-build-system that
> inherits from gnu-build-system and replaces the install phase, or to
> just copy and paste the code around. It depends on how many of these
> packages we plan to add.
>
> Let me know if you need help with any of that! The font-build-system
> is
> a concise example of making a new build system based on the
> gnu-build-system.
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6N9KMACgkQAi6uQjE9
cPOZBAgAth+9D5/B1oxdLCtMwCEG1S5es2JAeUU6N3bbDExiicovn1KeRZOXUAnr
jA5L0GjEbrRqd7/sGwS/mMQNZ79kR2S/aKMLJl97VDzw4msPibMt4TgRB0ILFBCP
ZwSyC1z4TilmlW3Zq+7GP8UnaHSe1SKCDIH5cQlhw0jmJ7GY2k30z4ZAVuYIgWzT
omwlCeWXB49NcuCibesDQHefhldsxiEVfhOeRggu9qT2fbWhK5TOZZozc+UfGld6
6rGRtRDS8RzH8XOt6oQpJjW0JkQB+GZEJl+cZn0zYIJsXnkSRDwSiWDb0eZrK/ho
5pfmfeqoMj33Wu1uZuElBWmiTNedvA==
=mq8g
-----END PGP SIGNATURE-----


A
A
Alexandros Theodotou wrote on 8 Apr 2020 18:34
(name . Leo Famulari)(address . leo@famulari.name)(address . 40468@debbugs.gnu.org)
435280caeb13a5a41edd3b007edea6eaa54a1e75.camel@zrythm.org
I went ahead and removed the inheritance for now and copied the
procedure. I guess we can see in the future if it's necessary to add a
build system or not.

Patch attached.

Thanks,
Alex
From 9f9638c67f97546e1077c34006079e09c9823618 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Apr 2020 17:03:18 +0100
Subject: [PATCH] gnu: Add shiru-lv2.

* gnu/packages/music.scm (shiru-lv2): New variable.
---
gnu/packages/music.scm | 63 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 63 insertions(+)

Toggle diff (73 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e2a3d84572..09ce5da4d3 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5387,3 +5387,66 @@ filtered, pitch shifted and ultimately disintegrated. This is an unofficial
port of the Regrader plugin created by Igorski. It is available as an LV2
plugin and a standalone JACK application.")
(license license:expat)))
+
+(define-public shiru-lv2
+ (let ((commit "08853f99140012234649e67e5647906fda74f6cc")
+ (revision "1"))
+ (package
+ (name "shiru-lv2")
+ (version (git-version "0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/linuxmao-org/shiru-plugins.git")
+ (commit commit)
+ ;; Bundles a specific commit of the DISTRHO plugin framework.
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00rf6im3rhg98h60sgl1r2s37za5vr5h14pybwi07h8zbc8mi6fm"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:make-flags (list "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ;no configure target
+ (replace 'install ;no install target
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (lv2 (string-append out "/lib/lv2")))
+ ;; Install LV2.
+ (for-each
+ (lambda (file)
+ (copy-recursively file
+ (string-append lv2 "/" (basename file))))
+ (find-files "bin" "\\.lv2$" #:directories? #t))
+ ;; Install executables.
+ (for-each
+ (lambda (file)
+ (install-file file bin))
+ (find-files "bin"
+ (lambda (name stat)
+ (and
+ (equal? (dirname name) "bin")
+ (not (string-suffix? ".so" name))
+ (not (string-suffix? ".lv2" name))))))
+ #t))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("cairo", cairo)
+ ("glu", glu)
+ ("jack", jack-1)
+ ("lv2", lv2)
+ ("mesa", mesa)
+ ("pango", pango)))
+ (synopsis "Audio plugin collection")
+ (description "Shiru plugins is a collection of audio plugins created
+ by Shiru, ported to LV2 by the Linux MAO project using the DISTRHO plugin
+ framework.")
+ (home-page "http://shiru.untergrund.net/software.shtml")
+ (license license:wtfpl2))))
--
2.26.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6N/P4ACgkQAi6uQjE9
cPOtyQf/Wovhd0TTEgX/V4WKRJhFk77q7RGmbk1plFAc/qnEr1VQ4X0LJ6l2Rtgt
XI7ES6ciIUZ8hgyPkWR4rK37EZXlX61KHhn1/xj5vOMEaipmqkkck1xfXBcy50LS
cN69iEzlQdiiCSL9Cpty6lBNuwQJmCUpUD+pbkhsO3ThJV8He5FW5XXdr4Qw6m7v
16tGuliT0oQXA4pd5uCnq3wKLm2rvQPDaLYiPVU0WtcxPUzLDXWguXo3+ug4pVIq
KgNIrfPMlvM9Lcb6o1Mk5NzgOiinTOv3bvG05J+XPclR0rro8upay0uOvpthfrmn
AxC4DHC7GvFuqOACF8xST2efW3JPFg==
=6UPe
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 29 May 2020 03:41
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40468-done@debbugs.gnu.org)
20200529014114.GI5443@jasmine.lan
On Wed, Apr 08, 2020 at 05:34:06PM +0100, Alexandros Theodotou wrote:
Toggle quote (2 lines)
> * gnu/packages/music.scm (shiru-lv2): New variable.

Thank you! And sorry for the delay...

Pushed as d870fcfb099cf5b0ad25220e1fa36162cc3284a5
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAl7QaDoACgkQJkb6MLrK
fwhw9Q//YbldQ2YeVcqCS4uJkI5h9xPhBEc+ehnWiz0173YHcmMzYQh1+bfH6hm7
MJwelSlhmQopa7fUyp6VHjNQHVuL8ooQiVadte2Z4QCLnDkvRG8N6I6f6V4yUgK1
RaXVCw7d/KJcyeynJDKtlPgkdilvziANJ55dvxs2slW2iUn99W7C/UoX0KOAAxkb
lTZJ1a8JlaWI+e6qgiOPb6EU6J3bQVV/KM9aBX1C6k4zsTtTJGYxHtKNimKcx9Xk
Obv8nf6WuHCZ6nxkPzhs0U1nK6+cqFGaFft1SUWe2ezUe4RYTY9U6PZoDIUplUkY
5viBjP7uvZzItm5MwoEcKBcsZBtwycfYO5kMRNpcf/hP08aLEm0QlYYlEm+dlxNF
C43gjUnzOFIb60Wb3AqYsLG2fvYCyDEUsFFAdeLEVoyg7bDWzcM58ZEdfoQEmZVT
bR0Z3BqPLi4FWE4dlSO2Fp/LnGk1xPcEDsuXPwuD9YJVsLBy5610eImfunAC4luw
SdBRQLbBrGn6tGaHLfgjIYGRWiINgbAv44q7bXBPPrEbOeYEj7c3xOp4qQbYKcni
WzbdpcuihhUe1ohmycRC6lvVUjCN4l+0m0b94hasSpv3/783JnxhDsbGwBIDArv4
KTu4KOpiHQ5sXtBSBRrqySA+ldP3RjMCoJBW4uPhe7RWhxyszxc=
=kTtM
-----END PGP SIGNATURE-----


Closed
?