[PATCH] gnu: python-intervaltree: Update to 3.0.2.

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Jakub K?dzio?ka
  • Marius Bakke
Owner
unassigned
Submitted by
Jakub K?dzio?ka
Severity
normal
J
J
Jakub K?dzio?ka wrote on 28 Mar 2020 00:51
(address . guix-patches@gnu.org)(address . rekado@elephly.net)
20200327235125.3250-1-kuba@kadziolka.net
* gnu/packages/bioinformatics.scm (python-intervaltree): Update to 3.0.2.
[arguments]: Don't skip the tests.
---

It turns out I need python-intervaltree 3.0 as a dependency for one of
the packages I'm working on.

Cc: Ricardo - you added python-pygenometracks, the only dependent. Could
you re-test it, just in case?

gnu/packages/bioinformatics.scm | 14 ++++++++++----
1 file changed, 10 insertions(+), 4 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index da3fe1d2c9..a8e4c830ae 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -13548,17 +13549,22 @@ allowing the insertion of arbitrary types into the tree.")
(define-public python-intervaltree
(package
(name "python-intervaltree")
- (version "2.1.0")
+ (version "3.0.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "intervaltree" version))
(sha256
(base32
- "02w191m9zxkcjqr1kv2slxvhymwhj3jnsyy3a28b837pi15q19dc"))))
+ "0wz234g6irlm4hivs2qzmnywk0ss06ckagwh15nflkyb3p462kyb"))))
(build-system python-build-system)
- ;; FIXME: error when collecting tests
- (arguments '(#:tests? #f))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'import-mismatch-error-workaround
+ (lambda _
+ (setenv "PY_IGNORE_IMPORTMISMATCH" "1")
+ #t)))))
(propagated-inputs
`(("python-sortedcontainers" ,python-sortedcontainers)))
(native-inputs
--
2.26.0
M
M
Marius Bakke wrote on 31 Mar 2020 16:58
(address . rekado@elephly.net)
87sghotvto.fsf@devup.no
Jakub K?dzio?ka <kuba@kadziolka.net> writes:

Toggle quote (8 lines)
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (add-before 'check 'import-mismatch-error-workaround
> + (lambda _
> + (setenv "PY_IGNORE_IMPORTMISMATCH" "1")
> + #t)))))

Can you add a comment about what this does?

Also, I guess this package should be moved out of bioinformatics.scm,
assuming the software you are packaging is not bioinfo-related?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6DWqMACgkQoqBt8qM6
VPoRRgf/R7/qeNNmlOMyu2xQObUyDsibHUdYoXSiAxjenDvzCZJXQVSHaWztlZ8G
aXBp7vXgZ+U/gcvN/yOPDTfHsS0a962wjkR7g2oLsU6OS95CtzvJdipxrAQ3GkgU
KrIgCZrMUOMlf95id9kUvcyi6EB8RjkvqoWV2SMqYkEB2RNGdyBGw9NL+SrIkzq8
F32AiCiF2ygUS35ydNVqVgARceXnRR60lNayzU5le6nbMBupWgCoGNSCQTQycOZ7
8pM2I5Yq/+1Hl4F/UZU3S1LAS3xfG4+2WCHKXNU4VOhFKavnXaQ2l42XepfNQ2Vo
Wi1rFzyrMxwNV1Oml9gUpuOuMK6S1w==
=KOeR
-----END PGP SIGNATURE-----

E
E
Efraim Flashner wrote on 1 Apr 2020 07:47
(name . Marius Bakke)(address . mbakke@fastmail.com)
20200401054751.GM5436@E5400
On Tue, Mar 31, 2020 at 04:58:43PM +0200, Marius Bakke wrote:
Toggle quote (12 lines)
> Jakub K?dzio?ka <kuba@kadziolka.net> writes:
>
> > + (arguments
> > + `(#:phases
> > + (modify-phases %standard-phases
> > + (add-before 'check 'import-mismatch-error-workaround
> > + (lambda _
> > + (setenv "PY_IGNORE_IMPORTMISMATCH" "1")
> > + #t)))))
>
> Can you add a comment about what this does?

It seems to me there is some import mismatch and this is a workaround
for it. I assume it's related to deprecated python naming/modules and
may break on a python upgrade. IMO the phase name is descriptive enough,
and I assume if we were to remove it then it'd make a lot more sense
after seeing the error message.

Toggle quote (6 lines)
>
> Also, I guess this package should be moved out of bioinformatics.scm,
> assuming the software you are packaging is not bioinfo-related?



--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl6EKwEACgkQQarn3Mo9
g1HXAA/+OPnyhksaNvO3CkFnIFojcaAxXZHMjfYwdgDLhKVpguQufIXFvcXfC9Z0
e7DkO0VX1zk3GJx8bIkWmXQIl/EzSZdQ47kTzUGj88Y6vjKW9qF2/NgFi9aAKVgd
ftoMnDfcE0JCMrjb8XZ/ux/G9jmfBf6QHl15jk3rQS3FtlYT4wB6IidOHC3fPBec
xmmi8k5IfAYIooh1qybRPi/S6GacBNE0mr1oNzHXrPivdIHkEBbUl//CSg3GwVL4
BRhv0v63dsq5RBWW4SggXaHk5b4K3ql8qVhKzwrsYESxj3nrPkFgj8Qc22WMrAEN
/H1rFdwCkY6KUWA/hZzuu4SK7dspV5ylcJkT/ec0ec7nzZttVeehpMb0xq5+m8Gw
M9XdpbW3aRyDlLOO38ZUOX3cJ8j1WBF6XKfB664FPyXX7iCgSpF3ILcOoiYNcJ1n
+3mWBusXulbNXsW0C6azIEfwZzYw63vrFCJRlgz0XTtSYawL2Wwyq/ieuELWAwPW
B8zF3eWI63NYEMXE2YP8PCoME0fvsgYWW9xMUJbUkhS4PwIRCF4uAt//Y6PET62V
AcL8kRm5xSGwrM2vPWse3iJZIfH0vj+js7uZTb9/l5gDfqpVCo+d1aiAmnyqAgW6
qg9MoCBv6mxJNM8i8GeDD+jGOfHI7Q3PQQNWu0h5/ALmVB+5PgI=
=HuKO
-----END PGP SIGNATURE-----


J
J
Jakub K?dzio?ka wrote on 1 Apr 2020 16:24
[PATCH v2] gnu: python-intervaltree: Update to 3.0.2.
(address . 40265@debbugs.gnu.org)
20200401142448.2683-1-kuba@kadziolka.net
* gnu/packages/bioinformatics.scm (python-intervaltree): Update to 3.0.2.
[arguments]: Don't skip the tests, work around the problematic
sanity-check instead.
---
Thanks for your helpful comments. I have added a comment, which, in
hindsight, should've been there in the first place :D

I will defer moving the package until committing the new dependent
(pwntools, #40265), as this is best done in a separate commit anyway.

gnu/packages/bioinformatics.scm | 19 +++++++++++++++----
1 file changed, 15 insertions(+), 4 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d69c2aea63..943369b275 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -13552,17 +13553,27 @@ allowing the insertion of arbitrary types into the tree.")
(define-public python-intervaltree
(package
(name "python-intervaltree")
- (version "2.1.0")
+ (version "3.0.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "intervaltree" version))
(sha256
(base32
- "02w191m9zxkcjqr1kv2slxvhymwhj3jnsyy3a28b837pi15q19dc"))))
+ "0wz234g6irlm4hivs2qzmnywk0ss06ckagwh15nflkyb3p462kyb"))))
(build-system python-build-system)
- ;; FIXME: error when collecting tests
- (arguments '(#:tests? #f))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; pytest seems to have a check to make sure the user is testing
+ ;; their checked-out code and not an installed, potentially
+ ;; out-of-date copy. This is harmless here, since we just installed
+ ;; the package, so we disable the check to avoid skipping tests
+ ;; entirely.
+ (add-before 'check 'import-mismatch-error-workaround
+ (lambda _
+ (setenv "PY_IGNORE_IMPORTMISMATCH" "1")
+ #t)))))
(propagated-inputs
`(("python-sortedcontainers" ,python-sortedcontainers)))
(native-inputs
--
2.26.0
M
M
Marius Bakke wrote on 2 Apr 2020 17:54
(address . efraim@flashner.co.il)
87lfndsx21.fsf@devup.no
Jakub K?dzio?ka <kuba@kadziolka.net> writes:

Toggle quote (4 lines)
> * gnu/packages/bioinformatics.scm (python-intervaltree): Update to 3.0.2.
> [arguments]: Don't skip the tests, work around the problematic
> sanity-check instead.

LGTM.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6GCqYACgkQoqBt8qM6
VPodTwf9G3ezUIP3hIrac5gzucaBL3fmQhJaI2EFVUUZqFAOJsdgi8vv7U8jg187
XmppKdAmY0tgq0UA0QrF7H/MdSvfZ+vkyfwpbE+j2jxwVJ/1W+GkioCOllJsC7SZ
dpGvoWYiCmj8sYvm3ATsSMExbM1QnDQ1wKY4Ab4wfMBTf3hehnG7pXHLk0Gu7ABH
XLihER00Kho6mmn788urX5P0eyZZTXihKD/Gzityb+oBqZfW4LgnCTe++qwaTeZO
wSPYj2urnFIrcMg9bqf3fgERikZhvNZmDKj4J8sl3rGbqH4ESXkef89/31m+aWQl
1SUJhaXhvB16i86zYF5pprYViuwgBw==
=AMEm
-----END PGP SIGNATURE-----

J
J
Jakub K?dzio?ka wrote on 5 Apr 2020 20:44
(name . Marius Bakke)(address . mbakke@fastmail.com)
20200405184448.ek2qernpt6ixbfj4@gravity
On Thu, Apr 02, 2020 at 05:54:14PM +0200, Marius Bakke wrote:
Toggle quote (8 lines)
> Jakub K?dzio?ka <kuba@kadziolka.net> writes:
>
> > * gnu/packages/bioinformatics.scm (python-intervaltree): Update to 3.0.2.
> > [arguments]: Don't skip the tests, work around the problematic
> > sanity-check instead.
>
> LGTM.

Thanks! Pushed as 7fe746e071e3177e76dad9e2bcd1d53e87187f1a.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl6KJyAACgkQ4xWnWEYT
FWSoMg/+OZOzRPzx2LqNIm6uOr0H0ZUx0mWTKUpVG+ucb9i11+0XCs8mjiDaAGP+
Ke+qgcYze6NcL4hj+yRODlxBMeJi8K4jL1KZ+ZfFWJscq2EcZ1Pt8cHoJ7PcYLpV
IVMZwDh26H4l5WPLqbgCXwPbRmHZv9MRr8u+2mCVxPkb8omJHW+JldiBsYT3qs/f
aCjTqi6j9nszgEmYoe7WfvrEyvxKr2ecAFkH9JJbcC0m8GnArle1WR3e89sG/TEO
1Mn+11n6TETHpkMXTQ1sB71xiVUixw0QAr0hI1oBCGsF0eIjiORRppuuew+XXaXq
TcoKQicZVtFsYTMLb1/Mw5uYm/9LxHpkBjTvnQEyvYOsmjDhMdS6mTeo3C/c+FuJ
9yytUItBk+5ar0JV4Z6eH5LOweMmIxFQ06Z8PQYsFLyr0EDEIf5wiR3Jb896ebmk
Y67UDl04xwvETseNBWHUVB0cn3Eklrl6SJMunO9H1NlxPV5yk5D+r9LAK7wMdR+L
lqAQ/TY3gqBo5ryJ+ir56uqDxZNBDeD0LKcvgDTcmMZTlpMickvQed2b/7ewF2Hh
k0wRxMLRUiyMYXCji4ODcEaxHHl+ABQkIMLOlz9JS8iqenfjiytH5SUtDDVaTZ45
tQ00IZKne/M5PwEC64MDuVSrpe1/ZiSXZTEqEK2XoE6VU7jP8qY=
=QxZj
-----END PGP SIGNATURE-----


Closed
?