[PATCH] gnu: clipmenu: Update to 6.0.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Damien Cassou
  • Marius Bakke
Owner
unassigned
Submitted by
Damien Cassou
Severity
normal
D
D
Damien Cassou wrote on 25 Mar 2020 21:38
(address . guix-patches@gnu.org)
875zesuq3r.fsf@cassou.me
* gnu/packages/xdisorg.scm (clipmenu): Update to 6.0.1.

--
Damien Cassou

"Success is the ability to go from one failure to another without
losing enthusiasm." --Winston Churchill
From c42b50c699610c2a8aa311369f34695abb8c0578 Mon Sep 17 00:00:00 2001
From: Damien Cassou <damien@cassou.me>
Date: Wed, 25 Mar 2020 21:37:15 +0100
Subject: [PATCH] gnu: clipmenu: Update to 6.0.1.

* gnu/packages/xdisorg.scm (clipmenu): Update to 6.0.1.
---
gnu/packages/xdisorg.scm | 22 +++++++---------------
1 file changed, 7 insertions(+), 15 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index facd63ab53..f09e4d52bc 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -2169,22 +2169,14 @@ (define-public clipnotify
(license license:public-domain)))
(define-public clipmenu
- (let ((commit "a495bcc7a4ab125182a661c5808364f66938a87c")
- (revision "1"))
(package
(name "clipmenu")
- (version (string-append "5.6.0-"
- revision "." (string-take commit 7)))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/cdown/clipnotify.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "12vvircdhl4psqi51cnfd6bqy85v2vwfcmdq1mimjgng727nwzys"))))
+ (version "6.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/cdown/clipmenu/archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256 (base32 "1wcvpz8wd369px8j8bgy21yqmb4h8zvya4k7qp8hvy27ac13z6h1"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -2248,4 +2240,4 @@ (define-public clipmenu
to find all available clips and launches @command{dmenu} (or @command{rofi},
depending on the value of @code{CM_LAUNCHER}) to let the user select a clip.
After selection, the clip is put onto the PRIMARY and CLIPBOARD X selections.")
- (license license:public-domain))))
+ (license license:public-domain)))
--
2.25.1
D
D
Damien Cassou wrote on 25 Mar 2020 21:57
Re: bug#40229: Acknowledgement ([PATCH] gnu: clipmenu: Update to 6.0.1.)
(address . 40229@debbugs.gnu.org)
87369wup7s.fsf@cassou.me
Same patch but with indentation fixed, sorry.

--
Damien Cassou

"Success is the ability to go from one failure to another without
losing enthusiasm." --Winston Churchill
M
M
Marius Bakke wrote on 29 Mar 2020 22:17
Re: [bug#40229] Acknowledgement ([PATCH] gnu: clipmenu: Update to 6.0.1.)
874ku6x6eq.fsf@devup.no
Damien Cassou <damien@cassou.me> writes:

Toggle quote (2 lines)
> Same patch but with indentation fixed, sorry.

Thanks! Can you submit the indentation change as a separate commit?

[...]

Toggle quote (2 lines)
> * gnu/packages/xdisorg.scm (clipmenu): Update to 6.0.1.

[...]
Toggle quote (7 lines)
> + (package
> + (name "clipmenu")
> + (version "6.0.1")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/cdown/clipmenu/archive/" version ".tar.gz"))

The GitHub /archive/ URL's are not stable: the tarballs they generate
may get regenerated in the future with different timestamps and break
the checksum. So please continue using git-fetch here.

Can you send an updated patch? TIA!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6BAk0ACgkQoqBt8qM6
VPqgcQf/Q41N4UMX7EYlU8Oms/r4GntSAO9vZFVwz8vII+rL6PbzS79YtuHAgXxs
ViE3EXY9z82UpWKG7ID9KkF4wrm+g6mB/wlbjZYsuEsOtPIpYMTkOe3AasKZDXAp
2m3Uktxdaih0PLVVu6onp4tbr/AciYcbdhYgQt5V7Q03/J1SZdILSQPVobEKxCfS
0K4viMoUpNOoC47tkSnYnjXIk/+6UdZgGNNhoJvLOOdCOtkbdQfx9GWfXRnQC/uU
opb0M+e1oa7C0g15ACy/WiMJHgkubo57HhNGXOIa3I68n6vLmwjz+vOwZcUxST1R
CTjqeowKFJECJMH//vw39GP+9e6vQw==
=GFqF
-----END PGP SIGNATURE-----

D
D
Damien Cassou wrote on 30 Mar 2020 15:50
87ftdqc5pn.fsf@cassou.me
Marius Bakke <mbakke@fastmail.com> writes:
Toggle quote (3 lines)
> Thanks! Can you submit the indentation change as a separate commit?


changing indentation was only necessary because of the switch to the
tarball. It's not necessary anymore.

Toggle quote (6 lines)
> The GitHub /archive/ URL's are not stable: the tarballs they generate
> may get regenerated in the future with different timestamps and break
> the checksum. So please continue using git-fetch here.
>
> Can you send an updated patch? TIA!

here it is.

--
Damien Cassou

"Success is the ability to go from one failure to another without
losing enthusiasm." --Winston Churchill
From 67876912ccc40dcbe539e0a1e8523d021a1e4b5c Mon Sep 17 00:00:00 2001
From: Damien Cassou <damien@cassou.me>
Date: Mon, 30 Mar 2020 13:59:34 +0200
Subject: [PATCH] gnu: clipnotify: Update to 6.0.1.

* gnu/packages/xdisorg.scm (clipnotify): Update to 6.0.1.
---
gnu/packages/xdisorg.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 22c8adc6fa..9335b48976 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -2169,17 +2169,17 @@ (define-public clipnotify
(license license:public-domain)))
(define-public clipmenu
- (let ((commit "a495bcc7a4ab125182a661c5808364f66938a87c")
+ (let ((commit "bcbe7b144598db4a103f14e8408c4b7327d6d5e1")
(revision "1"))
(package
(name "clipmenu")
- (version (string-append "5.6.0-"
+ (version (string-append "6.0.1-"
revision "." (string-take commit 7)))
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/cdown/clipnotify.git")
+ (url "https://github.com/cdown/clipmenu.git")
(commit commit)))
(file-name (git-file-name name version))
(sha256
--
2.25.1
M
M
Marius Bakke wrote on 3 Apr 2020 15:32
87tv20pudu.fsf@devup.no
Damien Cassou <damien@cassou.me> writes:

Toggle quote (8 lines)
>> The GitHub /archive/ URL's are not stable: the tarballs they generate
>> may get regenerated in the future with different timestamps and break
>> the checksum. So please continue using git-fetch here.
>>
>> Can you send an updated patch? TIA!
>
> here it is.

Pushed in 1ace39da78dc076f60542ad7729a29f2f6760076, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl6HOu0ACgkQoqBt8qM6
VPo/qQgAkATVJddyw+u45N5RFsQaFMXVbSOmbIkBUt26NCiprrS9vwFCGkigIuhM
WigYNtBdwMubX+NjY+GXoOT0S6pNydgruN0dAP6Vi3MT6+VMY1/glNFVNzfHI7WN
/ugkxbJlGSo/2MIiN+4oUFnS+2p6jNgeb9LlhAwjFzTvAfYE6aTFOwRIotM0a0k5
CI1Qbs7JZVLJBZB0temoqMR/Vj5seGTamrxLdj0h+Vj9eGX1afzlW4b/sGVeFJqB
BlLAkDeJ37hji9wNl/j7Y1zvl6uL+gQlMSgpBRQV7SMsy+Gex10UBNJLQQVodgiu
Yl0RFOtUOx7YRdXyTiuSQtS7YFyhaw==
=VVsq
-----END PGP SIGNATURE-----

Closed
?