[PATCH 1/2] gnu: icestorm: Update to latest revision.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • pinoaffe
Owner
unassigned
Submitted by
pinoaffe
Severity
normal
P
P
pinoaffe wrote on 22 Mar 2020 11:38
(address . guix-patches@gnu.org)
2c193888d4d7e49146436ad5981174a8@airmail.cc
* gnu/packages/fpga.scm (icestorm): Update to latest revision.
---
gnu/packages/fpga.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index dca67ad3ca..5cfc9a96f6 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -212,8 +212,8 @@ For synthesis, the compiler generates netlists in
the desired format.")
(license license:isc)))

(define-public icestorm
- (let ((commit "c0cbae88ab47a3879aacf80d53b6a85710682a6b")
- (revision "2"))
+ (let ((commit "0ec00d892a91cc68e45479b46161f649caea2933")
+ (revision "3"))
(package
(name "icestorm")
(version (git-version "0.0" revision commit))
@@ -225,7 +225,7 @@ For synthesis, the compiler generates netlists in
the desired format.")
(file-name (git-file-name name version))
(sha256
(base32
-
"0bqm0rpywm64yvbq75klpyzb1g9sdsp1kvdlyqg4hvm8jw9w8lya"))))
+
"1qlh99fafb7xga702k64fmc9m700nsddrfgcq4x8qn8fplsb64f1"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no unit tests that don't need an FPGA exist.
--
2.25.1
P
P
pinoaffe wrote on 22 Mar 2020 11:47
[PATCH 2/2] gnu: Add nextpnr-ice40
(address . 40182@debbugs.gnu.org)
55875bc483352f8105513ac5006c0666@airmail.cc
* gnu/packages/fpga.scm (nextpnr-ice40): New variable.
---
gnu/packages/fpga.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 5cfc9a96f6..8f34ef8282 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -44,6 +44,9 @@
#:use-module (gnu packages gperf)
#:use-module (gnu packages gawk)
#:use-module (gnu packages version-control)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages boost)
+ #:use-module (gnu packages algebra)
#:use-module (gnu packages libftdi))

(define-public abc
@@ -256,6 +259,41 @@ For synthesis, the compiler generates netlists in
the desired format.")
Includes the actual FTDI connector.")
(license license:isc))))

+(define-public nextpnr-ice40
+ (let [(commit "c192ba261d77ad7f0a744fb90b01e4a5b63938c4")
+ (revision "0")]
+ (package
+ (name "nextpnr-ice40")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://github.com/YosysHQ/nextpnr")
+ (commit commit)))
+ (sha256
+ (base32
+ "0g2ar1z89b31qw5vgqj2rrcv9rzncs94184dgcsrz19p866654mf"))))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("boost" ,boost-with-python3)
+ ("yosys" ,yosys)
+ ("eigen" ,eigen)
+ ("python" ,python)
+ ("icestorm" ,icestorm)))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags `("-DARCH=ice40"
+ ,(string-append "-DICEBOX_ROOT="
+ (assoc-ref %build-inputs
"icestorm")
+ "/share/icebox"))
+ #:tests? #f))
+ (synopsis "Place-and-Route tool for FPGAs")
+ (description "nextpnr aims to be a vendor neutral, timing driven,
+FOSS FPGA place and route tool. ")
+ (home-page "https://github.com/YosysHQ/nextpnr")
+ (license license:expat))))
+
(define-public arachne-pnr
(let ((commit "840bdfdeb38809f9f6af4d89dd7b22959b176fdd")
(revision "2"))
--
2.25.1
D
D
Danny Milosavljevic wrote on 22 Mar 2020 16:00
Re: [bug#40182] [PATCH 1/2] gnu: icestorm: Update to latest revision.
(address . pinoaffe@airmail.cc)(address . 40182-done@debbugs.gnu.org)
20200322160020.57a21c30@scratchpost.org
Hi!

Thanks for the patches!

Pushed both to guix master, as commits 179be4bbe488d6c18d482da69b4997f7682d5a58
and 363989e6689068daeca81b442358b183b7d983d1, respectively.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl53fYQACgkQ5xo1VCww
uqU8+wf9HsNYeoF7iiWwTDfnZu004+cGIWOQQqVE5iCFHYeG1de4V8jOzY19xG3v
atGvDb8SJSyTQqJ+/PGxY5x2+XWOoiu84XX6SuqQvGGdj1MaCLfFAvGmd8xbEZCD
cN8k1KkX+/Ou+1BadxCtJhinhFa1CWdhz6SXAXtMCnD1uCH0BayKy0bHBhGpFDDn
RCh0rFg7+7y+15FWKoUFbIH6C6cCYy3MIvsyzuYKrQUQUWHW+bAPVB0VZvivS09M
0WYjbMssKxp5L76Lj5YPYZy38w/22oA8xHnvhvH1RA40EVVJIktVCkvmyCKF7OA6
gs0dYsV/OPXEuvzBE2OTvgaBLe6+3Q==
=AQqX
-----END PGP SIGNATURE-----


Closed
?