[PATCH] Add Pyzo

  • Done
  • quality assurance status badge
Details
One participant
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Nicolas Goaziou
Severity
normal
N
N
Nicolas Goaziou wrote on 21 Mar 2020 21:44
(address . guix-patches@gnu.org)
8736a18mkq.fsf@nicolasgoaziou.fr
Hello,

The following patch adds Pyzo, a Python IDE.

Feedback welcome.

Regards,

--
Nicolas Goaziou
From b1946b7d23b99f89550ef35173f51c76a51038b4 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Sat, 21 Mar 2020 19:13:07 +0100
Subject: [PATCH] gnu: Add pyzo.

* gnu/packages/python-xyz.scm (pyzo): New variable.
---
gnu/packages/python-xyz.scm | 39 +++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d0da9b36c3..09a1a5534d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18358,3 +18358,42 @@ sequences.")
(define-public python2-fuzzywuzzy
(package-with-python2 python-fuzzywuzzy))
+
+(define-public pyzo
+ (package
+ (name "pyzo")
+ (version "4.10.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyzo" version))
+ (sha256
+ (base32 "1zplxcb78qy8qibifmnsx5i9gnlfmw9n6nr4yflsabpxw57mx4m1"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'fix-home-directory
+ (lambda _
+ ;; Tests fail with "Permission denied:
+ ;; '/homeless-shelter'".
+ (setenv "HOME" "/tmp")
+ #t)))
+ ;; Tests fail with "Uncaught Python exception: invalid literal
+ ;; for int() with base 10: 'test'".
+ #:tests? #f))
+ (propagated-inputs
+ `(("python-pyqt" ,python-pyqt)))
+ (home-page "https://pyzo.org")
+ (synopsis
+ "Python IDE for scientific computing")
+ (description
+ "Pyzo is a Python IDE focused on interactivity and introspection,
+which makes it very suitable for scientific computing. Its practical
+design is aimed at simplicity and efficiency.
+
+It consists of two main components, the editor and the shell, and uses
+a set of pluggable tools to help the programmer in various ways. Some
+example tools are source structure, project manager, interactive help,
+workspace...")
+ (license license:bsd-2)))
--
2.25.1
N
N
Nicolas Goaziou wrote on 23 Apr 2020 01:15
(address . 40177-done@debbugs.gnu.org)
87blnjkt7m.fsf@nicolasgoaziou.fr
Toggle quote (2 lines)
> The following patch adds Pyzo, a Python IDE.

Applied. Closing.
Closed
?