[PATCH] gnu: Add emacs-objed.

  • Done
  • quality assurance status badge
Details
2 participants
  • 6033fe7de85d
  • Mathieu Othacehe
Owner
unassigned
Submitted by
6033fe7de85d
Severity
normal
6
6
6033fe7de85d wrote on 18 Mar 2020 18:01
(address . guix-patches@gnu.org)
20200318170125.23894-1-6033fe7de85d@airmail.cc
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 298cfb23b0..b5e1e2d122 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -64,6 +64,7 @@
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21832,3 +21833,27 @@ a @samp{date} keywords, and optionally, a @samp{filetags} keyword.")
"Daredevil SKK is a version of @acronym{SKK, Simple Kana to Kanji
conversion program}, a Japanese input method on Emacs.")
(license license:gpl2+))))
+
+(define-public emacs-objed
+ (package
+ (name "emacs-objed")
+ (version "0.8.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://elpa.gnu.org/packages/objed-"
+ version
+ ".tar"))
+ (sha256
+ (base32
+ "1s38d6bvggdk5p45ww1jb4gxifzgjwgw1m6ar920nlg0j4fgbcvr"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/clemera/objed")
+ (synopsis "Navigate and edit text objects")
+ (description
+ "A global minor-mode to navigate and edit text objects. Objed enables modal
+editing and composition of commands, too. It combines ideas of other
+Editors like Vim or Kakoune and tries to align them with regular Emacs
+conventions.")
+ (license license:gpl3+)))
--
2.25.1
6
6
6033fe7de85d wrote on 18 Mar 2020 18:56
(address . 40122@debbugs.gnu.org)
20200318175633.5393-1-6033fe7de85d@airmail.cc
*gnu/packages/emacs-xyz.scm (emacs-objed): New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 298cfb23b0..b5e1e2d122 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -64,6 +64,7 @@
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21832,3 +21833,27 @@ a @samp{date} keywords, and optionally, a @samp{filetags} keyword.")
"Daredevil SKK is a version of @acronym{SKK, Simple Kana to Kanji
conversion program}, a Japanese input method on Emacs.")
(license license:gpl2+))))
+
+(define-public emacs-objed
+ (package
+ (name "emacs-objed")
+ (version "0.8.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://elpa.gnu.org/packages/objed-"
+ version
+ ".tar"))
+ (sha256
+ (base32
+ "1s38d6bvggdk5p45ww1jb4gxifzgjwgw1m6ar920nlg0j4fgbcvr"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/clemera/objed")
+ (synopsis "Navigate and edit text objects")
+ (description
+ "A global minor-mode to navigate and edit text objects. Objed enables modal
+editing and composition of commands, too. It combines ideas of other
+Editors like Vim or Kakoune and tries to align them with regular Emacs
+conventions.")
+ (license license:gpl3+)))
--
2.25.1
M
M
Mathieu Othacehe wrote on 21 Mar 2020 15:42
(address . guix-patches@gnu.org)(address . 40122-done@debbugs.gnu.org)
874kuhkbvj.fsf@gmail.com
Pushed as 6a65ec0945ef5a39073ffe06f51cbacd641883aa.

Thanks,

Mathieu
?