[PATCH] gnu: Add wev.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brendan Tildesley
  • Marius Bakke
Owner
unassigned
Submitted by
Brendan Tildesley
Severity
normal
B
B
Brendan Tildesley wrote on 15 Mar 2020 10:36
(address . guix-patches@gnu.org)
20200315093616.12884-1-mail@brendan.scot
* gnu/packages/freedesktop.scm (wev): New variable.
---
gnu/packages/freedesktop.scm | 40 +++++++++++++++++++++++++++++++++++-
1 file changed, 39 insertions(+), 1 deletion(-)

Toggle diff (67 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 1244da4fa0..b9811fb60e 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2017, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017, 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2017 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2017, 2020 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Stefan Stefanovi? <stefanx2ovic@gmail.com>
@@ -72,6 +72,7 @@
#:use-module (gnu packages libunwind)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages man)
#:use-module (gnu packages m4)
#:use-module (gnu packages nss)
#:use-module (gnu packages perl)
@@ -804,6 +805,43 @@ composes the final output. A Wayland compositor is essentially a
multiplexer to the KMS/DRM Linux kernel devices.")
(license license:expat)))
+(define-public wev
+ ;; There simple tool has no version or release yet.
+ (let ((commit "cee3dfb2a8b40ee303611018c68ae182d84a7f46"))
+ (package
+ (name "wev")
+ (version (string-append "2020-02-06-" (string-take commit 8)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sircmpwn/wev")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0l71v3fzgiiv6xkk365q1l08qvaymxd4kpaya6r2g8yzkr7i2hms"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("scdoc" ,scdoc)))
+ (inputs
+ `(("libxkbcommon" ,libxkbcommon)
+ ("wayland" ,wayland)
+ ("wayland-protocols" ,wayland-protocols)))
+ (home-page "https://git.sr.ht/~sircmpwn/wev")
+ (synopsis "Wayland event viewer")
+ (description "Wev is a tool that opens a window, printing all events
+sent to a Wayland window, such as key presses. It is analogous to the X11 tool
+XEv.")
+ (license license:expat))))
+
(define-public exempi
(package
(name "exempi")
--
2.25.1
M
M
Marius Bakke wrote on 20 Mar 2020 19:07
874kui99xl.fsf@devup.no
Brendan Tildesley <mail@brendan.scot> writes:

Toggle quote (2 lines)
> * gnu/packages/freedesktop.scm (wev): New variable.

Applied, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl51BnYACgkQoqBt8qM6
VPoShQgArg0+FEgCyWpQ0I89zoZJqTxFdCxS9mbuUb0T/Zx8NodNvlq0xy0rXSR8
orLNUkxslLLceSbbSYJq/5V9ioTLeVq7ZF5E6XLc9sE1rJDz8trMxLCRwR1iZtp7
c/8HFXYOhjy2tlSZSni4oFCOt9Ea9k5Fzdufqzmflo5wuiXLo3Ad/aYpRuG5L4B1
ljOI1zF0kxLB7Kv0diJLiZnWoeJBEErX+oabv80nr9phniMahrHAIvrYGkOh70JA
u5bVhPV14PcgqVmYyaAviZZvkkoVnDykALv3ed3f5EowAFdr2a7GLws7AI8qy9Tg
C9BDXCGhCScgNm7N6mY0OTJKCCKkXQ==
=LKI5
-----END PGP SIGNATURE-----

Closed
?