[PATCH] gnu: add premake5.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Marius Bakke
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal
L
L
Leo Prikler wrote on 15 Mar 2020 01:52
(address . guix-patches@gnu.org)
20200315005236.3031-1-leo.prikler@student.tugraz.at
* gnu/packages/build-tools.scm (premake5): New variable.
---
gnu/packages/build-tools.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 63dc72e1a7..816eb6c8fe 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -245,6 +245,31 @@ other lower-level build files.")
(home-page "https://premake.github.io")
(license license:bsd-3)))
+(define-public premake5
+ (package
+ (inherit premake4)
+ (version "5.0.0-alpha14")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/premake/premake-core/"
+ "releases/download/v" version
+ "/premake-" version "-src.zip"))
+ (sha256
+ (base32
+ "0236s7bjvxf7x1l5faywmfzjywflpx42ngyhkn0mqqjnh54a97vw"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments premake4)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "../../bin/release/premake5"
+ (string-append (assoc-ref outputs "out") "/bin"))
+ #t))))))
+ (description "@code{premake5} is a command line utility that reads a
+scripted definition of a software project and outputs @file{Makefile}s or
+other lower-level build files.")))
+
(define-public osc
(package
(name "osc")
--
2.25.1
M
M
Marius Bakke wrote on 20 Mar 2020 19:10
871rpm99t0.fsf@devup.no
Leo Prikler <leo.prikler@student.tugraz.at> writes:

Toggle quote (2 lines)
> * gnu/packages/build-tools.scm (premake5): New variable.

Applied, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl51BxsACgkQoqBt8qM6
VPoTmQf/ffy4BCLW7/Zxw4imcHXDFd8I2kF9Jc69j7/BrGO6jbE5z1H4aOK0CQXi
KZloe1cJJPgl4TTN55N8fD78Hg62T7kY89KmWSzzw1PRTilTLz1F3zvFppTROLgL
v4M2Sbvj+4JVQneNHsU93b0L73ZniKTZgI8xWq5UNvW1RwPEj8CQtO2atT8CqSpG
/7M2CoQh+ITRNQX2tnydPUZ3jVqS4wGwJyCiFTBmFtN3CZZlkmFMKq1Sc29wHTV3
g7hU7Cf5RvStCRs+iYDnxkympTyTSY2p9qz4AfW5YewN/DuVtfh077tpMw2ULKly
oUECvJpH6XxkubCH75F80B5amNjfVA==
=Gn05
-----END PGP SIGNATURE-----

Closed
?