(name . bug-guix)(address . bug-guix@gnu.org)
I just packages a simple GUI application using pythonqt5 and
python-poppler-qt. When running it fails with:
Could not load the Qt platform plugin "xcb" in "" even though it was
found.
When running with QT_DEBUG_PLUGINS=1 it reveals the cause:
QFactoryLoader::QFactoryLoader() checking directory path
"/usr/lib64/qt5/plugins/platforms" ...
QFactoryLoader::QFactoryLoader() looking at
"/usr/lib64/qt5/plugins/platforms/KWinQpaPlugin.so"
Found metadata in lib
/usr/lib64/qt5/plugins/platforms/KWinQpaPlugin.so, metadata=
[… many lines skipped …]
Got keys from plugin meta data ("xcb")
QFactoryLoader::QFactoryLoader() checking directory path
"/gnu/store/608bvypsh90c58apvd2cgg3m9l2pwjqn-python-3.7.4/bin/platforms"
...
Cannot load library /usr/lib64/qt5/plugins/platforms/libqxcb.so:
(libQt5XcbQpa.so.5: cannot open shared object file: No such file or
directory)
QLibraryPrivate::loadPlugin failed on
"/usr/lib64/qt5/plugins/platforms/libqxcb.so" : "Cannot load library
/usr/lib64/qt5/plugins/platforms/libqxcb.so: (libQt5XcbQpa.so.5:
cannot open shared object file: No such file or directory)"
Looks like the plugin is search in the wrong location and also the list
of plgins.
--
Regards
Hartmut Goebel
| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |