foreign distro: QT5 loads/searchs plugins from wrong location

  • Open
  • quality assurance status badge
Details
2 participants
  • Hartmut Goebel
  • Marius Bakke
Owner
unassigned
Submitted by
Hartmut Goebel
Severity
normal
H
H
Hartmut Goebel wrote on 9 Mar 2020 10:31
(name . bug-guix)(address . bug-guix@gnu.org)
3007053b-6378-a6c0-45b1-874bc1d4d6e1@crazy-compilers.com
I just packages a simple GUI application using pythonqt5 and
python-poppler-qt. When running it fails with:

Could not load the Qt platform plugin "xcb" in "" even though it was
found.

When running with QT_DEBUG_PLUGINS=1 it reveals the cause:

QFactoryLoader::QFactoryLoader() checking directory path
"/usr/lib64/qt5/plugins/platforms" ...
QFactoryLoader::QFactoryLoader() looking at
"/usr/lib64/qt5/plugins/platforms/KWinQpaPlugin.so"
Found metadata in lib
/usr/lib64/qt5/plugins/platforms/KWinQpaPlugin.so, metadata=
[… many lines skipped …]

Got keys from plugin meta data ("xcb")
QFactoryLoader::QFactoryLoader() checking directory path
"/gnu/store/608bvypsh90c58apvd2cgg3m9l2pwjqn-python-3.7.4/bin/platforms"
...
Cannot load library /usr/lib64/qt5/plugins/platforms/libqxcb.so:
(libQt5XcbQpa.so.5: cannot open shared object file: No such file or
directory)
QLibraryPrivate::loadPlugin failed on
"/usr/lib64/qt5/plugins/platforms/libqxcb.so" : "Cannot load library
/usr/lib64/qt5/plugins/platforms/libqxcb.so: (libQt5XcbQpa.so.5:
cannot open shared object file: No such file or directory)"

Looks like the plugin is search in the wrong location and also the list
of plgins.

--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
Attachment: signature.asc
M
M
Marius Bakke wrote on 10 Mar 2020 20:24
87r1y0ypw4.fsf@devup.no
Hartmut Goebel <h.goebel@crazy-compilers.com> writes:

Toggle quote (6 lines)
> I just packages a simple GUI application using pythonqt5 and
> python-poppler-qt. When running it fails with:
>
> Could not load the Qt platform plugin "xcb" in "" even though it was
> found.

Does it help if you wrap it with QT_PLUGIN_PATH, as we do with some
other KDE applications?

Alternatively, installing 'qtbase' with the other packages should set up
the relevant search paths.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl5n6WsACgkQoqBt8qM6
VPp1zAf/QzVn53bfwPY/c3oD0ghGhUCPK9H4lthlOwfTbXTWOmSFu1/MJNUN5iRY
5suAeyVAr7XcPMk0mln7mxoGzlBa/TANMqW3n54wtRdZDLoQAcvmMVneLUU3EOd1
SPUvuzuf19SOFBVlp6xuVA1ZXlGbv5cXQRBM2oQWtTfIyki8ZHNbgowsAzFxPPRM
7oVV6T2Fib829GhgKyh95qfViA4Miyo4NgHDZkTXYQcKts9V3wv+D56BljfO2f80
eC61lPaSWoTAHlBchSoYL5L5OplHlYBbR/jhTf01HJRzt5bSdUm1LOd5pgi8UbLQ
wPy/J9aKdPL4zxfCJEF9vaxwkFg+IA==
=1t/e
-----END PGP SIGNATURE-----

H
H
Hartmut Goebel wrote on 11 Mar 2020 09:55
43c5ae01-baa8-fb81-debe-7761815527f5@crazy-compilers.com
Hi Marius,
Toggle quote (3 lines)
> Does it help if you wrap it with QT_PLUGIN_PATH, as we do with some
> other KDE applications?

I was able to work-around this by setting QT_PLUGIN_PATH. (Installing
qtbase has worked, too, btw)

Nevertheless I which this would not be necessary. I'd expect the qtbase
to find the plugins and platform-plugins coming with itself. (As far as
I've seen from the Nixpkg, nix has the same issues, so no solution to
copy from there.)

--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
Attachment: signature.asc
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 39996@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 39996
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch