python-hy build failure

  • Done
  • quality assurance status badge
Details
2 participants
  • Jesse Gibbons
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jesse Gibbons
Severity
normal
J
J
Jesse Gibbons wrote on 17 Nov 2019 01:26
(name . bug-guix mailing list)(address . bug-guix@gnu.org)
722cf4545fefd4edd13c1f6eeccc90acf91cb668.camel@gmail.com
guix build python-hy fails with the message
error: [Errno 13] Permission denied: '/homeless-shelter'

It looks like the install step tries to access $HOME and fails. I am working
on a patch to fix this.
J
J
Jesse Gibbons wrote on 17 Nov 2019 02:44
(address . 38241@debbugs.gnu.org)
026987d0c93e7ca76de8dafe956b99398e1d16aa.camel@gmail.com
On Sat, 2019-11-16 at 17:26 -0700, Jesse Gibbons wrote:
Toggle quote (10 lines)
> guix build python-hy fails with the message
> error: [Errno 13] Permission denied: '/homeless-shelter'
>
> It looks like the install step tries to access $HOME and fails. I am
> working
> on a patch to fix this.
>
>
>
>
The patch is attached. I noticed it lets it build, but python-hy is still
broken. Python2-hy is not broken though.
From 15580fd77397d55ddc459c6ada58201ee61e8ec8 Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
Date: Sat, 16 Nov 2019 18:33:05 -0700
Subject: [PATCH] gnu: python-hy: Set HOME to /tmp before install

This fixes bug#38241

* gnu/packages/python-xyz.scm (python-hy)[arguments]: Add custom
'set-HOME phase before the 'install phase.
---
gnu/packages/python-xyz.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d2786e4826..5b8b33b87f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8745,6 +8745,9 @@ with a new public API, and RPython support.")
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-before 'install 'set-HOME
+ (lambda _
+ (setenv "HOME" "/tmp")))
(replace 'check
(lambda _
;; Tests require write access to HOME.
--
2.24.0
L
L
Ludovic Courtès wrote on 17 Nov 2019 22:35
(name . Jesse Gibbons)(address . jgibbons2357@gmail.com)(address . 38241-done@debbugs.gnu.org)
87o8xai3tv.fsf@gnu.org
Hi,

Jesse Gibbons <jgibbons2357@gmail.com> skribis:

Toggle quote (10 lines)
> From 15580fd77397d55ddc459c6ada58201ee61e8ec8 Mon Sep 17 00:00:00 2001
> From: Jesse Gibbons <jgibbons2357+guix@gmail.com>
> Date: Sat, 16 Nov 2019 18:33:05 -0700
> Subject: [PATCH] gnu: python-hy: Set HOME to /tmp before install
>
> This fixes bug#38241
>
> * gnu/packages/python-xyz.scm (python-hy)[arguments]: Add custom
> 'set-HOME phase before the 'install phase.

Applied, thanks!

Ludo’.
Closed
?