[PATCH] gnu: Add avldrums-lv2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Marius Bakke
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 8 Nov 2019 10:38
(name . Guix patches)(address . guix-patches@gnu.org)
3657edb78c1a186745eb5206b54d8f4f@posteo.net
From aae805260db2b830a35459ae219c780e6619cc14 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 09:35:38 +0000
Subject: [PATCH] gnu: Add avldrums-lv2.

* gnu/packages/music.scm: (avldrums-lv2): New variable.
---
gnu/packages/music.scm | 43 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a30765e87f..38d30c5438 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4699,3 +4700,45 @@ You can also get metadata about the playing track
such as the artist and title
for integration into status line generators or other command-line
tools.")
(home-page "https://github.com/altdesktop/playerctl")
(license license:lgpl3+)))
+
+(define-public avldrums-lv2
+ (package
+ (name "avldrums-lv2")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/x42/avldrums.lv2.git")
+ (commit (string-append "v" version))
+ (recursive? #t))) ; for the 'robtk' submodule
+ (file-name (string-append name "-v" version))
+ (sha256
+ (base32
+ "1z70rcq6z3gkb4fm8dm9hs31bslwr97zdh2n012fzki9b9rdj5qv"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-CC-variable
+ (lambda _ (setenv "CC" "gcc") #t))
+ (delete 'configure))))
+ (inputs
+ `(("cairo" ,cairo)
+ ("dssi" ,dssi)
+ ("glu" ,glu)
+ ("mesa" ,mesa)
+ ("pango" ,pango)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("lv2" ,lv2)))
+ (home-page "http://x42-plugins.com/x42/x42-avldrums")
+ (synopsis "Drum sample player LV2 plugin dedicated to the AVLinux
Drumkits")
+ (description "avldrums.lv2 is a drum sample player LV2 plugin
dedicated to Glen MacArthur's
+AVLdrums. This plugin provides a convenient way to sequence and mix
MIDI drums and
+comes as two separate drumkits: Black Pearl and Red Zeppelin.")
+ (license license:gpl2+)))
--
2.24.0
M
M
Marius Bakke wrote on 10 Nov 2019 23:27
87sgmvjrji.fsf@devup.no
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (7 lines)
> From aae805260db2b830a35459ae219c780e6619cc14 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 09:35:38 +0000
> Subject: [PATCH] gnu: Add avldrums-lv2.
>
> * gnu/packages/music.scm: (avldrums-lv2): New variable.

[...]

Toggle quote (9 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri
> + (git-reference
> + (url "https://github.com/x42/avldrums.lv2.git")
> + (commit (string-append "v" version))
> + (recursive? #t))) ; for the 'robtk' submodule

Can we package robtk separately?

Toggle quote (2 lines)
HTTPS ^

Toggle quote (8 lines)
> + (synopsis "Drum sample player LV2 plugin dedicated to the AVLinux
> Drumkits")
> + (description "avldrums.lv2 is a drum sample player LV2 plugin
> dedicated to Glen MacArthur's
> +AVLdrums. This plugin provides a convenient way to sequence and mix
> MIDI drums and
> +comes as two separate drumkits: Black Pearl and Red Zeppelin.")

Make sure to run 'guix lint' before resending these patches, to catch
infraction issues :-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3IjtEACgkQoqBt8qM6
VPoF8gf9G2X9Uf5DGx3QXCMHNYT2jgYzi8u/EgZOVDLXD+rsfmqZC7JP5gmi5Gr+
oaLLEiYSHjCRe7rGnkISuoP/zDVEDktCfK+A+VV3K5y95Ola5sdJWInmNFmURGQl
NxQabNRlNgtPrNFDMZOkLb3qsB2t5BhXbBi8Abq17EiTi1Nsf/o4Vxny5DSXOJJ8
GcnKstJD2ot5a6T9ltc3PY2mf9clpkHadg5nKWRlGj4Eb9UIWQQBPnRhKhX7X0Cr
9q8HF/aOtbYVWBgUiqp58Um+eMwPBuSVoKpfjtMY1EDYNnZXVw8WGMdrHvVvG5Eu
VkBV38HUzLA99Aaf+Sywu+9+A8WjQA==
=0JUH
-----END PGP SIGNATURE-----

A
A
Alexandros Theodotou wrote on 11 Nov 2019 05:07
32d92782035a3f31c13958486adb9d17243e3e89.camel@zrythm.org
Hi Marius,

Toggle quote (11 lines)
> > + (source
> > + (origin
> > + (method git-fetch)
> > + (uri
> > + (git-reference
> > + (url "https://github.com/x42/avldrums.lv2.git")
> > + (commit (string-append "v" version))
> > + (recursive? #t))) ; for the 'robtk' submodule
>
> Can we package robtk separately?

The author expects it to be included in the plugin's sources, much like
DPF (DISTRHO plugin framework) based plugins. I don't know if it is
possible to package it, or at least if any of the plugins using it can
build with a packaged version without modifications. The Redkite
toolkit is a bit better because it outputs a .a library that you can
statically link with instead of having to include its sources, so that
was easy to package.

By the way, Arch does the same thing for this package. I believe Debian
too, but not 100% sure about Debian.

Toggle quote (2 lines)
> Make sure to run 'guix lint' before resending these patches, to catch
> infraction issues :-)
Done, thank you!
From e6d30dd87ae46bfba50de7a0e549a13a0368dfcc Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 09:35:38 +0000
Subject: [PATCH] gnu: Add avldrums-lv2.

* gnu/packages/music.scm: (avldrums-lv2): New variable.
---
gnu/packages/music.scm | 45 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2f023685df..9d858ec6ff 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4737,3 +4737,48 @@ for integration into status line generators or other command-line tools.")
effects. It contains a bitcrusher, delay, distortion, equalizer, compressor,
and reverb.")
(license license:gpl2+)))
+
+(define-public avldrums-lv2
+ (package
+ (name "avldrums-lv2")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/x42/avldrums.lv2.git")
+ (commit (string-append "v" version))
+ ;; This plugin expects the robtk submodule's source files to be
+ ;; there in order to build
+ (recursive? #t)))
+ (file-name (string-append name "-v" version))
+ (sha256
+ (base32
+ "1z70rcq6z3gkb4fm8dm9hs31bslwr97zdh2n012fzki9b9rdj5qv"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-CC-variable
+ (lambda _
+ (setenv "CC" "gcc") #t))
+ (delete 'configure))))
+ (inputs
+ `(("cairo" ,cairo)
+ ("dssi" ,dssi)
+ ("glu" ,glu)
+ ("mesa" ,mesa)
+ ("pango" ,pango)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("lv2" ,lv2)))
+ (home-page "https://x42-plugins.com/x42/x42-avldrums")
+ (synopsis "Drum sample player LV2 plugin dedicated to the AVLinux Drumkits")
+ (description "AVLdrums is a drum sample player LV2 plugin dedicated to Glen
+MacArthur's AVLdrums. This plugin provides a convenient way to sequence and mix
+MIDI drums and comes as two separate drumkits: Black Pearl and Red Zeppelin.")
+ (license license:gpl2+)))
--
2.24.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl3I3pEACgkQAi6uQjE9
cPMAyQf+OeMHRkx2+yvEcD0fBJO4/MQV/PwxYDpmzx5bWqGjIy54ksa9i0APDsjA
aY05hZriK/q7bdNUKoVHftTtHV8mQBSoi+/KwCFp4GQsZKFs+cjrqbq+NjM09uje
uqi6tYoekjYSTv3KsN4osJDx54RjzVzM10k/7Fk+Y0SsSKOuYCeuxPT8CEmHuxQ7
yA5Vh/PmsJKsME01mykxal6WG4gfS7KWAja3mU41z8WxuemkydcayyWPXvKIb9qT
c6G9oXCi/uyqNMhWSZ/iQfwSE3Gdh4u6g083aDaAXYbDl851X5FD/dTso9VSR925
6ZHfaI+Xn4kz0G3KijTwRNdmOWP89w==
=RVuu
-----END PGP SIGNATURE-----


A
A
Alexandros Theodotou wrote on 11 Nov 2019 06:15
(address . 38118@debbugs.gnu.org)
5a5e1c42fff47cdd168bd1380a94e218cf433e5c.camel@zrythm.org
Oops, copy-paste fail. Added 2 spaces between sentences.
From e6d30dd87ae46bfba50de7a0e549a13a0368dfcc Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 09:35:38 +0000
Subject: [PATCH] gnu: Add avldrums-lv2.

* gnu/packages/music.scm: (avldrums-lv2): New variable.
---
gnu/packages/music.scm | 45 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2f023685df..9d858ec6ff 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4737,3 +4737,48 @@ for integration into status line generators or other command-line tools.")
effects. It contains a bitcrusher, delay, distortion, equalizer, compressor,
and reverb.")
(license license:gpl2+)))
+
+(define-public avldrums-lv2
+ (package
+ (name "avldrums-lv2")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/x42/avldrums.lv2.git")
+ (commit (string-append "v" version))
+ ;; This plugin expects the robtk submodule's source files to be
+ ;; there in order to build
+ (recursive? #t)))
+ (file-name (string-append name "-v" version))
+ (sha256
+ (base32
+ "1z70rcq6z3gkb4fm8dm9hs31bslwr97zdh2n012fzki9b9rdj5qv"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-CC-variable
+ (lambda _
+ (setenv "CC" "gcc") #t))
+ (delete 'configure))))
+ (inputs
+ `(("cairo" ,cairo)
+ ("dssi" ,dssi)
+ ("glu" ,glu)
+ ("mesa" ,mesa)
+ ("pango" ,pango)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("lv2" ,lv2)))
+ (home-page "https://x42-plugins.com/x42/x42-avldrums")
+ (synopsis "Drum sample player LV2 plugin dedicated to the AVLinux Drumkits")
+ (description "AVLdrums is a drum sample player LV2 plugin dedicated to Glen
+MacArthur's AVLdrums. This plugin provides a convenient way to sequence and mix
+MIDI drums and comes as two separate drumkits: Black Pearl and Red Zeppelin.")
+ (license license:gpl2+)))
--
2.24.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl3I7nkACgkQAi6uQjE9
cPMi/Af/R+qNXCsx3oG0eAKzy4NPGYQZwPn0sEd3N6lPqBu7WjjvNNcDdo7n3Nza
c+SJuOz8uR3102foKg3KN2U7VRqvCaIAOXJlSMXBo3ObJI0ys/6YkLkSjTje4jHG
d/RFc/qkwyqY+CdB7cWdAyBkKigJM30ehjE8lRozuLWPm/nve9Dea2epOfzNAlB2
q4OKjtd5XHX7kfmN4QCfR/jWY3iwflNxvT+gia9QUP+GcmHGNQcPwFW8Cu+r945M
4gRnXu110tyz792xU8pqqG5URMj7+voGkzJDI67QRASLGR2qHxYsjgua+oaKVM5U
TACDjwXZERAubuY13yc8OWsSf71r5w==
=Wzk4
-----END PGP SIGNATURE-----


M
M
Marius Bakke wrote on 13 Nov 2019 23:33
87imnniezb.fsf@devup.no
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (7 lines)
> From e6d30dd87ae46bfba50de7a0e549a13a0368dfcc Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 09:35:38 +0000
> Subject: [PATCH] gnu: Add avldrums-lv2.
>
> * gnu/packages/music.scm: (avldrums-lv2): New variable.

Thanks! Applied with indentation fixes like the other patches. This is
the last review I had time for today.

In the future, when sending many related patches at once, please send as
a "patch series" (commits on top of each other) instead of individual
patches all branching out from the same commit.

The reason is that applying the first patch to music.scm broke the other
patches for music.scm, because the context became different. I managed
to work around it with a workflow involving
`git am --show-current-patch | git apply`, but it would be better if all
applied cleanly when committed in order. :-)

Anyway, impressive first series of patches! I look forward to the next
one. ;-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3MhKgACgkQoqBt8qM6
VPrBmwf/eFIdWNn8smHh+d6eLO+Wj0ODXB0SLMgQCDWcs26MjIFTU8z0r/g8uXAy
TX1Kfbzccwv2RZGoz+xSfT42AFfq9HdsOEb7JMgP/iML9gC9lOQbF9v/zlUEzzB9
9MrqGHAO8y1vS86AmXGJgc0YtaUSaQlEhdf0NMymC8UyWH239zBVaOvnkroncx87
IIH7HDrbGrvCt5MFttRNZ/QHxCw/oq35Riyj536K9NePONU8xxM7Vpj5+zo15hRk
tB0whMC8gISDfMjiIhhdaLKWaT5BV6bWG+8MpYKawaKWMvj0HqRng4EqICNazuD9
ZlVrAs7HV9/U0zyTt7BnvFc9nngxCQ==
=jrd6
-----END PGP SIGNATURE-----

Closed
?