[PATCH 0/2] *** Add scroll ***

  • Done
  • quality assurance status badge
Details
One participant
  • Efraim Flashner
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 3 Nov 2019 21:15
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
20191103201551.3377-1-efraim@flashner.co.il
I have finally tried it out, and you can use scroll as a pager

Efraim Flashner (2):
gnu: Add ghc-ncurses.
gnu: Add scroll.

gnu/packages/haskell-apps.scm | 31 +++++++++++++++++++++++++++++
gnu/packages/haskell-xyz.scm | 37 +++++++++++++++++++++++++++++++++++
2 files changed, 68 insertions(+)

--
2.23.0
E
E
Efraim Flashner wrote on 3 Nov 2019 21:17
[PATCH 1/2] gnu: Add ghc-ncurses.
(address . 38048@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
20191103201739.3524-1-efraim@flashner.co.il
* gnu/packages/haskell-xyz.scm (ghc-ncurses): New variable.
---
gnu/packages/haskell-xyz.scm | 37 ++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 217c78a08c..e0cb34cd67 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6753,6 +6753,43 @@ between 2 and 3 times faster than the Mersenne Twister.")
`(("ghc-hashable" ,ghc-hashable-bootstrap)))
(properties '((hidden? #t)))))
+(define-public ghc-ncurses
+ (package
+ (name "ghc-ncurses")
+ (version "0.2.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/ncurses/ncurses-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0gsyyaqyh5r9zc0rhwpj5spyd6i4w2vj61h4nihgmmh0yyqvf3z5"))))
+ (build-system haskell-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'fix-includes
+ (lambda _
+ (substitute* '("cbits/hsncurses-shim.h"
+ "lib/UI/NCurses.chs"
+ "lib/UI/NCurses/Enums.chs"
+ "lib/UI/NCurses/Panel.chs")
+ (("<ncursesw/") "<"))
+ #t)))
+ #:cabal-revision
+ ("1"
+ "1wfdy716s5p1sqp2gsg43x8wch2dxg0vmbbndlb2h3d8c9jzxnca")))
+ (inputs `(("ncurses" ,ncurses)))
+ (native-inputs `(("ghc-c2hs" ,ghc-c2hs)))
+ (home-page "https://john-millikin.com/software/haskell-ncurses/")
+ (synopsis "Modernised bindings to GNU ncurses")
+ (description "GNU ncurses is a library for creating command-line application
+with pseudo-graphical interfaces. This package is a nice, modern binding to GNU
+ncurses.")
+ (license license:gpl3)))
+
(define-public ghc-network
(package
(name "ghc-network")
--
2.23.0
E
E
Efraim Flashner wrote on 3 Nov 2019 21:17
[PATCH 2/2] gnu: Add scroll.
(address . 38048@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
20191103201739.3524-2-efraim@flashner.co.il
* gnu/packages/haskell-apps.scm (scroll): New variable.
---
gnu/packages/haskell-apps.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 0fab912f4f..a2fa5d085d 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -599,6 +599,37 @@ proved to be an excellent learning experience for the programmers. Everything
is programmed in Haskell.")
(license license:bsd-3)))
+(define-public scroll
+ (package
+ (name "scroll")
+ (version "1.20180421")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/scroll/scroll-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0apzrvf99rskj4dbmn57jjxrsf19j436s8a09m950df5aws3a0wj"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-data-default" ,ghc-data-default)
+ ("ghc-ifelse" ,ghc-ifelse)
+ ("ghc-monad-loops" ,ghc-monad-loops)
+ ("ghc-ncurses" ,ghc-ncurses)
+ ("ghc-optparse-applicative" ,ghc-optparse-applicative)
+ ("ghc-random" ,ghc-random)
+ ("ghc-vector" ,ghc-vector)))
+ (home-page "https://joeyh.name/code/scroll/")
+ (synopsis "scroll(6), a roguelike game")
+ (description
+ "You're a bookworm that's stuck on a scroll. You have to dodge between
+words and use spells to make your way down the page as the scroll is read. Go
+too slow and you'll get wound up in the scroll and crushed.")
+ (license license:gpl2)))
+
(define-public shellcheck
(package
(name "shellcheck")
--
2.23.0
E
E
Efraim Flashner wrote on 10 Nov 2019 09:41
Re: [PATCH 1/2] gnu: Add ghc-ncurses.
(address . 38048-done@debbugs.gnu.org)
20191110084134.GE3954@E5400
Patches pushed

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl3HzT4ACgkQQarn3Mo9
g1G62w//WT9Lx38PHUrRbVoSesCIHb+uKPmvEPLVGLs3wNzXGd5RmzlrFfNDKvJ+
i6xATlgUhTnCaKksFgq437uzbsa27cUBG1cDa8mlvt2s+jDQCoLkVQ5c2iNsRNac
UZcBcej1mAJhlGGMRwYLRpbuViU/5zyT2IEFaJbTsNFijWCujSlgvQD1Iff3/R8A
p7ui7GVSeSvT/tBMfUy1q8ApEiuH8z34HvuaFoKdZTWMiLIJQH+iweuL5ZCFMXKN
9QypXBaXS//W6TWSS0Trqfgac53denFapzshz9JYAZeAPfvm0An/YiJNcuxpC/rX
LDhW76mqQC+WS4decqmmE1WziRb64u51eAoCoAKqoE2HTac3KptezPXcgCNwQHiu
ARSn8w+UUxArosnHDqPjzp79b0lZROSpTpHl9Wy4jd/xV0YgJy2rIB0EKzjwPrl7
iM1CHO2utpBn5GuL9biRZdWCedIa4MZ+qR6kdIfKzDhM9izpnyNInc3/gsTwQO3d
zO4vrt0FR9MIW03N/DSCLWd67XE8YelOBrKJJDpnw2M1yLy1MY3f32q2LWNYtvf1
2ox+3+OEoRTPFCLHSc+aIVBY1hrF1FDzLGys3ojBJtIbKhbwfDsrd5CnTlj8cr1P
vGgsCt/lE8iHjRHMDDSo6jICVD48S92kbiPED/oW1Y2vDEWI5T8=
=XY1p
-----END PGP SIGNATURE-----


Closed
?