v2 - [Patch] gnu: lilv: Enable python bindings.

  • Done
  • quality assurance status badge
Details
2 participants
  • Florian Paul Schmidt
  • Marius Bakke
Owner
unassigned
Submitted by
Florian Paul Schmidt
Severity
normal
F
F
Florian Paul Schmidt wrote on 1 Nov 2019 14:44
(address . guix-patches@gnu.org)
20191101144418.5c05b942@uni-bielefeld.de
Hi,

do please include me in replies since I'm not subscribed to
guix-patches..

Kind regards,
FPS
From 096a799b91fa6db12caaf7ad433852daf3ca6529 Mon Sep 17 00:00:00 2001
From: FPS <mista.tapas@gmx.net>
Date: Fri, 1 Nov 2019 14:35:49 +0100
Subject: [PATCH] gnu: lilv: Enable python bindings.

---
gnu/packages/audio.scm | 17 ++++++++++++++---
1 file changed, 14 insertions(+), 3 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 88b5696a9b..c7b88d9ecf 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1825,6 +1825,7 @@ included are the command line utilities @code{send_osc} and @code{dump_osc}.")
(build-system waf-build-system)
(arguments
`(#:tests? #f ; no check target
+ #:configure-flags (list "--bindings")
#:phases
(modify-phases %standard-phases
(add-before
@@ -1833,7 +1834,16 @@ included are the command line utilities @code{send_osc} and @code{dump_osc}.")
(setenv "LDFLAGS"
(string-append "-Wl,-rpath="
(assoc-ref outputs "out") "/lib"))
- #t)))))
+ #t))
+ (add-after
+ 'unpack 'full-store-path-to-shared-library
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-directory-excursion "bindings/python"
+ (substitute*
+ "lilv.py"
+ (("liblilv-0.so") (string-append (assoc-ref outputs "out")
+ "/lib/liblilv-0.so"))))
+ #t)))))
;; Required by lilv-0.pc.
(propagated-inputs
`(("lv2" ,lv2)
@@ -1841,8 +1851,9 @@ included are the command line utilities @code{send_osc} and @code{dump_osc}.")
("sord" ,sord)
("sratom" ,sratom)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
- (home-page "https://drobilla.net/software/lilv/")
+ `(("python" ,python)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://drobilla.net/software/lilv")
(synopsis "Library to simplify use of LV2 plugins in applications")
(description
"Lilv is a C library to make the use of LV2 plugins as simple as possible
--
2.22.0
M
M
Marius Bakke wrote on 3 Nov 2019 17:58
87zhhcoq0k.fsf@devup.no
Florian Paul Schmidt <florian_paul.schmidt@uni-bielefeld.de> writes:

Toggle quote (5 lines)
> Hi,
>
> do please include me in replies since I'm not subscribed to
> guix-patches..

Applied with a commit message and minor cosmetic adjustments, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl2/B0sACgkQoqBt8qM6
VPpbpwf8CYRGc5UMIm4zAC0TfVr64Cl9kzFnrL68RW5JVFrvyzQOsGg/j+XXRWEp
G11+1BTMOHegMqgX6afJBCLniPpL2yaOqnelRZaHyoBXiZmPLzMl/yca/jMkYXbv
aNY9AOwIOYAOOj1WF3ZK0Ua/kDZH6exK2VAEk0rSYue3a4qNqzdvP52vp8/UU8FD
QhPkJieyhJTsv7LDijl91qvft+EpCHIMhvxcuCdti6Edf2IEXmsUzwqF8iFglwuS
Qpkk4wEZkLN6g3LPEPA6iaGfvbj/7y+t0BIjWZf3PodYJtN1VGCQjHs4hRpHZQNH
6E15F0sMEbfKM+kzRrTRzEDiJ6jw9g==
=t3PY
-----END PGP SIGNATURE-----

Closed
?