[PATCH] gnu: Add endlessh.

  • Done
  • quality assurance status badge
Details
One participant
  • Efraim Flashner
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 29 Oct 2019 20:42
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
20191029194226.20634-1-efraim@flashner.co.il
* gnu/packages/ssh.scm (endlessh): New variable.
---
gnu/packages/ssh.scm | 36 +++++++++++++++++++++++++++++++++++-
1 file changed, 35 insertions(+), 1 deletion(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index f626e0e5f6..f6559f4578 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015, 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
@@ -741,3 +741,37 @@ optimized execution algorithms, as well as gathering results and merging
identical outputs, or retrieving return codes. ClusterShell takes advantage
of existing remote shell facilities such as SSH.")
(license license:lgpl2.1+)))
+
+(define-public endlessh
+ (package
+ (name "endlessh")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/skeeto/endlessh/releases/"
+ "download/" version "/endlessh-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0hhsr65hzrcb7ylskmxyr92svzndhks8hqzn8hvg7f7j89rkvq5k"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "CC=gcc")
+ #:tests? #f ; no test target
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (home-page "https://github.com/skeeto/endlessh")
+ (synopsis "SSH tarpit that slowly sends an endless banner")
+ (description
+ "Endlessh is an SSH tarpit that very slowly sends an endless, random SSH
+banner. It keeps SSH clients locked up for hours or even days at a time. The
+purpose is to put your real SSH server on another port and then let the script
+kiddies get stuck in this tarpit instead of bothering a real server.
+
+Since the tarpit is in the banner before any cryptographic exchange occurs, this
+program doesn't depend on any cryptographic libraries. It's a simple,
+single-threaded, standalone C program. It uses @code{poll()} to trap multiple
+clients at a time.")
+ (license license:unlicense)))
--
2.23.0
E
E
Efraim Flashner wrote on 3 Nov 2019 19:31
(address . 37984-done@debbugs.gnu.org)
20191103183136.GA372@E5400
Patch pushed


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl2/HQcACgkQQarn3Mo9
g1F2Ng/+PzQWBIpWzxoTkCe5Zr2Atjq25kDnKTXFJAybIryTJL8/E2Tzdn+DYO0T
pF7La3MZP1qpNo9DeUSR+TDKL6hS8W6PayfMJzPS5jufPFW7NiBv5n1WP+yPYKzx
+peHdjbKcMZVRAWpSlXSvS98idr0i3iCCIRRIcltahJpxWoxrJxG5/i1YKuS/L7a
uL/tW8MZi7yGuT+KKezkfy3yWTo2jgSf9eZngbSR/9xOenzINseQcW41bqm5XNLe
NW0Ih73s3HfJKOmfRIyR9QylPHfNLf+vWs7ST6JiKHTlE1XMlYxboRzehXF+A4hW
McxBQKrFmzDwmvRRwNxXZwfP7h9Li+AiORa0nfge8GXAJUtps3CGtW0FD2eDcdgq
3vohEuF3GZZsBdNbYaDJe5ofykJpebzTPJOpiyr2r4kNVutZN3P29Gsp+QNVrpq/
e2yrgqAkJfZdrG4ChUn1gPk73CZQR8vgr1UytKrOI+xhA+f+E8p/yqm6cyPTZf9t
JQcUMMl9XxOQIegFXhpKTkVVA6Pyn52cvk+PeV9lCaTvteBLSEThi0hulymxH4O3
1Oz4p5qErm85RtNiDuTNx9fFzFE1Iynhz3uH3qKs2zXxG8xykFlc8BpHaYmL1vyV
7/qZnIwzPa2YYBFIzeS93nOvC9b+V2vGYRcA0mR2VpPm1UzlWvc=
=vS+T
-----END PGP SIGNATURE-----


Closed
?