[PATCH] gnu: scdoc: Set PREFIX instead of patching Makefile.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brendan Tildesley
  • Marius Bakke
Owner
unassigned
Submitted by
Brendan Tildesley
Severity
normal
B
B
Brendan Tildesley wrote on 28 Oct 2019 16:46
(address . guix-patches@gnu.org)
20191028154633.3483-1-mail@brendan.scot
scdoc installs a scdoc.pc file in lib/pkgconfig, but it embeds
prefix=/usr/local unless the Makefile was patched before 'build. However, it
seemed better to simply set the PREFIX make-flag instead, since the Makefile
correctly checks for it. Diffoscope shows the output is identical with either
method.

* gnu/packages/man.scm (scdoc)[arguments]: Set PREFIX instead of patching
Makefile with output path.
---
gnu/packages/man.scm | 10 +++-------
1 file changed, 3 insertions(+), 7 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index de2377a14e..dc55e0a4ed 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -251,15 +251,11 @@ automatically.")
"00zc3rzj97gscby31djlqyczvqpyhrl66i44czwzmmn7rc5j03m1"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags '("CC=gcc")
+ `(#:make-flags
+ (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
- (delete 'configure)
- (add-before 'install 'hardcode-paths
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "Makefile"
- (("/usr/local") (assoc-ref outputs "out")))
- #t)))))
+ (delete 'configure))))
(home-page "https://git.sr.ht/~sircmpwn/scdoc")
(synopsis "Simple man page generator")
(description "scdoc is a simple man page generator written for POSIX systems
--
2.23.0
M
M
Marius Bakke wrote on 28 Oct 2019 23:01
87y2x4ttr0.fsf@devup.no
Brendan Tildesley <mail@brendan.scot> writes:

Toggle quote (9 lines)
> scdoc installs a scdoc.pc file in lib/pkgconfig, but it embeds
> prefix=/usr/local unless the Makefile was patched before 'build. However, it
> seemed better to simply set the PREFIX make-flag instead, since the Makefile
> correctly checks for it. Diffoscope shows the output is identical with either
> method.
>
> * gnu/packages/man.scm (scdoc)[arguments]: Set PREFIX instead of patching
> Makefile with output path.

Good catch, applied!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl23ZSMACgkQoqBt8qM6
VPqPnAgArexoBlGfLidzdb8gYr40bdC0tlThsNlZ/zpIdBlHuhzq+m/BOw6OTv6z
gDZ7hrP2EEEdPT51XaWNejasDJCqYkR8GnEHTlFbxjyZ/dtlLCJd6TLVaGskN/lt
iaUjaqInjpgrq9IT3LvIZZPEHAw7xfa8bi2bsXcB9IpnyHi2het+G6oRkI0ftz7c
C0oCq6OeT4af/At7aXDVu/f0ezUc4C31tEmDulVLpwNq2XlTT9abX6g0rRlR8BRj
vDH2HZ9Q6mgJ0LMQn1E8AC3QaffPFCAYylGNio/k7sw0i6BBo5GgwtUkWhcVKj9/
LfEb6immbfbasn7ZD48BwNisfsL+AA==
=4HQ+
-----END PGP SIGNATURE-----

Closed
?