[PATCH] gnu: bitcoin-abc: Update to 0.20.4.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Marius Bakke
Owner
unassigned
Submitted by
Guillaume Le Vaillant
Severity
normal
G
G
Guillaume Le Vaillant wrote on 19 Oct 2019 20:48
(address . guix-patches@gnu.org)(name . Guillaume Le Vaillant)(address . glv@posteo.net)
20191019184837.21457-1-glv@posteo.net
* gnu/packages/finance.scm (bitcoin-abc): Update to 0.20.4.
[source]: Fix uri.
[inputs]: Use bdb-5.3 (bdb-4.8 is not supported).
[arguments]: Add 'fix-tests' phase.
---
gnu/packages/finance.scm | 26 +++++++++++++++++++++++---
1 file changed, 23 insertions(+), 3 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 960e3adeb3..0ab6489aeb 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1133,15 +1133,35 @@ Trezor wallet.")
(package
(inherit bitcoin-core)
(name "bitcoin-abc")
- (version "0.19.8")
+ (version "0.20.4")
(source (origin
(method url-fetch)
(uri (string-append "https://download.bitcoinabc.org/"
- version "/linux/src/bitcoin-abc-"
+ version "/src/bitcoin-abc-"
version ".tar.gz"))
(sha256
(base32
- "0ndvkxv5m8346bdhfqzgdiz1k9wyjycj05jp7daf9pml3cw79sz5"))))
+ "0fld54z3l7z7k5n35rrjichjnx37j9xp0rv8i69m3x4qfj1xk2np"))))
+ (inputs
+ `(("bdb" ,bdb-5.3)
+ ("boost" ,boost)
+ ("libevent" ,libevent)
+ ("miniupnpc" ,miniupnpc)
+ ("openssl" ,openssl)
+ ("protobuf" ,protobuf)
+ ("qtbase" ,qtbase)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments bitcoin-core)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'fix-tests
+ ;; Disable 'check-devtools' test which tries to run a
+ ;; python script that doesn't exist.
+ (lambda _
+ (substitute* "Makefile.in"
+ (("^check-local: check-devtools")
+ "check-local:"))
+ #t))))))
(home-page "https://www.bitcoinabc.org/")
(synopsis "Bitcoin ABC peer-to-peer full node for the Bitcoin Cash protocol")
(description
--
2.23.0
M
M
Marius Bakke wrote on 1 Nov 2019 00:23
(name . Guillaume Le Vaillant)(address . glv@posteo.net)
87tv7oo5xa.fsf@devup.no
Guillaume Le Vaillant <glv@posteo.net> writes:

Toggle quote (5 lines)
> * gnu/packages/finance.scm (bitcoin-abc): Update to 0.20.4.
> [source]: Fix uri.
> [inputs]: Use bdb-5.3 (bdb-4.8 is not supported).
> [arguments]: Add 'fix-tests' phase.

[...]

Toggle quote (13 lines)
> + (arguments
> + (substitute-keyword-arguments (package-arguments bitcoin-core)
> + ((#:phases phases)
> + `(modify-phases ,phases
> + (add-after 'unpack 'fix-tests
> + ;; Disable 'check-devtools' test which tries to run a
> + ;; python script that doesn't exist.
> + (lambda _
> + (substitute* "Makefile.in"
> + (("^check-local: check-devtools")
> + "check-local:"))
> + #t))))))

Do you know why this script is not distributed? Should we provide it,
or was it a packaging mistake upstream?

In any case I pushed this patch in
28d46d9d4317180b348ad5baeddad8ef25ed430a. Thank you!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl27bQEACgkQoqBt8qM6
VPqz0QgA1CZwHiBED+NENN8JmzhemZYwF+IBK/8H77s7Xu7PwG57oNZ6bAIqmekR
dAKjOaJ5dCAvsfk8FMffHMUjfW2cK9J9+EL6wRQWPbSTSmZ7iYYvRnJFQOFvGCUH
OCIe9VlUfJY9pBS42NVJ30jIrBvnPwO+cfMNCc5kFoQ+mUQ9s/bN/na/rim4+kki
7j+OrHN1A2CQukROxH0+p+bcCM2Wx5lCjbFjocdVw2J2GlFqG/xhLGPktALPlZMm
8TGSs5bTFqo2/RaVec9Z4fT5VdTN3Zq9cWvDkwQ3J93+fEJKuANfcKZg/rEIProa
BF7VODVMTZ6KcTTdQseHBwi9ITnTgg==
=wiqW
-----END PGP SIGNATURE-----

Closed
G
G
Guillaume Le Vaillant wrote on 1 Nov 2019 11:18
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 37825@debbugs.gnu.org)
87tv7nlx1q.fsf@yamatai
Marius Bakke skribis:

Toggle quote (28 lines)
> Guillaume Le Vaillant <glv@posteo.net> writes:
>
>> * gnu/packages/finance.scm (bitcoin-abc): Update to 0.20.4.
>> [source]: Fix uri.
>> [inputs]: Use bdb-5.3 (bdb-4.8 is not supported).
>> [arguments]: Add 'fix-tests' phase.
>
> [...]
>
>> + (arguments
>> + (substitute-keyword-arguments (package-arguments bitcoin-core)
>> + ((#:phases phases)
>> + `(modify-phases ,phases
>> + (add-after 'unpack 'fix-tests
>> + ;; Disable 'check-devtools' test which tries to run a
>> + ;; python script that doesn't exist.
>> + (lambda _
>> + (substitute* "Makefile.in"
>> + (("^check-local: check-devtools")
>> + "check-local:"))
>> + #t))))))
>
> Do you know why this script is not distributed? Should we provide it,
> or was it a packaging mistake upstream?
>
> In any case I pushed this patch in
> 28d46d9d4317180b348ad5baeddad8ef25ed430a. Thank you!

I'm not sure if it's a packaging mistake or a makefile mistake (if these
tests are not supposed to be run on a release version). They are tests
to check that some development tools work correctly (e.g. tools to
generate a header file which is included in the release tarball, to
update the copyright years in the headers, etc).
M
M
Marius Bakke wrote on 3 Nov 2019 18:11
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 37825@debbugs.gnu.org)
87r22oopex.fsf@devup.no
Guillaume Le Vaillant <glv@posteo.net> writes:

Toggle quote (36 lines)
> Marius Bakke skribis:
>
>> Guillaume Le Vaillant <glv@posteo.net> writes:
>>
>>> * gnu/packages/finance.scm (bitcoin-abc): Update to 0.20.4.
>>> [source]: Fix uri.
>>> [inputs]: Use bdb-5.3 (bdb-4.8 is not supported).
>>> [arguments]: Add 'fix-tests' phase.
>>
>> [...]
>>
>>> + (arguments
>>> + (substitute-keyword-arguments (package-arguments bitcoin-core)
>>> + ((#:phases phases)
>>> + `(modify-phases ,phases
>>> + (add-after 'unpack 'fix-tests
>>> + ;; Disable 'check-devtools' test which tries to run a
>>> + ;; python script that doesn't exist.
>>> + (lambda _
>>> + (substitute* "Makefile.in"
>>> + (("^check-local: check-devtools")
>>> + "check-local:"))
>>> + #t))))))
>>
>> Do you know why this script is not distributed? Should we provide it,
>> or was it a packaging mistake upstream?
>>
>> In any case I pushed this patch in
>> 28d46d9d4317180b348ad5baeddad8ef25ed430a. Thank you!
>
> I'm not sure if it's a packaging mistake or a makefile mistake (if these
> tests are not supposed to be run on a release version). They are tests
> to check that some development tools work correctly (e.g. tools to
> generate a header file which is included in the release tarball, to
> update the copyright years in the headers, etc).

I see, thanks for the explanation. Perhaps we are simply using the
wrong Makefile target? By default gnu-build-system runs 'make check' in
the 'check' phase: some packages use 'make test' or 'make ci' instead.

Something to look out for in the next version. :-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl2/ClcACgkQoqBt8qM6
VPqtgwf+O/bNWF7RWcvTbZWX7XBbC9njVW+JcMv5fcqkoLD4GwTSSIdgvmCBYdQr
tYUTz3EY2W4C0EjosTD79kUe0Wn+13sXvLzYfttbIimOlNxRwROYUbBpKQlHwh7O
dOBI1F5YB9TjeFZmLsrtRCGXKX81bYMrjqTBtlq9q0oV3+cObTpN4lNUb0b6YSLZ
yaSNVuJUd9nYTPyPAGy09GlYryivvdyPEC6IZt76M6H4mylS03ZPj9pXCtZI3cvZ
IDwNDhHDuJqnjztnQG796yQDaMei0D1s4s2u0lVThJrx5yAkZP5FORX40M5h5mgn
8HtU6rKzNfK3c9o83V5bQUCZ+882gA==
=oihI
-----END PGP SIGNATURE-----

?