[PATCH] gnu: Add minisign.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Tanguy Le Carrour
Owner
unassigned
Submitted by
Tanguy Le Carrour
Severity
normal
T
T
Tanguy Le Carrour wrote on 17 Oct 2019 10:02
(name . Guix)(address . guix-patches@gnu.org)
20191017080233.dcsjsyh5ui6x67kj@rafflesia

From 7d5c08fd00e9cd5d883fc939187ce6fc6e8c45f7 Mon Sep 17 00:00:00 2001
From: Tanguy Le Carrour <tanguy@bioneland.org>
Date: Thu, 17 Oct 2019 09:57:28 +0200
Subject: [PATCH] gnu: Add minisign.

* gnu/packages/crypto.scm (minisign): New public variable.
---
gnu/packages/crypto.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 9592d18011..baf7c81a6a 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -974,3 +974,37 @@ pre-shared keys out of band. It is designed to handle large amounts of data
quickly by using all your CPU cores and hardware acceleration.")
(home-page "https://github.com/vstakhov/hpenc")
(license license:bsd-3)))
+
+(define-public minisign
+ (package
+ (name "minisign")
+ (version "0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/jedisct1/minisign/releases/download/"
+ version "/minisign-" version ".tar.gz"))
+ (sha256
+ (base32
+ "10hhgwxf9rcdlr00shrkcyxndrc22dh5lj8k5z27xg3nc0jba3hk"))))
+ (build-system cmake-build-system)
+ (arguments
+ ; No test suite
+ `(#:tests? #f))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libsodium" ,libsodium)))
+ (home-page "https://jedisct1.github.io/minisign")
+ (synopsis "Tool to sign files and verify signatures")
+ (description
+ "Minisign is a dead simple tool to sign files and verify signatures. It is
+portable, lightweight, and uses the highly secure Ed25519 public-key signature
+system. Signature written by minisign can be verified using OpenBSD's
+signify tool: public key files and signature files are compatible. However,
+minisign uses a slightly different format to store secret keys. Minisign
+signatures include trusted comments in addition to untrusted comments.
+Trusted comments are signed, thus verified, before being displayed.")
+ (license license:isc)))
+
--
2.23.0
T
T
Tanguy Le Carrour wrote on 17 Oct 2019 10:09
(address . 37788@debbugs.gnu.org)
20191017080954.rxj4m7dmelakx7zv@rafflesia
Remove new blank line at EOF.
From 467e7d9566cc655c4ea226769b76c8d803ecb4d4 Mon Sep 17 00:00:00 2001
From: Tanguy Le Carrour <tanguy@bioneland.org>
Date: Thu, 17 Oct 2019 09:57:28 +0200
Subject: [PATCH] gnu: Add minisign.

* gnu/packages/crypto.scm (minisign): New public variable.
---
gnu/packages/crypto.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 9592d18011..9ab15a6395 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -974,3 +974,36 @@ pre-shared keys out of band. It is designed to handle large amounts of data
quickly by using all your CPU cores and hardware acceleration.")
(home-page "https://github.com/vstakhov/hpenc")
(license license:bsd-3)))
+
+(define-public minisign
+ (package
+ (name "minisign")
+ (version "0.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/jedisct1/minisign/releases/download/"
+ version "/minisign-" version ".tar.gz"))
+ (sha256
+ (base32
+ "10hhgwxf9rcdlr00shrkcyxndrc22dh5lj8k5z27xg3nc0jba3hk"))))
+ (build-system cmake-build-system)
+ (arguments
+ ; No test suite
+ `(#:tests? #f))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libsodium" ,libsodium)))
+ (home-page "https://jedisct1.github.io/minisign")
+ (synopsis "Tool to sign files and verify signatures")
+ (description
+ "Minisign is a dead simple tool to sign files and verify signatures. It is
+portable, lightweight, and uses the highly secure Ed25519 public-key signature
+system. Signature written by minisign can be verified using OpenBSD's
+signify tool: public key files and signature files are compatible. However,
+minisign uses a slightly different format to store secret keys. Minisign
+signatures include trusted comments in addition to untrusted comments.
+Trusted comments are signed, thus verified, before being displayed.")
+ (license license:isc)))
--
2.23.0
M
M
Mathieu Othacehe wrote on 17 Oct 2019 17:32
(address . guix-patches@gnu.org)(address . 37788@debbugs.gnu.org)
874l07gzf9.fsf@gmail.com
Hello Tanguy,

Toggle quote (2 lines)
> Remove new blank line at EOF.

Please pass --subject-prefix="PATCH v2" to git format-patch so that it
is easier to identify patch revisions.

Toggle quote (2 lines)
> + ; No test suite

You can put it on the same line as the one below.

Toggle quote (2 lines)
> + `(#:tests? #f))

You also did forget to add the Copyright on top.

Otherwise seems fine :). I fixed the points above and pushed it.

Mathieu
M
M
Mathieu Othacehe wrote on 18 Oct 2019 10:26
control message for bug #37788
(address . control@debbugs.gnu.org)
87zhhyfoib.fsf@gmail.com
close 37788
quit
T
T
Tanguy Le Carrour wrote on 18 Oct 2019 12:03
Re: [bug#37788] [PATCH] gnu: Add minisign.
(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)(address . 37788@debbugs.gnu.org)
20191018100310.odkacqejqpes7f7i@rafflesia
Hello Mathieu!

Thanks for reviewing!

From: Mathieu Othacehe <m.othacehe <at> gmail.com>
Toggle quote (3 lines)
> Please pass --subject-prefix="PATCH v2" to git format-patch so that it
> is easier to identify patch revisions.

I'll try to keep that it mind for next time!


Toggle quote (4 lines)
>> + ; No test suite
>You can put it on the same line as the one below.
>> + `(#:tests? #f))

I did… then ran etc/indent-code.el which pushed the comment far away on
the right. It looked weird, so I moved it above. Next time I'll leave it
where the indent-code script puts it.


Toggle quote (2 lines)
>You also did forget to add the Copyright on top.

*Oups*… thanks for noticing!


Toggle quote (2 lines)
>Otherwise seems fine :). I fixed the points above and pushed it.

Thanks!


--
Tanguy
?