[PATCH] gnu: Add arrows.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Pierre Neidhardt
Owner
unassigned
Submitted by
Guillaume Le Vaillant
Severity
normal
G
G
Guillaume Le Vaillant wrote on 15 Oct 2019 13:54
(address . guix-patches@gnu.org)(name . Guillaume Le Vaillant)(address . glv@posteo.net)
20191015115416.8167-1-glv@posteo.net
* gnu/packages/lisp.scm (cl-arrows, sbcl-arrows, ecl-arrows): New variables.
---
gnu/packages/lisp.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 2bdebed04e..716014c67d 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -7718,3 +7718,35 @@ supplement, not a competitor, to Alexandria.")
(define-public cl-serapeum
(sbcl-package->cl-source-package sbcl-serapeum))
+
+(define-public sbcl-arrows
+ (let ((commit "df7cf0067e0132d9697ac8b1a4f1b9c88d4f5382")
+ (revision "0"))
+ (package
+ (name "sbcl-arrows")
+ (version (git-version "0.2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/Harleqin/arrows.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "042k9vkssrqx9nhp14wdzm942zgdxvp35mba0p2syz98i75im2yy"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("hu.dwim.stefil" ,sbcl-hu.dwim.stefil)))
+ (synopsis "Clojure-like arrow macros for Common Lisp")
+ (description
+ "This library implements the @code{->} and @code{->>} macros from
+Clojure, as well as several expansions on the idea.")
+ (home-page "https://gitlab.com/Harleqin/arrows")
+ (license license:public-domain))))
+
+(define-public cl-arrows
+ (sbcl-package->cl-source-package sbcl-arrows))
+
+(define-public ecl-arrows
+ (sbcl-package->ecl-package sbcl-arrows))
--
2.23.0
P
P
Pierre Neidhardt wrote on 18 Oct 2019 10:56
control message for bug #37763
(address . control@debbugs.gnu.org)
87eezal9e2.fsf@ambrevar.xyz
close 37763
quit
?