[PATCH] gnu: Add emacs-dimmer.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Stephen Webber
Owner
unassigned
Submitted by
Stephen Webber
Severity
normal
S
S
Stephen Webber wrote on 13 Oct 2019 17:38
(address . guix-patches@gnu.org)(name . Stephen Webber)(address . montokapro@gmail.com)
20191013153852.22414-1-montokapro@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-dimmer): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a55282a0a9..50f797a50c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -54,6 +54,7 @@
;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2019 Stephen Webber <montokapro@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18945,3 +18946,28 @@ Emacs that integrate with major modes like Org-mode.")
"Elixir-Mode Provides font-locking, indentation and navigation support
for the Elixir programming language.")
(license license:gpl3+)))
+
+(define-public emacs-dimmer
+ (let ((commit "12fc52a6570ec25020281735f5a0ca780a9105af"))
+ (package
+ (name "emacs-dimmer")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gonewest818/dimmer.el.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jv9rrv15nb5hpwcaqlpjj932gyisrkwbv11czkg3v0bn7qn6yif"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/gonewest818/dimmer.el")
+ (synopsis "Visually highlights the selected buffer in Emacs")
+ (description "Dimmer provides a minor mode that indicates which buffer is
+currently active by dimming the faces in the other buffers. It
+does this nondestructively, and computes the dimmed faces
+dynamically such that your overall color scheme is shown in a muted
+form without requiring you to define what is a \"dim\" version of
+every face.")
+ (license license:gpl3+))))
--
2.23.0
N
N
Nicolas Goaziou wrote on 14 Oct 2019 17:21
(name . Stephen Webber)(address . montokapro@gmail.com)(address . 37736-done@debbugs.gnu.org)
87k197bbe7.fsf@nicolasgoaziou.fr
Hello,

Stephen Webber <montokapro@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-dimmer): New variable.

I applied your patch with the following changes:

Toggle quote (3 lines)
> +(define-public emacs-dimmer
> + (let ((commit "12fc52a6570ec25020281735f5a0ca780a9105af"))

I removed this.

Toggle quote (10 lines)
> + (package
> + (name "emacs-dimmer")
> + (version "0.3.0")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/gonewest818/dimmer.el.git")
> + (commit commit)))

I replaced `commit' with `version', since they were equivalents.

Thank you.

Regards,

--
Nicolas Goaziou
Closed
?