[PATCH] gnu: Add libspatialindex.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Wiktor ?elazny
Owner
unassigned
Submitted by
Wiktor ?elazny
Severity
normal
W
W
Wiktor ?elazny wrote on 4 Oct 2019 15:25
(address . guix-patches@gnu.org)
20191004132516.16761-1-wz@freeshell.de
From: Wiktor ?elazny <wzelazny@vurv.cz>

* gnu/packages/geo.scm (libspatialindex): new variable.
---
gnu/packages/geo.scm | 41 ++++++++++++++++++++++++++++++++++++++++-
1 file changed, 40 insertions(+), 1 deletion(-)

Toggle diff (65 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 5e1f7e39d7..1d635c4f1f 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 Wiktor ?elazny <wzelazny@vurv.cz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -65,7 +66,8 @@
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
#:use-module (gnu packages wxwidgets)
- #:use-module (gnu packages xml))
+ #:use-module (gnu packages xml)
+ #:use-module (ice-9 regex))
(define-public geos
(package
@@ -996,3 +998,40 @@ XyGrib is the continuation of the zyGrib software package with a new team of
volunteers.")
(home-page "https://opengribs.org")
(license license:gpl3+)))
+
+(define-public libspatialindex
+ (package
+ (name "libspatialindex")
+ (version "1.8.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://download.osgeo.org/" name "/"
+ (regexp-substitute #f (string-match "^lib" name) 'pre "" 'post)
+ "-src-" version ".tar.gz"))
+ (sha256
+ (base32
+ ; checked <uri>.md5
+ "1vxzm7kczwnb6qdmc0hb00z8ykx11zk3sb68gc7rch4vrfi4dakw"))))
+ (build-system gnu-build-system)
+ (home-page "https://libspatialindex.org")
+ (synopsis "Spatial indexing library")
+ (description "The purpose of this library is to provide:
+
+@itemize
+ @item An extensible framework that will support robust spatial indexing
+methods.
+ @item Support for sophisticated spatial queries. Range, point location,
+ nearest neighbor and k-nearest neighbor as well as parametric queries (defined
+by spatial constraints) should be easy to deploy and run.
+ @item Easy to use interfaces for inserting, deleting and updating information.
+ @item Wide variety of customization capabilities. Basic index and storage
+characteristics like the page size, node capacity, minimum fan-out, splitting
+algorithm, etc. should be easy to customize.
+ @item Index persistence. Internal memory and external memory structures
+should be supported. Clustered and non-clustered indices should be easy to be
+persisted.
+@end itemize
+")
+ (license license:expat)))
--
2.23.0
L
L
Ludovic Courtès wrote on 4 Nov 2019 23:34
(name . Wiktor ?elazny)(address . wz@freeshell.de)(address . 37619-done@debbugs.gnu.org)
87h83j46f0.fsf@gnu.org
Hi Wiktor,

Wiktor ?elazny <wz@freeshell.de> skribis:

Toggle quote (4 lines)
> From: Wiktor ?elazny <wzelazny@vurv.cz>
>
> * gnu/packages/geo.scm (libspatialindex): new variable.

Applied with the minor changes below: no fancy regexp matching to build
up the URL :-), and slight reindentation.

Thanks!

Ludo’.
Toggle diff (30 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 37549cab3f..e49e0b6db6 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -67,8 +67,7 @@
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
#:use-module (gnu packages wxwidgets)
- #:use-module (gnu packages xml)
- #:use-module (ice-9 regex))
+ #:use-module (gnu packages xml))
(define-public geos
(package
@@ -1007,13 +1006,10 @@ volunteers.")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://download.osgeo.org/" name "/"
- (regexp-substitute #f (string-match "^lib" name) 'pre "" 'post)
- "-src-" version ".tar.gz"))
+ (uri (string-append "https://download.osgeo.org/libspatialindex/"
+ "spatialindex-src-" version ".tar.gz"))
(sha256
(base32
- ; checked <uri>.md5
"1vxzm7kczwnb6qdmc0hb00z8ykx11zk3sb68gc7rch4vrfi4dakw"))))
(build-system gnu-build-system)
(home-page "https://libspatialindex.org")
Closed
W
W
Wiktor ?elazny wrote on 9 Nov 2019 12:39
(address . 37619-done@debbugs.gnu.org)
20191109113952.f6zfpphdmscj3ayj@wz.localdomain
On Mon, Nov 04, 2019 at 11:34:43PM +0100, Ludovic Courtès wrote:

Toggle quote (2 lines)
> Applied with the minor changes below:

Thanks. This opens the way to QGIS, which I’ve been struggling with.

Toggle quote (2 lines)
> no fancy regexp matching to build up the URL :-),

LOL!

Toggle quote (2 lines)
> and slight reindentation.

What’s the indentation rule? I notice that you’re mixing double and
single spaces. Is that intentional?

Also, you removed the md5 comment. I thought it would be nice to put it
there as a reminder for whoever is updating the definition for a new
version of this library to make a new md5 check (Guix Manual insists
that these should be done).

W?
-----BEGIN PGP SIGNATURE-----

iQKTBAABCgB9FiEEvcl0zdnJun12Glc9xzWoxqtgedUFAl3GpYdfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldEJE
Qzk3NENERDlDOUJBN0Q3NjFBNTczREM3MzVBOEM2QUI2MDc5RDUACgkQxzWoxqtg
edVxPg//We1MEX+5UCcIu7SialtkdLXqGzQVrfbZDlI38VM6y0/7bnnGtVaI9h9m
HvjpVU97bvIJlk8qgZFiBZhXtLGKt7lBD2pCv7swopboHzdN/mkojRqbSEsU2ihK
h4Z3pY9xc1qVARuG8jfM8OTg28XpJWXzmK1vwzGp83Rn9zj9Wx5UtvjyY23r89JA
gnqqENGvkijYxb0DG1wuLO4pb5pz4hOG1ImRo+1HKPFKkrlVch3O8vwwtTJBCySc
G/y6CEJVwbd0rxtvMdhL0pEyaodeNARjYXWrRxSFhCmOZnGKeejml6fMUX3/QvoF
yQDRQCiZt89RDJYiquq+eqsG6WaV9QOriwXHRktZvBgFELusc4b+xsv4ZHSMUtDq
P8SdSMAcLBUPnrufXc8/HxsVKu73FC4Zc8AxLX/cRstxzm0Hc/D6e97YyJVxlRGE
VatWZ3W/LF6ORmM+c/YITvRCzBHIyWYr6cyyykSxGjzctugB7mi+/1s0IUYj8bGA
6q/HcWc/3a41qWOqMIgl9fEbUQNLUNA5ai5cekJTbQxxYhpXFZBwLWGDpnS4Cbq8
5VBzNecESRqcON0vsnlqZeKY7GeodRR2nrIkWvB3xbF3rBD7QTOQoAZvsmuw0AsW
i6e1hEbh1qfa0UQc51NlZ82G/fUfGtYVrhoWRne3YoNjkfnS5tk=
=sCsF
-----END PGP SIGNATURE-----


Closed
?