[PATCH] gnu: Add ruby-wayback-machine-downloader.

  • Done
  • quality assurance status badge
Details
2 participants
  • Diego Nicola Barbato
  • Ludovic Courtès
Owner
unassigned
Submitted by
Diego Nicola Barbato
Severity
normal
D
D
Diego Nicola Barbato wrote on 2 Oct 2019 12:37
(address . guix-patches@gnu.org)
878sq3wi04.fsf@GlaDOS.home
Hello Guix,

The following patch adds a Ruby program for downloading archived
websites from archive.org. The gem contains no tests and while there
are tests on the github repository, those do require network access.
That's why I left the source as returned by the importer.

Regards,

Diego
From 1f28318ef8e7c11ff15f09778420567b7dc80e49 Mon Sep 17 00:00:00 2001
From: Diego Nicola Barbato <dnbarbato@posteo.de>
Date: Tue, 1 Oct 2019 16:06:57 +0200
Subject: [PATCH] gnu: Add ruby-wayback-machine-downloader.

* gnu/packages/ruby.scm (ruby-wayback-machine-downloader): New variable.
---
gnu/packages/ruby.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a886a1cdd2..86143277b1 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 Collin J. Doering <collin@rekahsoft.ca>
+;;; Copyright © 2019 Diego N. Barbato <dnbarbato@posteo.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8954,3 +8955,29 @@ programming: intellisense, diagnostics, inline documentation, and type
checking.")
(home-page "https://solargraph.org/")
(license license:expat)))
+
+(define-public ruby-wayback-machine-downloader
+ (package
+ (name "ruby-wayback-machine-downloader")
+ (version "2.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri
+ "wayback_machine_downloader"
+ version))
+ (sha256
+ (base32
+ "12kb1qmvmmsaihqab1prn6cmynkn6cgb4vf41mgv22wkcgv5wgk2"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; no tests
+ (synopsis "Download archived websites from the Wayback Machine")
+ (description
+ "Wayback Machine Downloader is a command line tool for downloading
+websites from the Internet Archive's Wayback Machine (archive.org).
+It allows fine grained control over what to download by specifying
+which snapshots to consider and what files to include.")
+ (home-page
+ "https://github.com/hartator/wayback-machine-downloader")
+ (license license:expat)))
--
2.23.0
L
L
Ludovic Courtès wrote on 25 Oct 2019 12:35
(name . Diego Nicola Barbato)(address . dnbarbato@posteo.de)(address . 37581-done@debbugs.gnu.org)
87h83xru2q.fsf@gnu.org
Hi Diego,

Diego Nicola Barbato <dnbarbato@posteo.de> skribis:

Toggle quote (5 lines)
> The following patch adds a Ruby program for downloading archived
> websites from archive.org. The gem contains no tests and while there
> are tests on the github repository, those do require network access.
> That's why I left the source as returned by the importer.

OK.

Toggle quote (7 lines)
>>From 1f28318ef8e7c11ff15f09778420567b7dc80e49 Mon Sep 17 00:00:00 2001
> From: Diego Nicola Barbato <dnbarbato@posteo.de>
> Date: Tue, 1 Oct 2019 16:06:57 +0200
> Subject: [PATCH] gnu: Add ruby-wayback-machine-downloader.
>
> * gnu/packages/ruby.scm (ruby-wayback-machine-downloader): New variable.

Applied. Thank you, and sorry for the delay!

Ludo’.
Closed
?