[PATCH] gnu: Add ccls.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Mathieu Othacehe
Severity
normal
M
M
Mathieu Othacehe wrote on 25 Sep 2019 12:52
(address . guix-patches@gnu.org)(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)
20190925105224.3683-1-m.othacehe@gmail.com
* gnu/packages/cpp.scm (ccls): New variable.
---
gnu/packages/cpp.scm | 32 +++++++++++++++++++++++++++++++-
1 file changed, 31 insertions(+), 1 deletion(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 9e95bacd65..277274e60f 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,7 +34,8 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages llvm)
#:use-module (gnu packages pkg-config)
- #:use-module (gnu packages tls))
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages web))
(define-public libzen
(package
@@ -276,3 +278,31 @@ intuitive syntax and trivial integration.")
(description "xtl is a C++ header-only template library providing basic
tools (containers, algorithms) used by other QuantStack packages.")
(license license:bsd-3)))
+
+(define-public ccls
+ (package
+ (name "ccls")
+ (version "0.20190823.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/MaskRay/ccls")
+ (commit version)))
+ (sha256
+ (base32 "1sx31zp6q2qc6fz3r78rx34zp2x4blrqzxwbpww71vb6lp1clmdm"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f)) ; no check target.
+ (inputs
+ `(("rapidjson" ,rapidjson)))
+ (native-inputs
+ `(("clang" ,clang)
+ ("llvm" ,llvm)))
+ (home-page "https://github.com/MaskRay/ccls")
+ (synopsis "C/C++/Objective-C language server")
+ (description
+ "C/C++/Objective-C language server supporting cross references,
+hierarchies, completion and syntax highlighting.")
+ (license license:asl2.0)))
--
2.23.0
L
L
Ludovic Courtès wrote on 26 Sep 2019 11:32
(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)(address . 37511@debbugs.gnu.org)
87lfubpflk.fsf@gnu.org
Hi,

Mathieu Othacehe <m.othacehe@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/cpp.scm (ccls): New variable.

[...]

Toggle quote (6 lines)
> + (synopsis "C/C++/Objective-C language server")
> + (description
> + "C/C++/Objective-C language server supporting cross references,
> +hierarchies, completion and syntax highlighting.")

Could you write a full sentence and ideally elaborate a little bit?

Otherwise LGTM!

Thanks,
Ludo’.
M
M
Mathieu Othacehe wrote on 26 Sep 2019 13:55
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 37511@debbugs.gnu.org)
87h84zjmqt.fsf@gmail.com
Hey,

Toggle quote (2 lines)
> Could you write a full sentence and ideally elaborate a little bit?

Fixed and pushed on core-updates as it needs gcc7.

Thanks,

Mathieu
M
M
Mathieu Othacehe wrote on 27 Sep 2019 08:32
control message for bug #37511
(address . control@debbugs.gnu.org)
87o8z6dzal.fsf@gmail.com
close 37511
quit
?