[PATCH] gnu: Add r-assertable.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Wiktor ?elazny
Owner
unassigned
Submitted by
Wiktor ?elazny
Severity
normal
W
W
Wiktor ?elazny wrote on 16 Sep 2019 18:18
(address . guix-patches@gnu.org)
20190916161806.24226-1-wz@freeshell.de
From: Wiktor ?elazny <wzelazny@vurv.cz>

* gnu/packages/cran.scm (r-assertable): New variable.
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index cb0be4aedd..89a581cb5e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15610,3 +15610,30 @@ deprecated, and defunct). It makes it easy to insert badges corresponding to
these stages in your documentation. Usage of deprecated functions are
signalled with increasing levels of non-invasive verbosity.")
(license license:gpl3)))
+
+(define-public r-assertable
+ (package
+ (name "r-assertable")
+ (version "0.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "assertable" version))
+ (sha256
+ (base32
+ "0jjd6ylh26fykzzv1q2lbajzfj07lyxwb3b3xmr2zdg2fp5b2w4c"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-data-table" ,r-data-table)))
+ (home-page "https://cran.r-project.org/web/packages/assertable/")
+ (synopsis "Verbose assertions for tabular data (data.frames and data.tables)")
+ (description "This package provides simple, flexible assertions on
+data.frame or data.table objects with verbose output for vetting. While other
+assertion packages apply towards more general use-cases, @code{assertable} is
+tailored towards tabular data. It includes functions to check variable names
+and values, whether the dataset contains all combinations of a given set of
+unique identifiers, and whether it is a certain length. In addition,
+@code{assertable} includes utility functions to check the existence of target
+files and to efficiently import multiple tabular data files into one
+data.table.")
+ (license license:gpl3)))
--
2.23.0
L
L
Ludovic Courtès wrote on 25 Sep 2019 15:46
(name . Wiktor ?elazny)(address . wz@freeshell.de)(address . 37430-done@debbugs.gnu.org)
87sgoklc98.fsf@gnu.org
Hi,

Wiktor ?elazny <wz@freeshell.de> skribis:

Toggle quote (4 lines)
> From: Wiktor ?elazny <wzelazny@vurv.cz>
>
> * gnu/packages/cran.scm (r-assertable): New variable.

Applied, thanks!

Ludo’.
Closed
?