[PATCH] gnu: Add autocutsel.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Wiktor ?elazny
Owner
unassigned
Submitted by
Wiktor ?elazny
Severity
normal
W
W
Wiktor ?elazny wrote on 16 Sep 2019 18:15
(address . guix-patches@gnu.org)
20190916161549.21294-1-wz@freeshell.de
From: Wiktor ?elazny <wzelazny@vurv.cz>

* gnu/packages/xdisorg.scm (autocutsel): New variable.
---
gnu/packages/xdisorg.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index bcc61f59af..4d7119a693 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Nam Nguyen <namn@berkeley.edu>
+;;; Copyright © 2019 Wiktor ?elazny <wzelazny@vurv.cz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1708,3 +1709,28 @@ temperature of the screen.")
(description "Wl-clipboard is a set of command-line copy/paste utilities for
Wayland.")
(license license:gpl3+)))
+
+(define-public autocutsel
+ (package
+ (name "autocutsel")
+ (version "0.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/sigmike/" name
+ "/releases/download/" version "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0gsys2dzh4az51ndcsabhlbbrjn2nm75lnjr45kg6r8sm8q66dx2"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f)) ; no "check" target
+ (native-inputs `(("libx11" ,libx11)
+ ("libxaw" ,libxaw)))
+ (home-page "https://www.nongnu.org/autocutsel/")
+ (synopsis "Automated X11 clipboard and cutbuffer synchronization")
+ (description "@code{autocutsel} tracks changes in the server's cutbuffer
+and clipboard selection. When the clipboard is changed, it updates the
+cutbuffer. When the cutbuffer is changed, it owns the clipboard selection.
+The cutbuffer and clipboard selection are always synchronized.")
+ (license license:gpl2)))
--
2.23.0
L
L
Ludovic Courtès wrote on 20 Sep 2019 22:45
(name . Wiktor ?elazny)(address . wz@freeshell.de)(address . 37429-done@debbugs.gnu.org)
877e62puhp.fsf@gnu.org
Hi Wiktor,

Wiktor ?elazny <wz@freeshell.de> skribis:

Toggle quote (4 lines)
> From: Wiktor ?elazny <wzelazny@vurv.cz>
>
> * gnu/packages/xdisorg.scm (autocutsel): New variable.

I took the liberty to adjust as show below: the license is ‘gpl2+’
because headers carry the “or any later version” wording. The other
changes are just purely cosmetic, for the sake of consistency.

Thank you!

Ludo’.
Toggle diff (31 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 4d7119a693..10ffa6f695 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1716,21 +1716,21 @@ Wayland.")
(version "0.10.0")
(source (origin
(method url-fetch)
- (uri (string-append "https://github.com/sigmike/" name
+ (uri (string-append "https://github.com/sigmike/autocutsel"
"/releases/download/" version "/"
- name "-" version ".tar.gz"))
+ "autocutsel-" version ".tar.gz"))
(sha256
(base32
"0gsys2dzh4az51ndcsabhlbbrjn2nm75lnjr45kg6r8sm8q66dx2"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f)) ; no "check" target
- (native-inputs `(("libx11" ,libx11)
- ("libxaw" ,libxaw)))
+ (native-inputs `(("libx11" ,libx11)
+ ("libxaw" ,libxaw)))
(home-page "https://www.nongnu.org/autocutsel/")
(synopsis "Automated X11 clipboard and cutbuffer synchronization")
(description "@code{autocutsel} tracks changes in the server's cutbuffer
and clipboard selection. When the clipboard is changed, it updates the
cutbuffer. When the cutbuffer is changed, it owns the clipboard selection.
The cutbuffer and clipboard selection are always synchronized.")
- (license license:gpl2)))
+ (license license:gpl2+)))
Closed
?