[PATCH] Add emacs-flyspell-grammalecte

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Nicolas Goaziou
Severity
normal
N
N
Nicolas Goaziou wrote on 6 Sep 2019 01:11
(address . guix-patches@gnu.org)
87mufipcda.fsf@nicolasgoaziou.fr
Hello,

The following patch adds emacs-flyspell-grammalecte.

Feedback welcome.

Regards,

--
Nicolas Goaziou
From d362da36f369d0bf98d49c484ce9fd6b0603b5b2 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Fri, 6 Sep 2019 01:10:10 +0200
Subject: [PATCH] gnu: Add emacs-flycheck-grammalecte.

* gnu/packages/emacs-xyz.scm (emacs-flycheck-grammalecte): New variable.
---
gnu/packages/emacs-xyz.scm | 54 ++++++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)

Toggle diff (74 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8f866fbc28..7ca3f8e4ca 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -88,6 +88,7 @@
#:use-module (gnu packages cmake)
#:use-module (gnu packages code)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages dictionaries)
#:use-module (gnu packages emacs)
#:use-module (gnu packages guile)
#:use-module (gnu packages gtk)
@@ -3076,6 +3077,59 @@ boundaries defined by syntax highlighting.")
for Flow files.")
(license license:gpl3+))))
+(define-public emacs-flycheck-grammalecte
+ (package
+ (name "emacs-flycheck-grammalecte")
+ (version "0.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://git.deparis.io/"
+ "flycheck-grammalecte/snapshot/"
+ "flycheck-grammalecte-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0wjm9xyra870pci4bcrbnc9x66x18mi7iz08rkxa4clxv28xzryb"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:include '("\\.(el|py)$")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-python
+ ;; Hardcode python3 executable in the Emacs library.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((python3 (string-append (assoc-ref inputs "python")
+ "/bin/python3")))
+ (substitute* "flycheck-grammalecte.el"
+ (("python3") python3))
+ #t)))
+ (add-after 'install 'link-to-grammalecte
+ ;; The package expects grammalecte to be in a sub-directory.
+ ;; Symlink it there from the store.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((grammalecte (assoc-ref inputs "grammalecte"))
+ (out (assoc-ref outputs "out"))
+ (version ,(version-major+minor (package-version python))))
+ (with-directory-excursion
+ (string-append out
+ "/share/emacs/site-lisp/guix.d/"
+ "flycheck-grammalecte-" ,version)
+ (symlink (string-append grammalecte "/lib/"
+ "python" version "/site-packages/"
+ "grammalecte")
+ "grammalecte"))))))))
+ (inputs
+ `(("grammalecte" ,grammalecte)
+ ("python" ,python)))
+ (propagated-inputs
+ `(("emacs-flycheck" ,emacs-flycheck)))
+ (home-page "https://git.deparis.io/flycheck-grammalecte/")
+ (synopsis "Integrate Grammalecte with Flycheck")
+ (description "Integrate the French grammar and typography checker
+Grammalecte with Flycheck to automatically look for mistakes in your
+writings. It also provides an easy way to find synonyms and antonyms for
+a given word (to avoid repetitions for example).")
+ (license license:gpl3+)))
+
(define-public emacs-elisp-demos
(package
(name "emacs-elisp-demos")
--
2.23.0
N
N
Nicolas Goaziou wrote on 6 Sep 2019 09:09
(address . 37317@debbugs.gnu.org)
87imq5q4sc.fsf@nicolasgoaziou.fr
Completing myself,

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (16 lines)
> + (add-after 'install 'link-to-grammalecte
> + ;; The package expects grammalecte to be in a sub-directory.
> + ;; Symlink it there from the store.
> + (lambda* (#:key inputs outputs #:allow-other-keys)
> + (let ((grammalecte (assoc-ref inputs "grammalecte"))
> + (out (assoc-ref outputs "out"))
> + (version ,(version-major+minor (package-version python))))
> + (with-directory-excursion
> + (string-append out
> + "/share/emacs/site-lisp/guix.d/"
> + "flycheck-grammalecte-" ,version)
> + (symlink (string-append grammalecte "/lib/"
> + "python" version "/site-packages/"
> + "grammalecte")
> + "grammalecte"))))))))

I forgot a #t here. I'll add it. I'm not sending the updated patch.

Toggle quote (11 lines)
> + (inputs
> + `(("grammalecte" ,grammalecte)
> + ("python" ,python)))
> + (propagated-inputs
> + `(("emacs-flycheck" ,emacs-flycheck)))
> + (home-page "https://git.deparis.io/flycheck-grammalecte/")
> + (synopsis "Integrate Grammalecte with Flycheck")
> + (description "Integrate the French grammar and typography checker
> +Grammalecte with Flycheck to automatically look for mistakes in your
> +writings. It also provides an easy way to find synonyms and antonyms for

Missing space here. Also fixed.
L
L
Ludovic Courtès wrote on 26 Sep 2019 23:11
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 37317@debbugs.gnu.org)
87ef02ix07.fsf@gnu.org
Hi Nicolas,

Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:

Toggle quote (7 lines)
>>From d362da36f369d0bf98d49c484ce9fd6b0603b5b2 Mon Sep 17 00:00:00 2001
> From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
> Date: Fri, 6 Sep 2019 01:10:10 +0200
> Subject: [PATCH] gnu: Add emacs-flycheck-grammalecte.
>
> * gnu/packages/emacs-xyz.scm (emacs-flycheck-grammalecte): New variable.

LGTM, thanks!

Ludo’.
N
N
Nicolas Goaziou wrote on 27 Sep 2019 21:48
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 37317-done@debbugs.gnu.org)
87d0fl5xm4.fsf@nicolasgoaziou.fr
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (2 lines)
> LGTM, thanks!

Applied. Thank you!

Regards,

--
Nicolas Goaziou
Closed
?