[PATCH 0/3] Improvements for monero and monero-gui

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Ludovic Courtès
Owner
unassigned
Submitted by
Guillaume Le Vaillant
Severity
normal
G
G
Guillaume Le Vaillant wrote on 4 Sep 2019 16:55
(address . guix-patches@gnu.org)
87ef0wrtzg.fsf@yamatai
Patches:
1 - Fix detection of readline library.
2 - Activate Trezor support.
3 - Update monero-gui to 0.14.1.2.
G
G
Guillaume Le Vaillant wrote on 4 Sep 2019 16:58
[PATCH 1/3] gnu: monero: Fix detection of readline library.
(address . 37303@debbugs.gnu.org)(name . Guillaume Le Vaillant)(address . glv@posteo.net)
20190904145857.30682-1-glv@posteo.net
* gnu/packages/finance.scm (monero)[arguments]: Define 'Readline_ROOT_DIR'
in 'configure-flags'.
---
gnu/packages/finance.scm | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 377cb3a405..5824a14c33 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -490,9 +490,12 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
("zeromq" ,zeromq)))
(arguments
`(#:out-of-source? #t
- #:configure-flags '("-DARCH=default"
- "-DBUILD_TESTS=ON"
- "-DBUILD_GUI_DEPS=ON")
+ #:configure-flags
+ (list "-DARCH=default"
+ "-DBUILD_TESTS=ON"
+ "-DBUILD_GUI_DEPS=ON"
+ (string-append "-DReadline_ROOT_DIR="
+ (assoc-ref %build-inputs "readline")))
#:phases
(modify-phases %standard-phases
;; tests/core_tests need a valid HOME
--
2.23.0
G
G
Guillaume Le Vaillant wrote on 4 Sep 2019 16:58
[PATCH 2/3] gnu: monero: Activate Trezor support.
(address . 37303@debbugs.gnu.org)(name . Guillaume Le Vaillant)(address . glv@posteo.net)
20190904145857.30682-2-glv@posteo.net
* gnu/packages/finance.scm (monero):
[native-inputs]: Add python and protobuf.
[inputs]: Add libusb and protobuf.
[arguments]: Add delete-dead-links phase.
(monero-gui)[inputs]: Add libusb and protobuf.
---
gnu/packages/finance.scm | 18 +++++++++++++++---
1 file changed, 15 insertions(+), 3 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 5824a14c33..30ea797daf 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -473,16 +473,20 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
("git" ,git)
("graphviz" ,graphviz)
("pkg-config" ,pkg-config)
+ ("protobuf" ,protobuf)
+ ("python" ,python)
("qttools" ,qttools)))
(inputs
`(("boost" ,boost)
("cppzmq" ,cppzmq)
("expat" ,expat)
("hidapi" ,hidapi)
- ("libunwind" ,libunwind)
("libsodium" ,libsodium)
+ ("libunwind" ,libunwind)
+ ("libusb" ,libusb)
("miniupnpc" ,miniupnpc)
("openssl" ,openssl)
+ ("protobuf" ,protobuf)
("rapidjson" ,rapidjson)
("readline" ,readline)
("unbound" ,unbound)
@@ -534,7 +538,13 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
":")))
(invoke "tests/unit_tests/unit_tests"
(string-append "--gtest_filter=-"
- excluded-unit-tests))))))))
+ excluded-unit-tests)))))
+ (add-after 'install 'delete-dead-links
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (delete-file (string-append out "/lib/libprotobuf.so"))
+ (delete-file (string-append out "/lib/libusb-1.0.so"))
+ #t))))))
(home-page "https://getmonero.org/")
(synopsis "Command-line interface to the Monero currency")
(description
@@ -563,9 +573,11 @@ the Monero command line client and daemon.")
(inputs
`(("boost" ,boost)
("hidapi" ,hidapi)
- ("libunwind" ,libunwind)
("libsodium" ,libsodium)
+ ("libunwind" ,libunwind)
+ ("libusb" ,libusb)
("openssl" ,openssl)
+ ("protobuf" ,protobuf)
("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)
("qtgraphicaleffects" ,qtgraphicaleffects)
--
2.23.0
G
G
Guillaume Le Vaillant wrote on 4 Sep 2019 16:58
[PATCH 3/3] gnu: monero-gui: Update to 0.14.1.2.
(address . 37303@debbugs.gnu.org)(name . Guillaume Le Vaillant)(address . glv@posteo.net)
20190904145857.30682-3-glv@posteo.net
* gnu/packages/finance.scm (monero-gui): Update to 0.14.1.2.
---
gnu/packages/finance.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 30ea797daf..3fa0a4d331 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -555,7 +555,7 @@ the Monero command line client and daemon.")
(define-public monero-gui
(package
(name "monero-gui")
- (version "0.14.1.0")
+ (version "0.14.1.2")
(source
(origin
(method git-fetch)
@@ -565,7 +565,7 @@ the Monero command line client and daemon.")
(file-name (git-file-name name version))
(sha256
(base32
- "0ilx47771faygf97wilm64xnqxgxa3b43q0g9v014npk0qj8pc31"))))
+ "1rm043r6y2mzy8pclnzbjjfxgps8pkfa2b92p66k8y8rdmgq6m1k"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
--
2.23.0
L
L
Ludovic Courtès wrote on 10 Sep 2019 00:35
Re: [bug#37303] [PATCH 0/3] Improvements for monero and monero-gui
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 37303-done@debbugs.gnu.org)
87d0g9xfm3.fsf@gnu.org
Hi Guillaume,

Guillaume Le Vaillant <glv@posteo.net> skribis:

Toggle quote (5 lines)
> Patches:
> 1 - Fix detection of readline library.
> 2 - Activate Trezor support.
> 3 - Update monero-gui to 0.14.1.2.

Applied all three patches, thanks!

Ludo’.
Closed
?