[PATCH 08/20] gnu: Add tegaki-zinnia-japanese.

  • Done
  • quality assurance status badge
Details
One participant
  • Alex Vong
Owner
unassigned
Submitted by
Alex Vong
Severity
normal
A
A
Alex Vong wrote on 20 Aug 2019 17:49
(address . guix-patches@gnu.org)
86pnkzvnu5.fsf@gmail.com
From 6cdacc2aec203aef13de7dfe10da20b9bb61fa04 Mon Sep 17 00:00:00 2001
From: Alex Vong <alexvong1995@gmail.com>
Date: Thu, 8 Aug 2019 14:03:26 +0800
Subject: [PATCH 08/20] gnu: Add tegaki-zinnia-japanese.

* gnu/packages/language.scm (tegaki-zinnia-japanese): New variable.
---
gnu/packages/language.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index ad7cf2a4b3..db5a7cb8d2 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -32,6 +32,7 @@
#:use-module (gnu packages web)
#:use-module (gnu packages xorg)
#:use-module (guix packages)
+ #:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module ((guix licenses)
@@ -648,3 +649,40 @@ suitable for both the desktop and mobile devices.")
#t))))))
(synopsis "Chinese and Japanese Handwriting Recognition (Main program)")
(license gpl2+)))) ; all files
+
+(define-public tegaki-zinnia-japanese
+ (package
+ (inherit python2-tegaki-wagomu)
+ (name "tegaki-zinnia-japanese")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (tegaki-release-uri name version "zip"))
+ (sha256
+ (base32
+ "1nmg9acxhcqly9gwkyb9m0hpy76fll91ywk4b1q4xms0ajxip1h7"))
+ (modules remove-pre-compiled-files-modules)
+ (snippet (remove-pre-compiled-files "model"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("/usr/local")
+ (assoc-ref outputs "out")))
+ #t)))))
+ ;; override inherited inputs
+ (inputs '())
+ (native-inputs
+ `(("python2-tegaki-tools" ,python2-tegaki-tools)))
+ (propagated-inputs '())
+ (native-search-paths
+ (list (search-path-specification
+ (variable "TEGAKI_MODEL_PATH")
+ (files '("share/tegaki/models")))))
+ (synopsis "Chinese and Japanese Handwriting Recognition (Model)")
+ (license lgpl2.1))) ; all files
--
2.22.0
-----BEGIN PGP SIGNATURE-----

iHUEARYIAB0WIQQwb8uPLAHCXSnTBVZh71Au9gJS8gUCXVwWkgAKCRBh71Au9gJS
8n05AQC2kOyImBMcSuBcnPn8ZwuT0VDBfJT4byMGORuF+rDARwD/SQgR5MYga2IR
vgydCJJn2SlS8WOgsdk+hieIsVY9PwY=
=3zQD
-----END PGP SIGNATURE-----

A
A
Alex Vong wrote on 20 Aug 2019 18:21
Close all erroneously created bugs
(address . control@debbugs.gnu.org)
8636hvvmd6.fsf@gmail.com
# Close all erroneously created bugs
# Sorry for the noise!
close 37100
close 37101
close 37102
close 37103
close 37104
close 37105
close 37106
close 37107
close 37108
close 37109
close 37110
close 37111
close 37112
close 37113
close 37114
close 37115
close 37117
close 37118
close 37119
thanks
-----BEGIN PGP SIGNATURE-----

iHUEARYIAB0WIQQwb8uPLAHCXSnTBVZh71Au9gJS8gUCXVweBQAKCRBh71Au9gJS
8iX/AQDvrrIjhGRhbjTLLI9GC1Da+T+Etd+cPADjUlCs2NeI5QD9F8qny/MUgmkr
6uoW0LvoKzh6JyP4FRboLw7mLxUrDwc=
=Pm3m
-----END PGP SIGNATURE-----

?