[PATCH 04/20] gnu: Add python2-tegaki-python.

  • Done
  • quality assurance status badge
Details
One participant
  • Alex Vong
Owner
unassigned
Submitted by
Alex Vong
Severity
normal
A
A
Alex Vong wrote on 20 Aug 2019 17:46
(address . guix-patches@gnu.org)
86v9urvnyn.fsf@gmail.com
From e606e1f60f125a402eb13dc807d141b0c9b65fdb Mon Sep 17 00:00:00 2001
From: Alex Vong <alexvong1995@gmail.com>
Date: Thu, 8 Aug 2019 13:49:19 +0800
Subject: [PATCH 04/20] gnu: Add python2-tegaki-python.

* gnu/packages/language.scm (python2-tegaki-python): New variable.
---
gnu/packages/language.scm | 54 +++++++++++++++++++++++++++++++++++++--
1 file changed, 52 insertions(+), 2 deletions(-)

Toggle diff (78 lines)
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index cc685437c9..2ef4fed721 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -22,6 +22,7 @@
(define-module (gnu packages language)
#:use-module (gnu packages)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages ocr)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -31,8 +32,10 @@
#:use-module (guix packages)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
- #:use-module ((guix licenses) #:select (gpl2 gpl2+ gpl3 perl-license))
- #:use-module (guix download))
+ #:use-module ((guix licenses)
+ #:select (bsd-3 gpl2 gpl2+ gpl3 perl-license zpl2.1))
+ #:use-module (guix download)
+ #:use-module (guix utils))
(define-public perl-lingua-en-findnumber
(package
@@ -479,3 +482,50 @@ modern implementation of handwriting recognition software, specifically
designed for Chinese (simplified and traditional) and Japanese, and that is
suitable for both the desktop and mobile devices.")
(license gpl2+))) ; all files
+
+(define-public python2-tegaki-python
+ (package
+ (inherit python2-tegaki-wagomu)
+ (name "python2-tegaki-python")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (tegaki-release-uri "tegaki-python" version))
+ (sha256
+ (base32
+ "0x93k7pw9nh0ywd97pr8pm7jv3f94nw044i5k0zvzhdpsjqvak7p"))
+ (modules remove-pre-compiled-files-modules)
+ (snippet (remove-pre-compiled-files "pyc"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments python2-tegaki-wagomu)
+ ((#:phases _)
+ `(modify-phases %standard-phases
+ (add-after 'unpack 'pre-configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Always convert string to unicode to avoid the following error
+ ;; when running "tegaki-build" in python2-tegaki-tools:
+ ;;
+ ;; sqlite3.ProgrammingError: You must not use 8-bit bytestrings
+ ;; unless you use a text_factory that can interpret 8-bit
+ ;; bytestrings (like text_factory = str).
+ ;; It is highly recommended that you instead just switch your
+ ;; application to Unicode strings.
+ (substitute* "tegaki/charcol.py"
+ (("sqlite3.OptimizedUnicode")
+ "lambda s: unicode(s, 'utf-8')"))
+ (substitute* "tegaki/engine.py"
+ (("/usr(/local)?")
+ (assoc-ref inputs "python2-tegaki-wagomu")))
+ #t))))))
+ ;; override inherited inputs
+ (inputs '())
+ (native-inputs '())
+ (propagated-inputs
+ `(("python2-tegaki-wagomu" ,python2-tegaki-wagomu)
+ ("python2-zinnia" ,python2-zinnia)))
+ (synopsis
+ "Chinese and Japanese Handwriting Recognition (Base python library)")
+ (license (list gpl2+ ; all files except...
+ bsd-3 ; dictutils.py
+ zpl2.1)))) ; minjson.py
--
2.22.0
-----BEGIN PGP SIGNATURE-----

iHUEARYIAB0WIQQwb8uPLAHCXSnTBVZh71Au9gJS8gUCXVwV8QAKCRBh71Au9gJS
8rYYAQC0RV3FIWQ6BH2wZCWcZfISgBQ7WOAY/9Y7DhPGe5uXBAEAjBYFbWES35no
ZYwZEM+siQyGNRUqNJJcqiPagX/vKws=
=pir5
-----END PGP SIGNATURE-----

A
A
Alex Vong wrote on 20 Aug 2019 18:21
Close all erroneously created bugs
(address . control@debbugs.gnu.org)
8636hvvmd6.fsf@gmail.com
# Close all erroneously created bugs
# Sorry for the noise!
close 37100
close 37101
close 37102
close 37103
close 37104
close 37105
close 37106
close 37107
close 37108
close 37109
close 37110
close 37111
close 37112
close 37113
close 37114
close 37115
close 37117
close 37118
close 37119
thanks
-----BEGIN PGP SIGNATURE-----

iHUEARYIAB0WIQQwb8uPLAHCXSnTBVZh71Au9gJS8gUCXVweBQAKCRBh71Au9gJS
8iX/AQDvrrIjhGRhbjTLLI9GC1Da+T+Etd+cPADjUlCs2NeI5QD9F8qny/MUgmkr
6uoW0LvoKzh6JyP4FRboLw7mLxUrDwc=
=Pm3m
-----END PGP SIGNATURE-----

?