[PATCH 01/20] gnu: Add zinnia.

  • Done
  • quality assurance status badge
Details
One participant
  • Alex Vong
Owner
unassigned
Submitted by
Alex Vong
Severity
normal
A
A
Alex Vong wrote on 20 Aug 2019 17:40
(address . guix-patches@gnu.org)
8636hvx2ug.fsf@gmail.com
From 7ce4aad0c29c76d173a7273ee391d4d8a5a471ef Mon Sep 17 00:00:00 2001
From: Alex Vong <alexvong1995@gmail.com>
Date: Tue, 6 Aug 2019 23:43:55 +0800
Subject: [PATCH 01/20] gnu: Add zinnia.

* gnu/packages/ocr.scm (zinnia): New variable.
---
gnu/packages/ocr.scm | 55 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)

Toggle diff (79 lines)
diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index 2808359ca2..14ea7e443b 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,6 +23,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages compression)
#:use-module (gnu packages image))
@@ -76,3 +78,56 @@ positional information and page layout analysis. Several image formats are
supported through the Leptonica library. It can also detect whether text is
monospaced or proportional.")
(license license:asl2.0)))
+
+(define-public zinnia
+ (let* ((commit "581faa8f6f15e4a7b21964be3a5ec36265c80e5b")
+ (revision "1")
+ ;; version copied from 'configure.in'
+ (version (git-version "0.07" revision commit)))
+ (package
+ (name "zinnia")
+ (version version)
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/taku910/zinnia.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "1izjy5qw6swg0rs2ym2i72zndb90mwrfbd1iv8xbpwckbm4899lg"))
+ (file-name (git-file-name name version))
+ (modules '((guix build utils)
+ (ice-9 ftw)
+ (srfi srfi-26)))
+ (snippet ; remove unnecessary files with potentially different license
+ '(begin
+ (for-each delete-file-recursively
+ (scandir "."
+ (negate (cut member <> '("zinnia"
+ "." "..")))))
+ #t))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (chdir "zinnia")
+ (for-each make-file-writable
+ '("config.log" "config.status"))
+ #t)))))
+ (home-page "https://taku910.github.io/zinnia/")
+ (synopsis "Online hand recognition system with machine learning")
+ (description
+ "Zinnia is a simple, customizable and portable online hand recognition
+system based on Support Vector Machines. Zinnia simply receives user pen
+strokes as a sequence of coordinate data and outputs n-best characters sorted
+by SVM confidence. To keep portability, Zinnia doesn't have any rendering
+functionality. In addition to recognition, Zinnia provides training module
+that allows us to create any hand-written recognition systems with low-cost.")
+ (license (list license:bsd-3 ; all files except...
+ (license:non-copyleft ; some autotools related files
+ "file://zinnia/aclocal.m4")
+ license:x11 ; 'install-sh'
+ license:public-domain))))) ; 'install-sh'
--
2.22.0
-----BEGIN PGP SIGNATURE-----

iHUEARYIAB0WIQQwb8uPLAHCXSnTBVZh71Au9gJS8gUCXVwUVwAKCRBh71Au9gJS
8s9YAQCDes1xsRew9MzCkcxSog/QqE8wOqxweUaEDtiwr99cUQEA7iCQA8E65DcB
/nFEY1ni98EvzgnFh3Ti+YrqP/AxDAw=
=u0NV
-----END PGP SIGNATURE-----

A
A
Alex Vong wrote on 20 Aug 2019 18:21
Close all erroneously created bugs
(address . control@debbugs.gnu.org)
8636hvvmd6.fsf@gmail.com
# Close all erroneously created bugs
# Sorry for the noise!
close 37100
close 37101
close 37102
close 37103
close 37104
close 37105
close 37106
close 37107
close 37108
close 37109
close 37110
close 37111
close 37112
close 37113
close 37114
close 37115
close 37117
close 37118
close 37119
thanks
-----BEGIN PGP SIGNATURE-----

iHUEARYIAB0WIQQwb8uPLAHCXSnTBVZh71Au9gJS8gUCXVweBQAKCRBh71Au9gJS
8iX/AQDvrrIjhGRhbjTLLI9GC1Da+T+Etd+cPADjUlCs2NeI5QD9F8qny/MUgmkr
6uoW0LvoKzh6JyP4FRboLw7mLxUrDwc=
=Pm3m
-----END PGP SIGNATURE-----

?