[PATCH] gnu: Add template-glib.

  • Done
  • quality assurance status badge
Details
2 participants
  • Giacomo Leidi
  • Ludovic Courtès
Owner
unassigned
Submitted by
Giacomo Leidi
Severity
normal
G
G
Giacomo Leidi wrote on 20 Aug 2019 01:12
(address . guix-patches@gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20190819231211.11154-1-goodoldpaul@autistici.org
* gnu/packages/glib.scm (template-glib): New variable.
---
gnu/packages/glib.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index ab9ed0b1bf..3e16c62f53 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -891,3 +892,41 @@ main loop, simply get a connection to the bus via the methods in
@code{Net::DBus::GLib} rather than the usual @code{Net::DBus} module. Every
other API remains the same.")
(license license:gpl2+)))
+
+(define-public template-glib
+ (package
+ (name "template-glib")
+ (version "3.32.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1g0zx0sxpw8kqp7p3sgl9kngaqrg9xl6cir24nrahks0vgsk98rr"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags '("-D" "enable_gtk_doc=true")))
+ (inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib" ,glib)
+ ("gobject-introspection" ,gobject-introspection)))
+ (native-inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)
+ ("glib:bin" ,glib "bin") ;; For glib-mkenums
+ ("gtk-doc" ,gtk-doc)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (home-page "https://gitlab.gnome.org/GNOME/template-glib")
+ (synopsis "Library for template expansion which supports calling into
+GObject Introspection from templates")
+ (description
+ "Template-GLib is a library to help you generate text based on a template and
+user defined state. Template-GLib does not use a language runtime, so it is
+safe to use from any GObject-Introspectable language.
+
+Template-GLib allows you to access properties on GObjects as well as call
+simple methods via GObject-Introspection.")
+ (license license:lgpl2.1+)))
--
2.23.0
G
G
goodoldpaul wrote on 26 Aug 2019 21:00
(address . 37091@debbugs.gnu.org)
77b242319a5c8568ff324947b11be9e7@autistici.org
Friendly ping ;) .

Thanks

Giacomo
L
L
Ludovic Courtès wrote on 27 Aug 2019 12:45
Re: [bug#37091] [PATCH] gnu: Add template-glib.
(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)(address . 37091-done@debbugs.gnu.org)
87woeyq42q.fsf@gnu.org
Hello,

Giacomo Leidi <goodoldpaul@autistici.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/glib.scm (template-glib): New variable.

Applied with the tiny change below, to make the synopsis shorter.

Thanks,
Ludo’.
Toggle diff (14 lines)
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 3e16c62f53..77b5715eb0 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -920,8 +920,7 @@ other API remains the same.")
("pkg-config" ,pkg-config)
("vala" ,vala)))
(home-page "https://gitlab.gnome.org/GNOME/template-glib")
- (synopsis "Library for template expansion which supports calling into
-GObject Introspection from templates")
+ (synopsis "Library for template expansion")
(description
"Template-GLib is a library to help you generate text based on a template and
user defined state. Template-GLib does not use a language runtime, so it is
Closed
?