[PATCH] Add fe

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Nicolas Goaziou
Severity
normal
N
N
Nicolas Goaziou wrote on 18 Aug 2019 11:12
(address . guix-patches@gnu.org)
87wofa3ki8.fsf@nicolasgoaziou.fr
Hello

The following patch adds fe, a tiny folding ncurse editor.

A few caveats: it builds the development version (2.0) instead of the
stable one (1.8), because the former supports UTF-8. Also, I disabled
the undocumented "sendmail" feature, which only sends a mail after
a crash.

Feedback welcome.

Regards,

--
Nicolas Goaziou
From 37e7ceea742a858e7ef01232147f1cdb918c2cb3 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Sun, 18 Aug 2019 11:08:29 +0200
Subject: [PATCH] gnu: Add fe.

* gnu/packages/text-editors.scm (fe): New variable.
---
gnu/packages/text-editors.scm | 53 +++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 4412d54579..432e79e350 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -41,6 +41,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
@@ -567,3 +568,55 @@ The basic features of Geany are:
@item extensibility through plugins
@end itemize")
(license license:gpl2+)))
+
+(define-public fe
+ (package
+ (name "fe")
+ ;; Stable release is 1.8. However, this development version
+ ;; introduces support for UTF-8.
+ (version "2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.moria.de/~michael/fe/"
+ "fe-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hwws7si1752z6hp61zxznvgsb6846lp8zl1hn5ddhsbafwalwb9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no test
+ ;; Sendmail is only used to send a crash log. Disable the
+ ;; feature since it is (1) undocumented (2) not very useful.
+ #:configure-flags (list "--disable-sendmail")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version)))
+ (for-each (lambda (f) (install-file f doc))
+ '("fe.doc" "fe.html" "fe.ps" "feref.ps" "README"))
+ #t))))))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)))
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (home-page "http://www.moria.de/~michael/fe/")
+ (synopsis "Small folding editor")
+ (description "Fe is a small folding editor. It allows to fold
+arbitrary text regions; it is not bound to syntactic units.
+
+Fe has no configuration or extension language and requires no setup.
+Its user interface is emacs-like and it has menues for the very most
+important functions to help beginners. Further there is a reference
+card. It offers:
+
+@itemize
+@item Regions and Emacs-like kill ring
+@item Incremental search
+@item Keyboard macros
+@item Editing binary files
+@item Multiple windows and views
+@item Compose function for Latin 1 characters
+@end itemize")
+ (license license:gpl2+)))
--
2.22.0
L
L
Ludovic Courtès wrote on 28 Aug 2019 18:09
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 37070@debbugs.gnu.org)
87zhjtgtkv.fsf@gnu.org
Hello,

Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:

Toggle quote (7 lines)
>>From 37e7ceea742a858e7ef01232147f1cdb918c2cb3 Mon Sep 17 00:00:00 2001
> From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
> Date: Sun, 18 Aug 2019 11:08:29 +0200
> Subject: [PATCH] gnu: Add fe.
>
> * gnu/packages/text-editors.scm (fe): New variable.

LGTM, thanks!

Ludo’.
N
N
Nicolas Goaziou wrote on 29 Aug 2019 19:00
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 37070-done@debbugs.gnu.org)
878srbx5xh.fsf@nicolasgoaziou.fr
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (6 lines)
>> Subject: [PATCH] gnu: Add fe.
>>
>> * gnu/packages/text-editors.scm (fe): New variable.
>
> LGTM, thanks!

Applied. Thank you.

Regards,

--
Nicolas Goaziou
Closed
?