[PATCH] Add emacs-org packages.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brian Leung
  • Oleg Pyhalov
Owner
unassigned
Submitted by
Brian Leung
Severity
normal
B
B
Brian Leung wrote on 17 Aug 2019 07:01
(address . guix-patches@gnu.org)
CAAc=MExRjyFURj3Uw2fKfZruqRiVXRSTtHeEu-yU10CzFKnibg@mail.gmail.com
See attached.
Attachment: file
From 04e9a6d94cda9d4291324628f9ed7d6a76e484ba Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Sat, 17 Aug 2019 06:15:54 +0200
Subject: [PATCH 1/3] gnu: Add emacs-org-rich-yank.

* gnu/packages/emacs-xyz.scm (emacs-org-rich-yank): New variable.
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6e612cab56..8034a4cf84 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2729,6 +2729,29 @@ naming style of a symbol. It supports different naming conventions such as:
tables.")
(license license:gpl2+)))
+(define-public emacs-org-rich-yank
+ (package
+ (name "emacs-org-rich-yank")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/unhammer/org-rich-yank.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gxb0fnh5gxjmld0hnk5hli0cvdd8gjd27m30bk2b80kwldxlq1z"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/unhammer/org-rich-yank")
+ (synopsis "Automatically surround source code pasted into Org with
+@code{#+BEGIN_SRC} blocks")
+ (description
+ "This package provides a utility function for Org buffers that makes a
+@code{_SRC} block with the appropriate language annotation for code that has
+been copied from an Emacs major mode.")
+ (license license:gpl2+)))
+
(define-public emacs-rich-minority
(package
(name "emacs-rich-minority")
--
2.22.0
From f1414b3b1d32647e47aa7d47534aa7460ecb32e1 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Sat, 17 Aug 2019 06:49:51 +0200
Subject: [PATCH 2/3] gnu: Add emacs-ob-restclient.

* gnu/packages/emacs-xyz.scm (emacs-ob-restclient): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8034a4cf84..9512a2494a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2752,6 +2752,30 @@ tables.")
been copied from an Emacs major mode.")
(license license:gpl2+)))
+(define-public emacs-ob-restclient
+ (let ((commit "53376667eeddb1388fd6c6976f3222e7c8adcd46")
+ (revision "1"))
+ (package
+ (name "emacs-ob-restclient")
+ (version "0.02")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alf/ob-restclient.el.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1djg53cp7y83gic2v71y6r5z76kwrbkp0r69hl25rs99dx6p89dy"))))
+ (propagated-inputs
+ `(("emacs-restclient" ,emacs-restclient)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/alf/ob-restclient.el")
+ (synopsis "Org-babel functionality for @code{restclient-mode}")
+ (description
+ "This package integrates @code{restclient-mode} with Org.")
+ (license license:gpl3+))))
+
(define-public emacs-rich-minority
(package
(name "emacs-rich-minority")
--
2.22.0
From 41f2be66533eabc0c9925ca5eae74c2b9c43ef52 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Sat, 17 Aug 2019 06:59:48 +0200
Subject: [PATCH 3/3] gnu: Add emacs-org-now.

* gnu/packages/emacs-xyz.scm (emacs-org-now): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9512a2494a..00da280f0d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2776,6 +2776,33 @@ been copied from an Emacs major mode.")
"This package integrates @code{restclient-mode} with Org.")
(license license:gpl3+))))
+(define-public emacs-org-now
+ (let ((commit "8f6b277a73f1c66e58ccb4b7f40d406851befc91")
+ (revision "1"))
+ (package
+ (name "emacs-org-now")
+ (version "0.1-pre")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alphapapa/org-now.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "117zzkryznznk6h4i1jqzdn888nl019xrgxm2gza0lndx8dxsg2c"))))
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/alphapapa/org-now")
+ (synopsis "Show current Org tasks in a sidebar")
+ (description
+ "This package provides commands to show Org headings in a sidebar
+window while working on them. After defining one heading as the \"now\"
+heading, other headings can be refiled to it with one command, and back to
+their original location with another.")
+ (license license:gpl3+))))
+
(define-public emacs-rich-minority
(package
(name "emacs-rich-minority")
--
2.22.0
O
O
Oleg Pyhalov wrote on 18 Aug 2019 19:58
(name . Brian Leung)(address . bkleung89@gmail.com)
8736hypd8p.fsf@majordomo.ru
Hello Brian,

Thank you for new packages. As I know we should use ‘git-version’ if
commit is not tagged. Pushed to master with following changes.
Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a413279dc0..df89aebb3f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2753,11 +2753,10 @@ been copied from an Emacs major mode.")
(license license:gpl2+)))
(define-public emacs-ob-restclient
- (let ((commit "53376667eeddb1388fd6c6976f3222e7c8adcd46")
- (revision "1"))
+ (let ((commit "53376667eeddb1388fd6c6976f3222e7c8adcd46"))
(package
(name "emacs-ob-restclient")
- (version "0.02")
+ (version (git-version "0.02" "1" commit))
(source
(origin
(method git-fetch)
@@ -2777,11 +2776,10 @@ been copied from an Emacs major mode.")
(license license:gpl3+))))
(define-public emacs-org-now
- (let ((commit "8f6b277a73f1c66e58ccb4b7f40d406851befc91")
- (revision "1"))
+ (let ((commit "8f6b277a73f1c66e58ccb4b7f40d406851befc91"))
(package
(name "emacs-org-now")
- (version "0.1-pre")
+ (version (git-version "0.1-pre" "1" commit))
(source
(origin
(method git-fetch)
@@ -2798,7 +2796,7 @@ been copied from an Emacs major mode.")
(synopsis "Show current Org tasks in a sidebar")
(description
"This package provides commands to show Org headings in a sidebar
-window while working on them. After defining one heading as the \"now\"
+window while working on them. After defining one heading as the \"now\"
heading, other headings can be refiled to it with one command, and back to
their original location with another.")
(license license:gpl3+))))
Regards,
Oleg.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAl1ZkbYACgkQFn+OpQAa
+py6Ow/6A1n9wAc9SNT/as/rc2GAkbVGB7VzKiy8J/utvxhzLfP/EC+GMKHlMuNu
ZrGq2zFqBTHeJS7o633Yn3wFuYrbIIKRc4wKj7m9y8QrCf+Q8pRXBA0onMUP4w4C
VQpCDFNJQhhObrl5xKpdmzv+Er3Zle9xkhp1aUQS/QQOxKx8aXXfgQuBhwJRfkHL
1U+PQai9P+13ZWnj1PgzaRmt+6qmrnLVBBUfVYEXcGicJ4TDOe9enf9zgGX0mGFn
GXwiuXSP7O2gVIp7VySYD7Je61bvrk1m/QXgAaRdxlNE3Ynb57iq4fMWRlEurnxI
vW1cfuL5XoT7L+YWwh0j+/O7jCNKT2ymz8xd2G7N/5mE6EWCWDYZhRZckbM4uBkT
IjFkCVW6IUmUzsziRjdeiXS6/49zLmoMlc+Y+/HlS2v9yYWGHQvdkwWuwx8CB3N1
/vAmAIXmkSsmLJpSQkcLU3O19oF6vXkg6WGu1BDhpQwvnChQsXuKGNRqzzVWabxn
/u6nu7++njnQ5o9d8lRDnFpN/ClCEIF3e1lTGLweziV3WrlKdn6+xzhuG98A1Q0E
JYcUkzgg6rau1ds+AVNVdmLdUxlKldpkEUDGwEdnTVGVh6xvSatX6dmHv/mLfsL6
dddMWnkAC6Pr3QxsdCZGs7AVABytM6i4YOJUGiFM0iv9wWg7BzU=
=isM3
-----END PGP SIGNATURE-----

?