[PATCH] gnu: Add libgit2-glib.

  • Done
  • quality assurance status badge
Details
2 participants
  • Giacomo Leidi
  • Ludovic Courtès
Owner
unassigned
Submitted by
Giacomo Leidi
Severity
normal
G
G
Giacomo Leidi wrote on 14 Aug 2019 19:23
(address . guix-patches@gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20190814172301.29737-1-goodoldpaul@autistici.org
* gnu/packages/gnome.scm (libgit2-glib): New variable.
---
gnu/packages/gnome.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index da6cbf2a05..57842d4b5b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8283,3 +8283,35 @@ advanced image management tool")
(description "The aim of the handy library is to help with developing user
intefaces for mobile devices using GTK+.")
(license license:lgpl2.1+)))
+
+(define-public libgit2-glib
+ (package
+ (name "libgit2-glib")
+ (version "0.28.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0a0g7aw66rfgnqr4z7fgbk5zzcjq66m4rp8v4val3a212941h0g7"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ;; For glib-mkenums
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("libssh2" ,libssh2)
+ ("pkg-config" ,pkg-config)
+ ("python-pygobject" ,python-pygobject)
+ ("python-wrapper" ,python-wrapper)
+ ("vala" ,vala)))
+ (inputs
+ `(("glib" ,glib)
+ ("libgit2" ,libgit2)))
+ (synopsis "A glib wrapper library around the libgit2 git access library")
+ (description "libgit2-glib is a glib wrapper library around the libgit2 git
+access library. It only implements the core plumbing functions, not really the
+higher level porcelain stuff.")
+ (home-page "https://wiki.gnome.org/Projects/Libgit2-glib")
+ (license license:gpl2+)))
--
2.22.1
L
L
Ludovic Courtès wrote on 16 Aug 2019 22:59
(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)(address . 37030-done@debbugs.gnu.org)
87mug8g720.fsf@gnu.org
Hi,

Giacomo Leidi <goodoldpaul@autistici.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/gnome.scm (libgit2-glib): New variable.

Applied with the nitpicking below. :-)

Thanks,
Ludo’.
Toggle diff (15 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 57842d4b5b..d5e46e09c1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8309,8 +8309,8 @@ intefaces for mobile devices using GTK+.")
(inputs
`(("glib" ,glib)
("libgit2" ,libgit2)))
- (synopsis "A glib wrapper library around the libgit2 git access library")
- (description "libgit2-glib is a glib wrapper library around the libgit2 git
+ (synopsis "GLib wrapper around the libgit2 Git access library")
+ (description "libgit2-glib is a GLib wrapper library around the libgit2 Git
access library. It only implements the core plumbing functions, not really the
higher level porcelain stuff.")
(home-page "https://wiki.gnome.org/Projects/Libgit2-glib")
Closed
?