[PATCH] gnu: Add scron.

  • Done
  • quality assurance status badge
Details
2 participants
  • ???
  • Robert Vollmert
Owner
unassigned
Submitted by
Robert Vollmert
Severity
normal
R
R
Robert Vollmert wrote on 30 Jul 2019 11:36
(address . guix-patches@gnu.org)(name . Robert Vollmert)(address . rob@vllmrt.net)
20190730093633.4525-1-rob@vllmrt.net
* gnu/packages/suckless.scm (scron): New package.
---
gnu/packages/suckless.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index 427bc44598..afad6947bf 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -724,3 +724,31 @@ as -1, to be used instead of U+FFFD.
It is a front end for ii-like chat programs. It uses @code{tail -f} to get the
chat output in the background.")
(license license:isc))))
+
+(define-public scron
+ (package
+ (name "scron")
+ (version "0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://dl.2f30.org/releases/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "066fwa55kqcgfrsqgxh94sqbkxfsr691360xg4ljxr4i75d25s2a"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; No tests
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; No configure script
+ (home-page "https://git.2f30.org/scron/")
+ (synopsis "Simple cron daemon")
+ (description
+ "Schedule commands to be run at specified dates and times.
+Single daemon and configuration file. Log to stdout or syslog.
+No mail support.")
+ (license license:expat)))
--
2.21.0
?
(name . Robert Vollmert)(address . rob@vllmrt.net)(address . 36854-done@debbugs.gnu.org)
877e6h378x.fsf@member.fsf.org
Robert Vollmert <rob@vllmrt.net> writes:

Toggle quote (6 lines)
> * gnu/packages/suckless.scm (scron): New package.
> ---
> gnu/packages/suckless.scm | 28 ++++++++++++++++++++++++++++
> 1 file changed, 28 insertions(+)
>

Cool, pushed, thank you!
Closed
?