[PATCH 2/3] gnu: Add osm-gps-map

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume LE VAILLANT
  • Ludovic Courtès
Owner
unassigned
Submitted by
Guillaume LE VAILLANT
Severity
normal
G
G
Guillaume LE VAILLANT wrote on 14 Jun 2019 19:27
(address . guix-patches@gnu.org)(address . glv@posteo.net)
20190614172751.22468-3-glv@posteo.net
* gnu/packages/geo.scm (osm-gps-map): New variable.
---
gnu/packages/geo.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index ec5ace3519..07831c85ca 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -869,3 +869,39 @@ dropping features at lower levels.")
OpenStreetMap project. They can be used to convert, filter and update
OpenStreetMap data files.")
(license license:agpl3)))
+
+(define-public osm-gps-map
+ (package
+ (name "osm-gps-map")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/nzjrs/osm-gps-map/releases/download/"
+ version
+ "/osm-gps-map-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "11imsf4cz1dpxdjh178k2s29axmq86rkfg1pqmn7incyxmjzhbwg"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gnome-common" ,gnome-common)
+ ("gtk-doc" ,gtk-doc)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("glib" ,glib)
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+" ,gtk+)
+ ("libsoup" ,libsoup)))
+ (home-page "https://nzjrs.github.io/osm-gps-map/")
+ (synopsis "Gtk+ widget for displaying OpenStreetMap tiles")
+ (description
+ "A Gtk+ widget (and Python bindings) that when given GPS coordinates,
+draws a GPS track, and points of interest on a moving map display.
+Downloads map data from a number of websites, including
+@url{https://www.openstreetmap.org}.")
+ (license license:gpl2+)))
--
2.22.0
L
L
Ludovic Courtès wrote on 26 Jun 2019 15:34
(name . Guillaume LE VAILLANT)(address . glv@posteo.net)(address . 36211-done@debbugs.gnu.org)
87mui4ii7l.fsf@gnu.org
Guillaume LE VAILLANT <glv@posteo.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/geo.scm (osm-gps-map): New variable.

Applied with the changes below.

Ludo’.
Toggle diff (31 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 07831c85ca..4cccd97643 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -879,10 +879,7 @@ OpenStreetMap data files.")
(method url-fetch)
(uri (string-append
"https://github.com/nzjrs/osm-gps-map/releases/download/"
- version
- "/osm-gps-map-"
- version
- ".tar.gz"))
+ version "/osm-gps-map-" version ".tar.gz"))
(sha256
(base32
"11imsf4cz1dpxdjh178k2s29axmq86rkfg1pqmn7incyxmjzhbwg"))))
@@ -898,10 +895,10 @@ OpenStreetMap data files.")
("gtk+" ,gtk+)
("libsoup" ,libsoup)))
(home-page "https://nzjrs.github.io/osm-gps-map/")
- (synopsis "Gtk+ widget for displaying OpenStreetMap tiles")
+ (synopsis "GTK+ widget for displaying OpenStreetMap tiles")
(description
- "A Gtk+ widget (and Python bindings) that when given GPS coordinates,
-draws a GPS track, and points of interest on a moving map display.
-Downloads map data from a number of websites, including
+ "This package provides a GTK+ widget (and Python bindings) that when
+given GPS coordinates,draws a GPS track, and points of interest on a moving
+map display. Downloads map data from a number of websites, including
@url{https://www.openstreetmap.org}.")
(license license:gpl2+)))
Closed
?