[PATCH] Add Emacs packages.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brian Leung
  • Oleg Pykhalov
Owner
unassigned
Submitted by
Brian Leung
Severity
normal
B
B
Brian Leung wrote on 3 Jun 2019 23:21
(address . guix-patches@gnu.org)
CAAc=MEw2Zi=jbzCyuBOE5P4Bf4TjUDJCZJeVtFyvwc+q4paiPg@mail.gmail.com
See attached.
Attachment: file
From f48217c70c719000f0bebf8989bbef8b4943312d Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Mon, 3 Jun 2019 22:14:28 +0200
Subject: [PATCH 1/4] gnu: Add emacs-whitespace-cleanup-mode.

* gnu/packages/emacs-xyz.scm (emacs-whitespace-cleanup-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c2b3bfddcb..724c4a4883 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8049,6 +8049,30 @@ from within Emacs. Restclient runs queries from a plan-text query sheet,
displays results pretty-printed in XML or JSON with @code{restclient-mode}")
(license license:public-domain))))
+(define-public emacs-whitespace-cleanup-mode
+ (let ((commit "72427144b054b0238a86e1348c45d986b8830d9d")
+ (revision "1"))
+ (package
+ (name "emacs-whitespace-cleanup-mode")
+ (version (git-version "0.10" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/purcell/whitespace-cleanup-mode")
+ (commit commit)))
+ (sha256
+ (base32
+ "1zlk534jbwrsabcg3kqlzk4h4hwya60lh6q2n1v4yn4rpf5ghsag"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/purcell/whitespace-cleanup-mode")
+ (synopsis "Intelligently call @code{whitespace-cleanup} on save")
+ (description
+ "This package provides a minor mode that calls
+@code{whitespace-cleanup} before saving the current buffer only if the
+whitespace in the buffer was initially clean.")
+ (license license:gpl3+))))
+
(define-public emacs-eimp
(let ((version "1.4.0")
(commit "2e7536fe6d8f7faf1bad7a8ae37faba0162c3b4f")
--
2.21.0
From dd739951c5db7872f79dd38949d1525b22299da1 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Mon, 3 Jun 2019 22:15:19 +0200
Subject: [PATCH 2/4] gnu: Add emacs-lcr.

* gnu/packages/emacs-xyz.scm (emacs-lcr): New variable.
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 724c4a4883..d4dc672180 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8304,6 +8304,29 @@ multiplexer.")
editing RPM spec files.")
(license license:gpl2+)))
+(define-public emacs-lcr
+ (package
+ (name "emacs-lcr")
+ (version "1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jyp/lcr")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mc55icihxqpf8b05990q1lc2nj2792wcgyr73xsiqx0963sjaj8"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)))
+ (home-page "https://github.com/jyp/lcr")
+ (synopsis "Lightweight coroutines in Emacs Lisp")
+ (description "This package provides macros that can translate code into
+equivalent continuation-passing code, as well as miscellaneous utility
+functions written in continuation-passing style.")
+ (license license:gpl3+)))
+
(define-public emacs-git-messenger
(package
(name "emacs-git-messenger")
--
2.21.0
From 929f4e2d0cec923b1735f12962dbe33839d147bf Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Mon, 3 Jun 2019 22:15:33 +0200
Subject: [PATCH 3/4] gnu: Add emacs-dante.

* gnu/packages/emacs-xyz.scm (emacs-dante): New variable.
---
gnu/packages/emacs-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d4dc672180..a5e72a3341 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -667,6 +667,37 @@ programs.")
(define-public haskell-mode
(deprecated-package "haskell-mode" emacs-haskell-mode))
+(define-public emacs-dante
+ (let ((commit "149dded24ca9cdff09a3d859e4b62638db4aadda")
+ (revision "1"))
+ (package
+ (name "emacs-dante")
+ (version (git-version "1.5" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jyp/dante")
+ (commit commit)))
+ (sha256
+ (base32
+ "0i7kj3d6pfys6si9va5f36qzifyac9mahdl0qh40rya9m0syrkla"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)
+ ("emacs-flycheck" ,emacs-flycheck)
+ ("emacs-haskell-mode" ,emacs-haskell-mode)
+ ("emacs-s" ,emacs-s)
+ ("emacs-company" ,emacs-company)
+ ("emacs-lcr" ,emacs-lcr)))
+ (home-page "https://github.com/jyp/dante")
+ (synopsis "Minor mode for interactive Haskell")
+ (description
+ "This package provides a minor mode for Haskell development that
+supports type hints, definition-jumping, completion, and more.")
+ (license license:gpl3+))))
+
(define-public emacs-flycheck
(package
(name "emacs-flycheck")
--
2.21.0
From 52679d7562578fa2dce7398fb17fe989a58d80db Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Mon, 3 Jun 2019 22:16:40 +0200
Subject: [PATCH 4/4] gnu: Add emacs-attrap.

* gnu/packages/emacs-xyz.scm (emacs-attrap): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a5e72a3341..88bb61fddb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8358,6 +8358,33 @@ equivalent continuation-passing code, as well as miscellaneous utility
functions written in continuation-passing style.")
(license license:gpl3+)))
+(define-public emacs-attrap
+ (let ((commit "3b092bb8f6755a97e6ecb7623b9d2dde58beba4a")
+ (revision "1"))
+ (package
+ (name "emacs-attrap")
+ (version (git-version "1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jyp/attrap")
+ (commit commit)))
+ (sha256
+ (base32
+ "05d32980saji8ja1pcv65l0s3dq7w0n5hpikbf246hciy1x067pp"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)
+ ("emacs-flycheck" ,emacs-flycheck)
+ ("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/jyp/attrap")
+ (synopsis "Fix coding error at point")
+ (description "This package provides a command to fix the Flycheck error
+at point.")
+ (license license:gpl3+))))
+
(define-public emacs-git-messenger
(package
(name "emacs-git-messenger")
--
2.21.0
O
O
Oleg Pykhalov wrote on 5 Jun 2019 07:45
(name . Brian Leung)(address . bkleung89@gmail.com)(address . 36080-done@debbugs.gnu.org)
87zhmwwpoq.fsf@gmail.com
Hello, Brian.

Pushed to master.

Thanks,
Oleg.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAlz3VvUACgkQFn+OpQAa
+pycUQ//fCYPRf0SEovrzLnuaAdOZ7Qgiwm9n5BGPnvhLWLvGSOC/kRcyKKdORvA
rPbMtREcZFcu4o98fvKCYjxoonyUreA2GcnBF2IdB1tbduxGuqEjWrOF1EBC9YPn
T/hlrGQIdiwBORyaTjKN+6+FCSCmm9LkIMIuey31U7ocAjbCNojUW4TTCucYaOr3
miazkVhV0nRD2PqOk6tH5Se9SIC2Dechw6RIuXDrQ9laKHFAPBAcORUdVuEQuoK9
/+cVdEtJR7UO/imH4Jib6C+Bar4G6b6JM+Vy2Vg083xS/KNAM+gE4NM+x0cHVYiv
tHrj8WQwQIs/GjsaLymSW76dt0c1hdTnE1T9vGLni5Rv+s5S6IMfap7tI05BcPMe
RqPFifhnaEUFTJzCQxSBOk069D0lUI+L5TgQqiGokBecpa0LGCutJh2x52D7HxlS
LbmiaDo/cSKsNbS7IFfW/85LVm9ozwCu7AUL87tqYp8esK37eXuKXE81elWOhQCN
mU6adEc2MNgbFp65YJcEmq4Ld/d7PNxwOtP6KkeQ9CWYfP2yEx5jGfoh1BxUkwry
qQZfYfL0toDo/6zBXVN7WUnQy0DN9A6JEULDEERUx47eq+P67Gd+4DAhj1ZCIsOT
IlrQc5LqjbbU0WH1IEaFhjurtRvRpic2t8eLkEPegiXaMJvV0Bo=
=iyvb
-----END PGP SIGNATURE-----

Closed
?