[PATCH 1/2] tests: hackage: Test multiline cabal description.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Robert Vollmert
Owner
unassigned
Submitted by
Robert Vollmert
Severity
normal
R
R
Robert Vollmert wrote on 2 Jun 2019 00:27
(address . guix-patches@gnu.org)(name . Robert Vollmert)(address . rob@vllmrt.net)
20190601222750.74262-1-rob@vllmrt.net
* tests/hackage.scm: Add test case with multi-line description.
---
tests/hackage.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/tests/hackage.scm b/tests/hackage.scm
index 269c1e1f9b..2f45194fab 100644
--- a/tests/hackage.scm
+++ b/tests/hackage.scm
@@ -236,6 +236,25 @@ library
(test-assert "hackage->guix-package test 6"
(eval-test-with-cabal test-cabal-6 match-ghc-foo-6))
+;; Check multi-line layouted description
+(define test-cabal-multiline-desc
+ "name: foo
+version: 1.0.0
+homepage: http://test.org
+synopsis: synopsis
+description: first line
+ second line
+license: BSD3
+executable cabal
+ build-depends:
+ HTTP >= 4000.2.5 && < 4000.3,
+ mtl >= 2.0 && < 3
+")
+
+(test-assert "hackage->guix-package test multiline desc"
+ (eval-test-with-cabal test-cabal-multiline-desc match-ghc-foo))
+
+
(test-assert "read-cabal test 1"
(match (call-with-input-string test-read-cabal-1 read-cabal)
((("name" ("test-me"))
--
2.20.1 (Apple Git-117)
L
L
Ludovic Courtès wrote on 2 Jun 2019 22:15
(name . Robert Vollmert)(address . rob@vllmrt.net)(address . 36047-done@debbugs.gnu.org)
87r28b7nhg.fsf@gnu.org
Robert Vollmert <rob@vllmrt.net> skribis:

Toggle quote (2 lines)
> * tests/hackage.scm: Add test case with multi-line description.

I edited the commit log to more closely reflect the changes made and
committed it.

Thanks!

Ludo’.
Closed
?