thunar loose its icons on slim in Guix

  • Open
  • quality assurance status badge
Details
One participant
  • znavko
Owner
unassigned
Submitted by
znavko
Severity
normal
Z
Z
znavko wrote on 16 Apr 2019 20:51
(name . bug-guix)(address . bug-guix@gnu.org)
0a2d3792898a1ce643728d0e8b5f1508@disroot.org

But in my config with slim instead of gdm, thunar does not have icons like here: http://lists.gnu.org/archive/html/bug-guix/2019-03/msg00324.html
config:

;-*- mode: Scheme; -*-
;;this is znavko's cute config

(use-modules (gnu) (gnu system nss)
(gnu system locale) ;;for locale-definition
(gnu services desktop)
(srfi srfi-1) ;;for remove function
(gnu services networking) ;;for remove ntp
(gnu services avahi) ;;for remove avahi
(gnu services xorg)
(gnu packages admin) ;;for wpa_supplicant
)
(use-service-modules desktop)
(use-package-modules certs gnome)

(operating-system (host-name "antelope") (timezone "Europe/Moscow") (locale "en_US.utf8")
(bootloader (bootloader-configuration (bootloader grub-bootloader) (target "/dev/sda")))
(file-systems (cons (file-system (device "/dev/sda1") (mount-point "/") (type "ext4")) %base-file-systems))
(swap-devices '("/dev/sda2"))

(users (cons* (user-account (name "bob") (group "users")
(supplementary-groups '("wheel" "netdev" "audio" "video"))
(home-directory "/home/bob"))
(user-account (name "mom") (group "users")
(supplementary-groups '("wheel" "netdev" "audio" "video"))
(home-directory "/home/mom"))
%base-user-accounts))

;; This is where we specify system-wide packages.
(packages (cons* nss-certs ;for HTTPS access
gvfs ;for user mounts
wpa-supplicant
%base-packages))

(services (cons*
(service xfce-desktop-service-type)
(service dhcp-client-service-type)
(service slim-service-type
(slim-configuration
(xorg-configuration
(xorg-configuration
(extra-config
'("Section "InputClass"
Identifier "touchpad"
Driver "libinput"
MatchIsTouchpad "on"
Option "Tapping" "on"
EndSection")
))))
)

(modify-services
(remove (lambda (service)
(member (service-kind service)
(list ntp-service-type avahi-service-type
bluetooth-service network-manager-service-type
gdm-service-type)))
%desktop-services) ;end of remove lambda services

(wpa-supplicant-service-type config =>
(wpa-supplicant-configuration
(interface "wlp2s0")
(config-file "/etc/wpa_supplicant/wpa_supplicant.conf")))

(elogind-service-type
c => (elogind-configuration (handle-lid-switch 'ignore)))
) ;;end of modify-services
)) ;;end of services
;; Allow resolution of '.local' host names with mDNS.
(name-service-switch %mdns-host-lookup-nss)

;;blacklist ugly sound speaker, blacklist ideapad_laptop for prevent soft blocking wlan
(kernel-arguments '("modprobe.blacklist=pcspkr,snd_pcsp,bluetooth,ideapad_laptop"))

) ;;end of operating-system
Attachment: file
?