[PATCH] gnu: Add inferno.

  • Done
  • quality assurance status badge
Details
3 participants
  • Diego Nicola Barbato
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Diego Nicola Barbato
Severity
normal
D
L
L
Ludovic Courtès wrote on 10 Nov 2018 19:05
(name . Diego Nicola Barbato)(address . dnbarbato@posteo.de)(address . 33080@debbugs.gnu.org)
87lg60yfir.fsf@gnu.org
Hi Diego,

Sorry for the late reply.

Diego Nicola Barbato <dnbarbato@posteo.de> skribis:

Toggle quote (3 lines)
> This patch adds inferno as discussed here:
> https://lists.gnu.org/archive/html/guix-devel/2018-10/msg00031.html

In that thread we discussed the font issue, and I’m unsure if it was
resolved:


Is everything “known good” with this version of the patch?

Toggle quote (8 lines)
> From c97b28e97a210cc31e34c08bc1abdc8bd74114fa Mon Sep 17 00:00:00 2001
> From: Diego Nicola Barbato <dnbarbato@posteo.de>
> Date: Wed, 17 Oct 2018 23:07:40 +0200
> Subject: [PATCH] gnu: Add inferno.
>
> * gnu/packages/inferno.scm: New file.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Register it.

Overall it LGTM! Minor suggestions here:

Toggle quote (16 lines)
> + #:phases
> + (let* ((bash (assoc-ref %build-inputs "bash"))
> + (objtype ,@(match (%current-system)
> + ((or "armhf-linux" "aarch64-linux")
> + `("arm"))
> + (_
> + `("386"))))
> + (out (assoc-ref %outputs "out"))
> + (root (string-append out "/share/inferno"))
> + (root/bindir (string-append root "/Linux/"
> + objtype "/bin"))
> + (bindir (string-append out "/bin"))
> + (infwm-script (string-append bindir "/infwm")))
> + `(,(assoc 'set-paths %standard-phases)
> + (unpack . ,(lambda* (#:key source #:allow-other-keys)

For consistency, I would very much prefer if we could use
‘modify-phases’ here, which is what is used throughout gnu/packages.
If that’s fine with you, could you update the patch?

Toggle quote (3 lines)
> + (synopsis
> + "Compact operating system for building cross-platform distributed systems")

Maybe shorten to “Operating system for building distributed systems”?

Thanks!

Ludo’.
D
D
Diego Nicola Barbato wrote on 15 Nov 2018 12:22
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 33080@debbugs.gnu.org)
87a7mazit8.fsf@GlaDOS.home
Hello Ludo,

ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (16 lines)
> Hi Diego,
>
> Sorry for the late reply.
>
> Diego Nicola Barbato <dnbarbato@posteo.de> skribis:
>
>> This patch adds inferno as discussed here:
>> https://lists.gnu.org/archive/html/guix-devel/2018-10/msg00031.html
>
> In that thread we discussed the font issue, and I’m unsure if it was
> resolved:
>
> <https://lists.gnu.org/archive/html/guix-devel/2018-10/msg00265.html>
>
> Is everything “known good” with this version of the patch?

Unfortunately it is not. As you suggested, I wrote to the
GNU/Linux-libre mailing list asking for advice on the font issues [1]
and the licensing issues [2]. The only reply I got so far is not very
encouraging. Maybe it is best to put this on hold until I receive more
information?

Toggle quote (35 lines)
>> From c97b28e97a210cc31e34c08bc1abdc8bd74114fa Mon Sep 17 00:00:00 2001
>> From: Diego Nicola Barbato <dnbarbato@posteo.de>
>> Date: Wed, 17 Oct 2018 23:07:40 +0200
>> Subject: [PATCH] gnu: Add inferno.
>>
>> * gnu/packages/inferno.scm: New file.
>> * gnu/local.mk (GNU_SYSTEM_MODULES): Register it.
>
> Overall it LGTM! Minor suggestions here:
>
>> + #:phases
>> + (let* ((bash (assoc-ref %build-inputs "bash"))
>> + (objtype ,@(match (%current-system)
>> + ((or "armhf-linux" "aarch64-linux")
>> + `("arm"))
>> + (_
>> + `("386"))))
>> + (out (assoc-ref %outputs "out"))
>> + (root (string-append out "/share/inferno"))
>> + (root/bindir (string-append root "/Linux/"
>> + objtype "/bin"))
>> + (bindir (string-append out "/bin"))
>> + (infwm-script (string-append bindir "/infwm")))
>> + `(,(assoc 'set-paths %standard-phases)
>> + (unpack . ,(lambda* (#:key source #:allow-other-keys)
>
> For consistency, I would very much prefer if we could use
> ‘modify-phases’ here, which is what is used throughout gnu/packages.
> If that’s fine with you, could you update the patch?
>
>> + (synopsis
>> + "Compact operating system for building cross-platform distributed systems")
>
> Maybe shorten to “Operating system for building distributed systems”?

If it is OK I will wait for the font and licensing issues to be resolved
before I update the patch, since, as of now, it looks to me like Inferno
can not be included in an FSDG distro.

Thanks for the feedback and I am sorry this turned out to be more
complicated than I anticipated.

Diego


L
L
Ludovic Courtès wrote on 15 Nov 2018 12:51
(name . Diego Nicola Barbato)(address . dnbarbato@posteo.de)(address . 33080@debbugs.gnu.org)
874lci4kzn.fsf@gnu.org
Hi Diego,

Diego Nicola Barbato <dnbarbato@posteo.de> skribis:

Toggle quote (24 lines)
> ludo@gnu.org (Ludovic Courtès) writes:
>
>> Hi Diego,
>>
>> Sorry for the late reply.
>>
>> Diego Nicola Barbato <dnbarbato@posteo.de> skribis:
>>
>>> This patch adds inferno as discussed here:
>>> https://lists.gnu.org/archive/html/guix-devel/2018-10/msg00031.html
>>
>> In that thread we discussed the font issue, and I’m unsure if it was
>> resolved:
>>
>> <https://lists.gnu.org/archive/html/guix-devel/2018-10/msg00265.html>
>>
>> Is everything “known good” with this version of the patch?
>
> Unfortunately it is not. As you suggested, I wrote to the
> GNU/Linux-libre mailing list asking for advice on the font issues [1]
> and the licensing issues [2]. The only reply I got so far is not very
> encouraging. Maybe it is best to put this on hold until I receive more
> information?

Sure, thanks for asking for advice on gnu-linux-libre.

Ludo’.
M
M
Maxim Cournoyer wrote on 13 Jul 2021 14:51
Re: bug#33080: [PATCH] gnu: Add inferno.
(name . Diego Nicola Barbato)(address . dnbarbato@posteo.de)
87mtqqs7fs.fsf_-_@gmail.com
Hello Diego,

Diego Nicola Barbato <dnbarbato@posteo.de> writes:

Toggle quote (27 lines)
> Hello Ludo,
>
> ludo@gnu.org (Ludovic Courtès) writes:
>
>> Hi Diego,
>>
>> Sorry for the late reply.
>>
>> Diego Nicola Barbato <dnbarbato@posteo.de> skribis:
>>
>>> This patch adds inferno as discussed here:
>>> https://lists.gnu.org/archive/html/guix-devel/2018-10/msg00031.html
>>
>> In that thread we discussed the font issue, and I’m unsure if it was
>> resolved:
>>
>> <https://lists.gnu.org/archive/html/guix-devel/2018-10/msg00265.html>
>>
>> Is everything “known good” with this version of the patch?
>
> Unfortunately it is not. As you suggested, I wrote to the
> GNU/Linux-libre mailing list asking for advice on the font issues [1]
> and the licensing issues [2]. The only reply I got so far is not very
> encouraging. Maybe it is best to put this on hold until I receive more
> information?
>

[...]

Toggle quote (4 lines)
> If it is OK I will wait for the font and licensing issues to be resolved
> before I update the patch, since, as of now, it looks to me like Inferno
> can not be included in an FSDG distro.

Sadly, it seems a blocker that there are no sources to rebuild the fonts
from.

We'll have to do without them it seems.

Closing.

Maxim
Closed
?