Submitting package for SpaceFM

  • Done
  • quality assurance status badge
Details
2 participants
  • Ison111
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ison111
Severity
normal
I
I
Ison111 wrote on 25 Aug 2018 22:27
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
C4TIVs2sC5pUGnCRdn7gjE1Z5DCIV4bQ0p3gBBYERI7iYUqPi5e2bn8MWt0EV06Mjj0t2B1lTsGKQpIriQTCD4HdKUi0zzDszs_yUyW9FRI=@protonmail.com
Hello,
I would like to submit this package for the SpaceFM file manager.
Attachment: file
(define-module (gnu packages spacefm) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix utils) #:use-module (guix build-system gnu) #:use-module (gnu packages) #:use-module (gnu packages bash) #:use-module (gnu packages pkg-config) #:use-module (gnu packages gtk) #:use-module (gnu packages linux) #:use-module (gnu packages freedesktop) #:use-module (gnu packages gnome) #:use-module (gnu packages glib) #:use-module (gnu packages video) #:use-module (gnu packages lsof)) (define-public spacefm (package (name "spacefm") (version "1.0.6") (source (origin (method url-fetch) (uri (string-append "https://github.com/IgnorantGuru/spacefm/archive/" version ".tar.gz")) (sha256 (base32 "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy")) (file-name (string-append name "-" version ".tar.gz")))) (build-system gnu-build-system) (native-inputs `(("pkg-config" ,pkg-config))) (inputs `(("bash" ,bash) ("gtk+" ,gtk+) ("eudev" ,eudev) ("desktop-file-utils" ,desktop-file-utils) ("shared-mime-info" ,shared-mime-info) ("intltool" ,intltool) ("ffmpegthumbnailer" ,ffmpegthumbnailer) ("jmtpfs" ,jmtpfs) ("lsof" ,lsof) ("udisks" ,udisks))) (arguments `(#:configure-flags (list (string-append "--with-bash-path=" (assoc-ref %build-inputs "bash") "/bin/bash") (string-append "--sysconfdir=" (assoc-ref %outputs "out") "/etc")))) (home-page "http://ignorantguru.github.io/spacefm/") (synopsis "A multi-panel tabbed file manager") (description "Multi-panel tabbed file and desktop manager for GNU/Linux with built-in VFS, udev- or HAL-based device manager, customizable menu system, and bash integration") (license license:gpl3+)))
L
L
Ludovic Courtès wrote on 26 Aug 2018 00:20
(name . Ison111)(address . ison111@protonmail.com)(address . 32529@debbugs.gnu.org)
87lg8u6qc4.fsf@gnu.org
Hello Ison111,

Could you please send it as a patch as produced by ‘git format-patch’?
Please see
which also contains other pieces of advice.

At first sight there are a couple of minor issues that ‘guix lint’
should report. Usually we don’t indent items in the ‘inputs’ list the
way you did, but I’m nitpicking.

Could you send the updated patch? Let me know if you have troubles with
any of this.

Thanks,
Ludo’.
I
I
Ison111 wrote on 26 Aug 2018 10:57
[PATCH] Submit SpaceFM package
(name . 32529@debbugs.gnu.org)(address . 32529@debbugs.gnu.org)
HCgKuJAAnX5ZtIKw145k6whCnsAjSqBzvl6FJIohkc6M2ZmKwQvBlwLuLtbyKU5n1S-LDEG1U8fMKJejvuv8_CIx3780PGMvNyUGk3TrLaM=@protonmail.com
Sorry for the poor formatting, and thanks for the documentation. Please let me know if there are still any issues, or if this package should be added to an existing package file instead of given it's own as I'm not sure what the convention is for that.
Attachment: file
From 5212c860c123b161c08208beaa429b581542ce88 Mon Sep 17 00:00:00 2001
From: ison111 <ison111@protonmail.com>
Date: Sun, 26 Aug 2018 02:49:59 -0600
Subject: [PATCH] Submit SpaceFM package

---
gnu/packages/spacefm.scm | 55 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)
create mode 100644 gnu/packages/spacefm.scm

Toggle diff (63 lines)
diff --git a/gnu/packages/spacefm.scm b/gnu/packages/spacefm.scm
new file mode 100644
index 000000000..d32d39ec0
--- /dev/null
+++ b/gnu/packages/spacefm.scm
@@ -0,0 +1,55 @@
+(define-module (gnu packages spacefm)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix utils)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages bash)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages video)
+ #:use-module (gnu packages lsof))
+
+(define-public spacefm
+ (package
+ (name "spacefm")
+ (version "1.0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/IgnorantGuru/spacefm/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1jg7xfyr7kihjnalxp8wxyb9qjk8hqf5l36rp3s0lvkpmpyakppy"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs `(("bash" ,bash)
+ ("gtk+" ,gtk+)
+ ("eudev" ,eudev)
+ ("desktop-file-utils" ,desktop-file-utils)
+ ("shared-mime-info" ,shared-mime-info)
+ ("ffmpegthumbnailer" ,ffmpegthumbnailer)
+ ("jmtpfs" ,jmtpfs)
+ ("lsof" ,lsof)
+ ("udisks" ,udisks)))
+ (arguments
+ `(#:configure-flags (list (string-append "--with-bash-path="
+ (assoc-ref %build-inputs "bash")
+ "/bin/bash")
+ (string-append "--sysconfdir="
+ (assoc-ref %outputs "out")
+ "/etc"))))
+ (home-page "http://ignorantguru.github.io/spacefm/")
+ (synopsis "Multi-panel tabbed file manager")
+ (description "Multi-panel tabbed file manager for GNU/Linux
+based on PCManFM with built-in virtual file system, udev- or
+HAL-based device manager, customizable menu system, and bash
+integration. Comes with a build-in desktop and device manager.")
+ (license license:gpl3+)))
--
2.18.0
L
L
Ludovic Courtès wrote on 28 Aug 2018 12:37
(name . Ison111)(address . ison111@protonmail.com)(name . 32529@debbugs.gnu.org)(address . 32529-done@debbugs.gnu.org)
87wosalqup.fsf@gnu.org
Hello Ison111,

Ison111 <ison111@protonmail.com> skribis:

Toggle quote (2 lines)
> Sorry for the poor formatting, and thanks for the documentation. Please let me know if there are still any issues, or if this package should be added to an existing package file instead of given it's own as I'm not sure what the convention is for that.

I ended up moving it to lxde.scm, next to PCManFM. I added a copyright
line for you, tweaked the description, and added a commit log that
follows our conventions. You can see the result here:


Thank you!

Ludo’.
Closed
?