Submission of patch for Add r-abc

  • Done
  • quality assurance status badge
Details
2 participants
  • Ricardo Wurmus
  • Sahithi Yarlagadda
Owner
unassigned
Submitted by
Sahithi Yarlagadda
Severity
normal
S
S
Sahithi Yarlagadda wrote on 21 Mar 2018 12:14
(address . guix-patches@gnu.org)(name . Ricardo Wurmus)(address . rekado@elephly.net)
071fa29f-107d-2097-586c-ce2f1eb91c23@swecha.net
Hi,

I am submitting a patch for r-abc. Please review.

--
Regards
Sahithi
From 4b3b3eee4995616059d8a27489affc43cee26ea4 Mon Sep 17 00:00:00 2001
From: Sahithi Yarlagadda <sahi@swecha.net>
Date: Wed, 21 Mar 2018 16:30:18 +0530
Subject: [PATCH] gnu: Add r-abc.

* gnu/packages/cran.scm (r-abc): New variable.
---
gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ce09c22c5..6aecd0f8e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3295,3 +3295,33 @@ Dependencies of the distribution of the specified variable (response
variable) to other variables (explanatory variables) are derived and
evaluated by the @dfn{Akaike Information Criterion} (AIC).")
(license license:gpl2+)))
+
+(define-public r-abc
+ (package
+ (name "r-abc")
+ (version "2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abc" version))
+ (sha256
+ (base32
+ "0ngzaaz2y2s03fhngvwipmy4kq38xrmyddaz6a6l858rxvadrlhb"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-abc-data" ,r-abc-data)
+ ("r-locfit" ,r-locfit)
+ ("r-mass" ,r-mass)
+ ("r-nnet" ,r-nnet)
+ ("r-quantreg" ,r-quantreg)))
+ (home-page
+ "http://cran.r-project.org/web/packages/abc")
+ (synopsis
+ "Tools for approximate bayesian computation (ABC)")
+ (description
+ "Implements several ABC algorithms for performing parameter estimation,
+model selection, and goodness-of-fit. Cross-validation tools are also
+available for measuring the accuracy of ABC estimates, and to calculate the
+misclassification probabilities of different models.")
+ (license license:gpl3+)))
+
--
2.16.2
R
R
Ricardo Wurmus wrote on 21 Mar 2018 22:27
(name . Sahithi Yarlagadda)(address . sahi@swecha.net)(address . 30894@debbugs.gnu.org)
87tvt9azl6.fsf@elephly.net
Hi Sahithi,

Toggle quote (2 lines)
> I am submitting a patch for r-abc. Please review.

Thank you for the patch!

What follows is a short review that includes things I could change
myself before applying the patch, but for the sake of learning I
explicitly point out in this message. I hope you don’t mind that I’m
focusing on what may seem like minor details.

Toggle quote (7 lines)
> From 4b3b3eee4995616059d8a27489affc43cee26ea4 Mon Sep 17 00:00:00 2001
> From: Sahithi Yarlagadda <sahi@swecha.net>
> Date: Wed, 21 Mar 2018 16:30:18 +0530
> Subject: [PATCH] gnu: Add r-abc.
>
> * gnu/packages/cran.scm (r-abc): New variable.

Nitpick: please don’t indent this line. The asterisk should be the
first character in this line.

Toggle quote (22 lines)
> +
> +(define-public r-abc
> + (package
> + (name "r-abc")
> + (version "2.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (cran-uri "abc" version))
> + (sha256
> + (base32
> + "0ngzaaz2y2s03fhngvwipmy4kq38xrmyddaz6a6l858rxvadrlhb"))))
> + (build-system r-build-system)
> + (propagated-inputs
> + `(("r-abc-data" ,r-abc-data)
> + ("r-locfit" ,r-locfit)
> + ("r-mass" ,r-mass)
> + ("r-nnet" ,r-nnet)
> + ("r-quantreg" ,r-quantreg)))
> + (home-page
> + "http://cran.r-project.org/web/packages/abc")

Please pull this onto the previous line and use “https”.

Toggle quote (3 lines)
> + (synopsis
> + "Tools for approximate bayesian computation (ABC)")

Please combine this line with the previous line.

Toggle quote (6 lines)
> + (description
> + "Implements several ABC algorithms for performing parameter estimation,
> +model selection, and goodness-of-fit. Cross-validation tools are also
> +available for measuring the accuracy of ABC estimates, and to calculate the
> +misclassification probabilities of different models.")

Please use full sentences. For CRAN packages the official description
usually provides only a sentence fragment in place of the first
sentence. Please also use “@dfn{Approximate Bayesian Computation}
(ABC)” the first time “ABC” is mentioned.

All thoughout the indentation is a bit off (that’s expected as the
importer is very simple and doesn’t know about the expected
indentation). If you’re using Emacs you can easily adjust it with M-C-q
(also known as “indent-sexp”); otherwise please use
“etc/indent-code.el”.

Have you built this package with Guix?

Finally, please rebase this patch so that it can be applied
independently from the other patch you’ve sent, which cannot currently
be applied due to problems in building the defined package. Rebasing
this patch ensures that it can be merged even if the other patch is
stuck.

Thanks!

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
R
R
Ricardo Wurmus wrote on 28 Mar 2018 21:44
Re: [bug#30894] Submission of patch for Add r-abc
(name . Sahithi Yarlagadda)(address . sahi@swecha.net)(address . 30894@debbugs.gnu.org)
87vadgdlyd.fsf@elephly.net
Hi Sahiti,

have you been able to look at my review below?
Please let me know if anything is unclear.

~~ Ricardo

Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (76 lines)
> Hi Sahithi,
>
>> I am submitting a patch for r-abc. Please review.
>
> Thank you for the patch!
>
> What follows is a short review that includes things I could change
> myself before applying the patch, but for the sake of learning I
> explicitly point out in this message. I hope you don’t mind that I’m
> focusing on what may seem like minor details.
>
>> From 4b3b3eee4995616059d8a27489affc43cee26ea4 Mon Sep 17 00:00:00 2001
>> From: Sahithi Yarlagadda <sahi@swecha.net>
>> Date: Wed, 21 Mar 2018 16:30:18 +0530
>> Subject: [PATCH] gnu: Add r-abc.
>>
>> * gnu/packages/cran.scm (r-abc): New variable.
>
> Nitpick: please don’t indent this line. The asterisk should be the
> first character in this line.
>
>> +
>> +(define-public r-abc
>> + (package
>> + (name "r-abc")
>> + (version "2.1")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (cran-uri "abc" version))
>> + (sha256
>> + (base32
>> + "0ngzaaz2y2s03fhngvwipmy4kq38xrmyddaz6a6l858rxvadrlhb"))))
>> + (build-system r-build-system)
>> + (propagated-inputs
>> + `(("r-abc-data" ,r-abc-data)
>> + ("r-locfit" ,r-locfit)
>> + ("r-mass" ,r-mass)
>> + ("r-nnet" ,r-nnet)
>> + ("r-quantreg" ,r-quantreg)))
>> + (home-page
>> + "http://cran.r-project.org/web/packages/abc")
>
> Please pull this onto the previous line and use “https”.
>
>> + (synopsis
>> + "Tools for approximate bayesian computation (ABC)")
>
> Please combine this line with the previous line.
>
>> + (description
>> + "Implements several ABC algorithms for performing parameter estimation,
>> +model selection, and goodness-of-fit. Cross-validation tools are also
>> +available for measuring the accuracy of ABC estimates, and to calculate the
>> +misclassification probabilities of different models.")
>
> Please use full sentences. For CRAN packages the official description
> usually provides only a sentence fragment in place of the first
> sentence. Please also use “@dfn{Approximate Bayesian Computation}
> (ABC)” the first time “ABC” is mentioned.
>
> All thoughout the indentation is a bit off (that’s expected as the
> importer is very simple and doesn’t know about the expected
> indentation). If you’re using Emacs you can easily adjust it with M-C-q
> (also known as “indent-sexp”); otherwise please use
> “etc/indent-code.el”.
>
> Have you built this package with Guix?
>
> Finally, please rebase this patch so that it can be applied
> independently from the other patch you’ve sent, which cannot currently
> be applied due to problems in building the defined package. Rebasing
> this patch ensures that it can be merged even if the other patch is
> stuck.
>
> Thanks!
R
R
Ricardo Wurmus wrote on 28 Mar 2018 21:51
control message for bug #30894
(address . control@debbugs.gnu.org)
E1f1H6d-0006MD-Dw@debbugs.gnu.org
tags 30894 moreinfo
S
S
Sahithi Yarlagadda wrote on 29 Mar 2018 12:15
Re: [bug#30894] Submission of patch for Add r-abc
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 30894@debbugs.gnu.org)
6c9c531d-75a5-be08-2784-ebae3c3a432b@swecha.net
Hi Ricardo


I have a small doubt regarding the build. Let me explain the process i
am doing the build.

1) Cloning the Source

2) Running guix environment guix

3) ./bootstrap

4) ./configure --localstatedir=/var

5) make

6) Make Changes to the cran.scm file

7) Build using  ./pre-inst-env guix build <package>

8) If build is success, format the patch and submit the patch

*When i am planning to write a different package description, i am
following this*

9) rebasing the patch

10) Pull for any changes

11) running the process from (2)


Am i doing the right way, I hope i have to compile everytime and then
make changes each Package Description. Because when i tired to just make
changes and build on old one, i got many errors and warning saying the
.go file is older than the .scm.


Please suggest me.


On Thursday 29 March 2018 01:14 AM, Ricardo Wurmus wrote:
Toggle quote (84 lines)
> Hi Sahiti,
>
> have you been able to look at my review below?

> Please let me know if anything is unclear.
>
> ~~ Ricardo
>
> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> Hi Sahithi,
>>
>>> I am submitting a patch for r-abc. Please review.
>> Thank you for the patch!
>>
>> What follows is a short review that includes things I could change
>> myself before applying the patch, but for the sake of learning I
>> explicitly point out in this message. I hope you don’t mind that I’m
>> focusing on what may seem like minor details.
>>
>>> From 4b3b3eee4995616059d8a27489affc43cee26ea4 Mon Sep 17 00:00:00 2001
>>> From: Sahithi Yarlagadda <sahi@swecha.net>
>>> Date: Wed, 21 Mar 2018 16:30:18 +0530
>>> Subject: [PATCH] gnu: Add r-abc.
>>>
>>> * gnu/packages/cran.scm (r-abc): New variable.
>> Nitpick: please don’t indent this line. The asterisk should be the
>> first character in this line.
>>
>>> +
>>> +(define-public r-abc
>>> + (package
>>> + (name "r-abc")
>>> + (version "2.1")
>>> + (source
>>> + (origin
>>> + (method url-fetch)
>>> + (uri (cran-uri "abc" version))
>>> + (sha256
>>> + (base32
>>> + "0ngzaaz2y2s03fhngvwipmy4kq38xrmyddaz6a6l858rxvadrlhb"))))
>>> + (build-system r-build-system)
>>> + (propagated-inputs
>>> + `(("r-abc-data" ,r-abc-data)
>>> + ("r-locfit" ,r-locfit)
>>> + ("r-mass" ,r-mass)
>>> + ("r-nnet" ,r-nnet)
>>> + ("r-quantreg" ,r-quantreg)))
>>> + (home-page
>>> + "http://cran.r-project.org/web/packages/abc")
>> Please pull this onto the previous line and use “https”.
>>
>>> + (synopsis
>>> + "Tools for approximate bayesian computation (ABC)")
>> Please combine this line with the previous line.
>>
>>> + (description
>>> + "Implements several ABC algorithms for performing parameter estimation,
>>> +model selection, and goodness-of-fit. Cross-validation tools are also
>>> +available for measuring the accuracy of ABC estimates, and to calculate the
>>> +misclassification probabilities of different models.")
>> Please use full sentences. For CRAN packages the official description
>> usually provides only a sentence fragment in place of the first
>> sentence. Please also use “@dfn{Approximate Bayesian Computation}
>> (ABC)” the first time “ABC” is mentioned.
>>
>> All thoughout the indentation is a bit off (that’s expected as the
>> importer is very simple and doesn’t know about the expected
>> indentation). If you’re using Emacs you can easily adjust it with M-C-q
>> (also known as “indent-sexp”); otherwise please use
>> “etc/indent-code.el”.
>>
>> Have you built this package with Guix?
>>
>> Finally, please rebase this patch so that it can be applied
>> independently from the other patch you’ve sent, which cannot currently
>> be applied due to problems in building the defined package. Rebasing
>> this patch ensures that it can be merged even if the other patch is
>> stuck.
>>
>> Thanks!
>
>

--
Regards
Sahithi
Attachment: file
R
R
Ricardo Wurmus wrote on 29 Mar 2018 12:32
(name . Sahithi Yarlagadda)(address . sahi@swecha.net)(address . 30894@debbugs.gnu.org)
87lgebdveu.fsf@elephly.net
Hi Sahithi,

Toggle quote (8 lines)
> 1) Cloning the Source
>
> 2) Running guix environment guix
>
> 3) ./bootstrap
>
> 4) ./configure --localstatedir=/var

You need to perform these steps only once.

Toggle quote (8 lines)
> 5) make
>
> 6) Make Changes to the cran.scm file
>
> 7) Build using ./pre-inst-env guix build <package>
>
> 8) If build is success, format the patch and submit the patch

I suggest running make again after making changes to any file in the
Guix source tree. This way you can avoid the “.go file is older than
the .scm” messages.

Toggle quote (9 lines)
> *When i am planning to write a different package description, i am
> following this*
>
> 9) rebasing the patch
>
> 10) Pull for any changes
>
> 11) running the process from (2)

I’d do this instead:

git fetch origin # fetch any upstream changes
git stash # hide my uncommitted local changes
git rebase origin/master # rebase my local commits on top of upstream
git stash pop # apply my uncommitted local changes
make # compile .scm to .go

Note that you should be inside of a suitable environment when running
“make”, so better do all of this after “guix environment guix”.

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
S
S
Sahithi Yarlagadda wrote on 29 Mar 2018 12:50
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 30894@debbugs.gnu.org)
cdefaf9b-5815-a400-97af-88f32fda656f@swecha.net
Thanks Ricardo

When i am building r-abc  I found errors with the following.

  (propagated-inputs
     `(("r-abc-data" ,r-abc-data)


abc.data is the upstream name of abc-data. I am figuring out how to use
it. I have searched for various package description to compare the
usage, but in vain. Can u help me what attribute is to be given to make
it work.



On Thursday 29 March 2018 04:02 PM, Ricardo Wurmus wrote:
Toggle quote (50 lines)
> Hi Sahithi,
>
>> 1) Cloning the Source
>>
>> 2) Running guix environment guix
>>
>> 3) ./bootstrap
>>
>> 4) ./configure --localstatedir=/var
> You need to perform these steps only once.
>
>> 5) make
>>
>> 6) Make Changes to the cran.scm file
>>
>> 7) Build using ./pre-inst-env guix build <package>
>>
>> 8) If build is success, format the patch and submit the patch
> I suggest running make again after making changes to any file in the
> Guix source tree. This way you can avoid the “.go file is older than
> the .scm” messages.
>
>> *When i am planning to write a different package description, i am
>> following this*
>>
>> 9) rebasing the patch
>>
>> 10) Pull for any changes
>>
>> 11) running the process from (2)
> I’d do this instead:
>
> git fetch origin # fetch any upstream changes
> git stash # hide my uncommitted local changes
> git rebase origin/master # rebase my local commits on top of upstream
> git stash pop # apply my uncommitted local changes
> make # compile .scm to .go
>
> Note that you should be inside of a suitable environment when running
> “make”, so better do all of this after “guix environment guix”.
>
> --
> Ricardo
>
> GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
> https://elephly.net
>
>
>

--
Regards
Sahithi
S
S
Sahithi Yarlagadda wrote on 29 Mar 2018 13:00
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 30894@debbugs.gnu.org)
53d2dd04-03cd-4069-5aee-e4ff3d1f865d@swecha.net
Hi

I am planning to do this.

I will submit the Package Description for r-abc-data. Which builds and
create a derivative in gnu/store. Later i will send the abc package
description, where the build finds necessary data and does a successful
build.


On Thursday 29 March 2018 04:20 PM, Sahithi Yarlagadda wrote:
Toggle quote (66 lines)
> Thanks Ricardo
>
> When i am building r-abc  I found errors with the following.
>
>   (propagated-inputs
>      `(("r-abc-data" ,r-abc-data)
>
>
> abc.data is the upstream name of abc-data. I am figuring out how to use
> it. I have searched for various package description to compare the
> usage, but in vain. Can u help me what attribute is to be given to make
> it work.
>
>
>
> On Thursday 29 March 2018 04:02 PM, Ricardo Wurmus wrote:
>> Hi Sahithi,
>>
>>> 1) Cloning the Source
>>>
>>> 2) Running guix environment guix
>>>
>>> 3) ./bootstrap
>>>
>>> 4) ./configure --localstatedir=/var
>> You need to perform these steps only once.
>>
>>> 5) make
>>>
>>> 6) Make Changes to the cran.scm file
>>>
>>> 7) Build using ./pre-inst-env guix build <package>
>>>
>>> 8) If build is success, format the patch and submit the patch
>> I suggest running make again after making changes to any file in the
>> Guix source tree. This way you can avoid the “.go file is older than
>> the .scm” messages.
>>
>>> *When i am planning to write a different package description, i am
>>> following this*
>>>
>>> 9) rebasing the patch
>>>
>>> 10) Pull for any changes
>>>
>>> 11) running the process from (2)
>> I’d do this instead:
>>
>> git fetch origin # fetch any upstream changes
>> git stash # hide my uncommitted local changes
>> git rebase origin/master # rebase my local commits on top of upstream
>> git stash pop # apply my uncommitted local changes
>> make # compile .scm to .go
>>
>> Note that you should be inside of a suitable environment when running
>> “make”, so better do all of this after “guix environment guix”.
>>
>> --
>> Ricardo
>>
>> GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
>> https://elephly.net
>>
>>
>>

--
Regards
Sahithi
S
S
Sahithi Yarlagadda wrote on 29 Mar 2018 13:28
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 30894@debbugs.gnu.org)
9fb9be96-8bc2-fd88-4528-0141cbdb323d@swecha.net
Hi

On Thursday 29 March 2018 04:30 PM, Sahithi Yarlagadda wrote:
Toggle quote (9 lines)
> Hi
>
> I am planning to do this.
>
> I will submit the Package Description for r-abc-data. Which builds and
> create a derivative in gnu/store. Later i will send the abc package
> description, where the build finds necessary data and does a successful
> build.

Submitted a Patch file for r-abc-data which is a dependency for r-abc



Then,
Re-based the source

git fetch origin # fetch any upstream changes
git stash # hide my uncommitted local changes
git rebase origin/master # rebase my local commits on top of upstream
git stash pop # apply my uncommitted local changes
make # compile .scm to .go


I have done adding r-abc. And the build was success.

 ( I am still unsure whether i did it right. Fingers Crossed !!!! ...
Waiting for your comment)

Its a great experience while learning with each contribution. Each
Package Description have a different things to look into carefully and
contribute.

Ricardo have been of great help in this process.

Created a Patch (I sense something's not right here!!!). 
Submitting for the review.



Toggle quote (68 lines)
>
> On Thursday 29 March 2018 04:20 PM, Sahithi Yarlagadda wrote:
>> Thanks Ricardo
>>
>> When i am building r-abc  I found errors with the following.
>>
>>   (propagated-inputs
>>      `(("r-abc-data" ,r-abc-data)
>>
>>
>> abc.data is the upstream name of abc-data. I am figuring out how to use
>> it. I have searched for various package description to compare the
>> usage, but in vain. Can u help me what attribute is to be given to make
>> it work.
>>
>>
>>
>> On Thursday 29 March 2018 04:02 PM, Ricardo Wurmus wrote:
>>> Hi Sahithi,
>>>
>>>> 1) Cloning the Source
>>>>
>>>> 2) Running guix environment guix
>>>>
>>>> 3) ./bootstrap
>>>>
>>>> 4) ./configure --localstatedir=/var
>>> You need to perform these steps only once.
>>>
>>>> 5) make
>>>>
>>>> 6) Make Changes to the cran.scm file
>>>>
>>>> 7) Build using ./pre-inst-env guix build <package>
>>>>
>>>> 8) If build is success, format the patch and submit the patch
>>> I suggest running make again after making changes to any file in the
>>> Guix source tree. This way you can avoid the “.go file is older than
>>> the .scm” messages.
>>>
>>>> *When i am planning to write a different package description, i am
>>>> following this*
>>>>
>>>> 9) rebasing the patch
>>>>
>>>> 10) Pull for any changes
>>>>
>>>> 11) running the process from (2)
>>> I’d do this instead:
>>>
>>> git fetch origin # fetch any upstream changes
>>> git stash # hide my uncommitted local changes
>>> git rebase origin/master # rebase my local commits on top of upstream
>>> git stash pop # apply my uncommitted local changes
>>> make # compile .scm to .go
>>>
>>> Note that you should be inside of a suitable environment when running
>>> “make”, so better do all of this after “guix environment guix”.
>>>
>>> --
>>> Ricardo
>>>
>>> GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
>>> https://elephly.net
>>>
>>>
>>>

--
Regards
Sahithi
From 0f248126c47882a0d8b866787577a7335de0a735 Mon Sep 17 00:00:00 2001
From: Sahithi Yarlagadda <sahi@swecha.net>
Date: Thu, 29 Mar 2018 16:42:18 +0530
Subject: [PATCH] gnu: Add r-abc.

* gnu/packages/cran.scm (r-abc): New variable.
---
gnu/packages/cran.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8602a7d87..70551507a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3593,3 +3593,32 @@ implements several @dfn{Approximate Bayesian Computation} (ABC) algorithms
for performing parameter estimation, model selection, and goodness-of-fit.")
(license license:gpl3)))
+(define-public r-abc
+ (package
+ (name "r-abc")
+ (version "2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abc" version))
+ (sha256
+ (base32
+ "0ngzaaz2y2s03fhngvwipmy4kq38xrmyddaz6a6l858rxvadrlhb"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-abc-data" ,r-abc-data)
+ ("r-locfit" ,r-locfit)
+ ("r-mass" ,r-mass)
+ ("r-nnet" ,r-nnet)
+ ("r-quantreg" ,r-quantreg)))
+ (home-page "https://cran.r-project.org/web/packages/abc")
+ (synopsis "Tools for approximate bayesian computation (ABC)")
+ (description
+ "Implements several @dfn{Approximate Bayesian Computation} (ABC)
+algorithms for performing parameter estimation, model selection, and
+goodness-of-fit. Cross-validation tools are also available for
+measuring the accuracy of ABC estimates, and to calculate the
+misclassification probabilities of different models.")
+ (license license:gpl3)))
+
+
--
2.16.2
R
R
Ricardo Wurmus wrote on 2 Apr 2018 23:26
(name . Sahithi Yarlagadda)(address . sahi@swecha.net)(address . 30894-done@debbugs.gnu.org)
87woxpcnbg.fsf@elephly.net
Hi Sahithi,

Toggle quote (2 lines)
> I have done adding r-abc. And the build was success.

Excellent! I also built it without problems.

I couldn’t apply it cleanly after making modifications to r-abc-data,
but that’s not your problem. I performed these minor changes:

* changed license from gpl3 to gpl3+
* added a beginning to the description.

Pushed the patch to the master branch with commit 82c8e0ae0.

Thanks again!

~~ Ricardo
Closed
?