[PATCH core-updates 0/3] nologin and ifconfig profile conflicts

  • Done
  • quality assurance status badge
Details
6 participants
  • Danny Milosavljevic
  • Leo Famulari
  • Ludovic Courtès
  • Marius Bakke
  • Marius Bakke
  • zimoun
Owner
unassigned
Submitted by
Marius Bakke
Severity
normal
M
M
Marius Bakke wrote on 6 Mar 2018 17:54
(address . guix-patches@gnu.org)(name . Marius Bakke)(address . mbakke@fastmail.com)
20180306165438.4306-1-mbakke@fastmail.com
These patches aim to fix conflicts in the default profile. The second
patch is unrelated and not necessarily even accurate.

Feedback wanted!

Marius Bakke (3):
gnu: util-linux: Don't build 'nologin'.
gnu: util-linux: Move '.la' files to static output.
gnu: net-tools: Don't install 'ifconfig'.

gnu/packages/linux.scm | 17 ++++++++++++-----
1 file changed, 12 insertions(+), 5 deletions(-)

--
2.16.2
M
M
Marius Bakke wrote on 6 Mar 2018 17:56
[PATCH core-updates 1/3] gnu: util-linux: Don't build 'nologin'.
(address . 30734@debbugs.gnu.org)(name . Marius Bakke)(address . mbakke@fastmail.com)
20180306165642.4486-1-mbakke@fastmail.com
* gnu/packages/linux.scm (util-linux)[source](snippet): Add substitution.
---
gnu/packages/linux.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c33b473ca..e63abcea4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -559,12 +559,13 @@ providing the system administrator with some help in common tasks.")
(patches (search-patches "util-linux-tests.patch"))
(modules '((guix build utils)))
(snippet
- ;; We take the 'logger' program from GNU Inetutils and 'kill'
- ;; from GNU Coreutils.
+ ;; We take 'nologin' from Shadow, the 'logger' program from
+ ;; GNU Inetutils and 'kill' from GNU Coreutils.
'(begin
(substitute* "configure"
(("build_logger=yes") "build_logger=no")
- (("build_kill=yes") "build_kill=no"))
+ (("build_kill=yes") "build_kill=no")
+ (("build_nologin=yes") "build_nologin=no"))
#t))))
(build-system gnu-build-system)
(outputs '("out"
--
2.16.2
M
M
Marius Bakke wrote on 6 Mar 2018 17:56
[PATCH core-updates 2/3] gnu: util-linux: Move '.la' files to static output.
(address . 30734@debbugs.gnu.org)(name . Marius Bakke)(address . mbakke@fastmail.com)
20180306165642.4486-2-mbakke@fastmail.com
* gnu/packages/linux.scm (util-linux)[arguments]: Update 'move-static-libs'
phase to include .la files. Substitute the output.
---
gnu/packages/linux.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e63abcea4..dffe2c49c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -608,10 +608,16 @@ providing the system administrator with some help in common tasks.")
(mkdir-p (string-append static "/lib"))
(with-directory-excursion out
(for-each (lambda (file)
+ ;; The dynamic linker does not need the '.la'
+ ;; files, but libtool might. Make sure they
+ ;; refer to the right output.
+ (when (string= ".la" (string-take-right file 3))
+ (substitute* file
+ ((out) static)))
(rename-file file
(string-append static "/"
file)))
- (find-files "lib" "\\.a$")))
+ (find-files "lib" "\\.l?a$")))
#t))))))
(inputs `(("zlib" ,zlib)
("ncurses" ,ncurses)
--
2.16.2
M
M
Marius Bakke wrote on 6 Mar 2018 17:56
[PATCH core-updates 3/3] gnu: net-tools: Don't install 'ifconfig'.
(address . 30734@debbugs.gnu.org)(name . Marius Bakke)(address . mbakke@fastmail.com)
20180306165642.4486-3-mbakke@fastmail.com
* gnu/packages/linux.scm (net-tools)[arguments]: In
REMOVE-REDUNDANT-COMMANDS-PHASE, add regexp for ifconfig.
---
gnu/packages/linux.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index dffe2c49c..8c07d1fdd 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1290,7 +1290,7 @@ inadequately in modern network environments, and both should be deprecated.")
;; Remove commands and man pages redundant with Inetutils.
(let* ((out (assoc-ref outputs "out"))
(dup (append-map (cut find-files out <>)
- '("^hostname"
+ '("^hostname" "^ifconfig"
"^(yp|nis|dns)?domainname"))))
(for-each delete-file dup)
#t))))
--
2.16.2
D
D
Danny Milosavljevic wrote on 6 Mar 2018 18:04
Re: [bug#30734] [PATCH core-updates 2/3] gnu: util-linux: Move '.la' files to static output.
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 30734@debbugs.gnu.org)
20180306180449.074d2365@scratchpost.org
Hi Marius,

On Tue, 6 Mar 2018 17:56:41 +0100
Marius Bakke <mbakke@fastmail.com> wrote:

Toggle quote (12 lines)
> index e63abcea4..dffe2c49c 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -608,10 +608,16 @@ providing the system administrator with some help in common tasks.")
> (mkdir-p (string-append static "/lib"))
> (with-directory-excursion out
> (for-each (lambda (file)
> + ;; The dynamic linker does not need the '.la'
> + ;; files, but libtool might. Make sure they
> + ;; refer to the right output.
> + (when (string= ".la" (string-take-right file 3))

string-take-right errors out when given an argument which is longer than the length of FILE.

I suggest using (string-suffix? ".la" file) instead.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlqeyjEACgkQ5xo1VCww
uqUgKQf/fO895XT2xesC88wJBkFbSW9A4u/ir66tFK1o0ci50BCJhRLN2LDU41oG
NVrhBy6lz6NBcZ06jrXtH7N9I9nu0FJxILyZwbaP4u+lizDVPQP1BS3uZbEROyPa
sdDhlhM626sV/BcbgObCJCF/5KPPQ8wy35VxA02cOHiMTnm630Qlho9Ix0LNoHiI
n6+UL7kAceiGaazkYwKTmtcBcIP975lBWGj77A+VZjRSysYEcrW96FUvlLHvCgJR
qkQ92chTZipySe9T+vMui2PCJJl3p5B3miKhpXQALaLOxbFiXyO2VqQBMxzAoU2O
zVwYyH7abQYnENgpNQH72N9trrk4dw==
=ihtu
-----END PGP SIGNATURE-----


D
D
Danny Milosavljevic wrote on 6 Mar 2018 21:20
Re: [bug#30734] [PATCH core-updates 3/3] gnu: net-tools: Don't install 'ifconfig'.
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 30734@debbugs.gnu.org)
20180306212009.58742508@scratchpost.org
Hi Marius,

On Tue, 6 Mar 2018 17:56:42 +0100
Marius Bakke <mbakke@fastmail.com> wrote:

Toggle quote (19 lines)
> * gnu/packages/linux.scm (net-tools)[arguments]: In
> REMOVE-REDUNDANT-COMMANDS-PHASE, add regexp for ifconfig.
> ---
> gnu/packages/linux.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index dffe2c49c..8c07d1fdd 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -1290,7 +1290,7 @@ inadequately in modern network environments, and both should be deprecated.")
> ;; Remove commands and man pages redundant with Inetutils.
> (let* ((out (assoc-ref outputs "out"))
> (dup (append-map (cut find-files out <>)
> - '("^hostname"
> + '("^hostname" "^ifconfig"
> "^(yp|nis|dns)?domainname"))))
> (for-each delete-file dup)

Is there a reason why those regular expressions don't end in "$" (meaning "at the end")?

Otherwise LGTM!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlqe9/kACgkQ5xo1VCww
uqUhywf/VytEsUUq5wgUFtHYoPmBbT5fq4o+XbGIILo7TEEO+ZHRGFR2Cb0MMdL+
+fyuisHOkyxZdZeoPXduLXTX0dtlF+e6FgnVJPu/ksmfCicI2rR9zKnuAN9Oucdf
yfJkVKhx8MT7GHItEwJKqJXAxJbe90ND8tbG0teO6LuDHZOUrq3mLVDwmqhfBMTi
2skxoN0BHqAfrT+Wqok6LYMlWttmId0yiB88sb/9aqrZ8BkxxQUQPnkC5ze9shmb
yQWo61qeAAJyLScyqTk8ns4cfWiHBFDgH8iFGRTMjUVyP70jIYJvZObXR7zyXSi/
k9Hm82QRfoChEh3/icDmrg5riS3koA==
=giXq
-----END PGP SIGNATURE-----


D
D
Danny Milosavljevic wrote on 6 Mar 2018 21:20
Re: [bug#30734] [PATCH core-updates 1/3] gnu: util-linux: Don't build 'nologin'.
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 30734@debbugs.gnu.org)
20180306212051.4c212370@scratchpost.org
LGTM!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlqe+CMACgkQ5xo1VCww
uqU0Vwf5ARi4o7sBC5pEUpW+Cvz1Vq7mPYp6DP6YaxPqmwQ2GNIC6q36EsWU0qOZ
gMx8OvxrkgH2TvQaS2KU4Hf9Ts4LBne9naXSGodEl6HQu/q2yIC2VIOe442+ZpO7
Y2e4dldEfGYFMESOvyFiqRKTQdrApmj7G3iLzjNfStM2bd/wuxDHbrBPVVtjt6/9
CBVVSIneQnefKG3xrWTsI/K9dNDhBUo5Plpu3kUgbalHMEX3WeLbrPwg7V9XTOGy
EfhtHju6FwxE6b+UhWyKC55FGTQDJV2x1tT/1zCi1HhQdUregJFE8nCfhfOF1dAB
TWFsm7FW5R5MJJOlobqxdW1tXBmXow==
=51yr
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 7 Mar 2018 22:19
Re: [bug#30734] [PATCH core-updates 3/3] gnu: net-tools: Don't install 'ifconfig'.
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 30734@debbugs.gnu.org)
87zi3jporb.fsf@gnu.org
Marius Bakke <mbakke@fastmail.com> skribis:

Toggle quote (17 lines)
> * gnu/packages/linux.scm (net-tools)[arguments]: In
> REMOVE-REDUNDANT-COMMANDS-PHASE, add regexp for ifconfig.
> ---
> gnu/packages/linux.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index dffe2c49c..8c07d1fdd 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -1290,7 +1290,7 @@ inadequately in modern network environments, and both should be deprecated.")
> ;; Remove commands and man pages redundant with Inetutils.
> (let* ((out (assoc-ref outputs "out"))
> (dup (append-map (cut find-files out <>)
> - '("^hostname"
> + '("^hostname" "^ifconfig"

GNU ifconfig is somewhat incompatible and may have a different feature
set compared to the one of net-tools, so I’d be in favor of keeping it.

WDYT?

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote on 7 Mar 2018 22:19
Re: [bug#30734] [PATCH core-updates 1/3] gnu: util-linux: Don't build 'nologin'.
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 30734@debbugs.gnu.org)
87vae7poqr.fsf@gnu.org
Marius Bakke <mbakke@fastmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/linux.scm (util-linux)[source](snippet): Add substitution.

LGTM!

Ludo'.
M
M
Marius Bakke wrote on 8 Mar 2018 21:45
Re: [bug#30734] [PATCH core-updates 3/3] gnu: net-tools: Don't install 'ifconfig'.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30734@debbugs.gnu.org)
87woym70ue.fsf@fastmail.com
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (24 lines)
> Marius Bakke <mbakke@fastmail.com> skribis:
>
>> * gnu/packages/linux.scm (net-tools)[arguments]: In
>> REMOVE-REDUNDANT-COMMANDS-PHASE, add regexp for ifconfig.
>> ---
>> gnu/packages/linux.scm | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
>> index dffe2c49c..8c07d1fdd 100644
>> --- a/gnu/packages/linux.scm
>> +++ b/gnu/packages/linux.scm
>> @@ -1290,7 +1290,7 @@ inadequately in modern network environments, and both should be deprecated.")
>> ;; Remove commands and man pages redundant with Inetutils.
>> (let* ((out (assoc-ref outputs "out"))
>> (dup (append-map (cut find-files out <>)
>> - '("^hostname"
>> + '("^hostname" "^ifconfig"
>
> GNU ifconfig is somewhat incompatible and may have a different feature
> set compared to the one of net-tools, so I’d be in favor of keeping it.
>
> WDYT?

The motivation for this commit was to remove a conflict in
%base-packages. Currently it's entirely random which ifconfig ends up
in the system profile, which is not great.

What about the below hack? Alternatively, it could be moved to a
separate output. Thoughts?
From 0887b6af81781ae74f0a34c59f32ed098fa199dc Mon Sep 17 00:00:00 2001
From: Marius Bakke <mbakke@fastmail.com>
Date: Thu, 8 Mar 2018 21:41:13 +0100
Subject: [PATCH] gnu: net-tools: Move 'ifconfig' to "/sbin".

* gnu/packages/linux.scm (net-tools)[arguments]: In
REMOVE-REDUNDANT-COMMANDS-PHASE, use rename-file on ifconfig.
---
gnu/packages/linux.scm | 5 +++++
1 file changed, 5 insertions(+)

Toggle diff (18 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 875f11062..916309b79 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1286,6 +1286,11 @@ inadequately in modern network environments, and both should be deprecated.")
'("^hostname"
"^(yp|nis|dns)?domainname"))))
(for-each delete-file dup)
+ ;; ifconfig from net-tools is somewhat incompatible with
+ ;; GNU ifconfig, so we keep it around. Move it to "/sbin"
+ ;; to prevent conflict in %base-packages.
+ (rename-file (string-append out "/bin/ifconfig")
+ (string-append out "/sbin/ifconfig"))
#t))))
;; Binaries that depend on libnet-tools.a don't declare that
;; dependency, making it parallel-unsafe.
--
2.16.2
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlqhoPkACgkQoqBt8qM6
VPo6MQf8CdVl3ium+344HMGTo5CzXbTK5JdDgL3sq2luXAFk8nE7ZVM6ha1nUQKD
NlhgtyLfq9AzrGU5nShmgknHzzD2aYdU5MIt+YrCpzmOg8HLvo1s35DLw44Ec2Qh
ybkX3gPJZY6Zi2ZdL60OjEpxPwAkVgRHdI0cTSw7OmsqqQtZC0N1RbGb3O9/jETB
0PzxIo8uOopCD9FLEJ2cjUwNH/KX88i6xnZL9NqUOD5ZunA7BKvnIN/njAY+okcV
uR8h2GiBPbk8z9YXr1+jdWMH2HGxMDRaZywmN8n9K/FizZbkBz5Rf1IeU9IOafkS
u3tdFf3iKXbhlfpC4itUkt4eNl3TkA==
=1Osj
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 8 Mar 2018 21:53
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 30734@debbugs.gnu.org)
87fu5al261.fsf@gnu.org
Marius Bakke <mbakke@fastmail.com> skribis:

Toggle quote (30 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Marius Bakke <mbakke@fastmail.com> skribis:
>>
>>> * gnu/packages/linux.scm (net-tools)[arguments]: In
>>> REMOVE-REDUNDANT-COMMANDS-PHASE, add regexp for ifconfig.
>>> ---
>>> gnu/packages/linux.scm | 2 +-
>>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>>
>>> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
>>> index dffe2c49c..8c07d1fdd 100644
>>> --- a/gnu/packages/linux.scm
>>> +++ b/gnu/packages/linux.scm
>>> @@ -1290,7 +1290,7 @@ inadequately in modern network environments, and both should be deprecated.")
>>> ;; Remove commands and man pages redundant with Inetutils.
>>> (let* ((out (assoc-ref outputs "out"))
>>> (dup (append-map (cut find-files out <>)
>>> - '("^hostname"
>>> + '("^hostname" "^ifconfig"
>>
>> GNU ifconfig is somewhat incompatible and may have a different feature
>> set compared to the one of net-tools, so I’d be in favor of keeping it.
>>
>> WDYT?
>
> The motivation for this commit was to remove a conflict in
> %base-packages. Currently it's entirely random which ifconfig ends up
> in the system profile, which is not great.

I think it’s not _entirely_ random, but I agree it’s not great. ;-)

Toggle quote (29 lines)
> What about the below hack? Alternatively, it could be moved to a
> separate output. Thoughts?
>
> From 0887b6af81781ae74f0a34c59f32ed098fa199dc Mon Sep 17 00:00:00 2001
> From: Marius Bakke <mbakke@fastmail.com>
> Date: Thu, 8 Mar 2018 21:41:13 +0100
> Subject: [PATCH] gnu: net-tools: Move 'ifconfig' to "/sbin".
>
> * gnu/packages/linux.scm (net-tools)[arguments]: In
> REMOVE-REDUNDANT-COMMANDS-PHASE, use rename-file on ifconfig.
> ---
> gnu/packages/linux.scm | 5 +++++
> 1 file changed, 5 insertions(+)
>
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index 875f11062..916309b79 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -1286,6 +1286,11 @@ inadequately in modern network environments, and both should be deprecated.")
> '("^hostname"
> "^(yp|nis|dns)?domainname"))))
> (for-each delete-file dup)
> + ;; ifconfig from net-tools is somewhat incompatible with
> + ;; GNU ifconfig, so we keep it around. Move it to "/sbin"
> + ;; to prevent conflict in %base-packages.
> + (rename-file (string-append out "/bin/ifconfig")
> + (string-append out "/sbin/ifconfig"))
> #t))))

Sure, either that or rename it to “ifconfig.net-tools” (I think Debian
sometimes does things like this.)

But, isc-dhcp depends on net-tools, and it might have scripts that
depend on its ifconfig, for instance. Same for virtuoso-ose, isc-bind,
iodine, and more.

So all in all, your suggestion may be safer, though we should check
whether these things break.

Thank you,
Ludo’.
M
M
Marius Bakke wrote on 22 Mar 2018 19:40
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 30734@debbugs.gnu.org)
87d0zwkl7l.fsf@fastmail.com
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (41 lines)
> Marius Bakke <mbakke@fastmail.com> skribis:
>
>> What about the below hack? Alternatively, it could be moved to a
>> separate output. Thoughts?
>>
>> From 0887b6af81781ae74f0a34c59f32ed098fa199dc Mon Sep 17 00:00:00 2001
>> From: Marius Bakke <mbakke@fastmail.com>
>> Date: Thu, 8 Mar 2018 21:41:13 +0100
>> Subject: [PATCH] gnu: net-tools: Move 'ifconfig' to "/sbin".
>>
>> * gnu/packages/linux.scm (net-tools)[arguments]: In
>> REMOVE-REDUNDANT-COMMANDS-PHASE, use rename-file on ifconfig.
>> ---
>> gnu/packages/linux.scm | 5 +++++
>> 1 file changed, 5 insertions(+)
>>
>> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
>> index 875f11062..916309b79 100644
>> --- a/gnu/packages/linux.scm
>> +++ b/gnu/packages/linux.scm
>> @@ -1286,6 +1286,11 @@ inadequately in modern network environments, and both should be deprecated.")
>> '("^hostname"
>> "^(yp|nis|dns)?domainname"))))
>> (for-each delete-file dup)
>> + ;; ifconfig from net-tools is somewhat incompatible with
>> + ;; GNU ifconfig, so we keep it around. Move it to "/sbin"
>> + ;; to prevent conflict in %base-packages.
>> + (rename-file (string-append out "/bin/ifconfig")
>> + (string-append out "/sbin/ifconfig"))
>> #t))))
>
> Sure, either that or rename it to “ifconfig.net-tools” (I think Debian
> sometimes does things like this.)
>
> But, isc-dhcp depends on net-tools, and it might have scripts that
> depend on its ifconfig, for instance. Same for virtuoso-ose, isc-bind,
> iodine, and more.
>
> So all in all, your suggestion may be safer, though we should check
> whether these things break.

I like renaming it better than moving to 'sbin'. I'll try out some of
the dependent packages and see what needs to be done. Would it be okay
to switch to GNU Inetutils for those that require 'ifconfig'?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlqz+J4ACgkQoqBt8qM6
VPqArQgArD8UUvwMlUVB3TJWHF9HuJeAjQoZvCd84pnigGlU7OltUGrD0HvN+yNl
YIDZQagnj/pGoA2GaBerWdco0eiHlMu2UqjEAykh0IWQZxhps5K6z2iOWks4d29v
4KgIoIPbdXVRs20THwR9FLF5cViTlXSdv1KVQ6+cface7+wOfd+BaYUbTrdVA97M
Q1/KCxMqijgwuRC06+1Ql2OKcpD+bayyy8a4XJUkp41NXHy+wbsHcAS/j75yHHYi
bz5jPgWkaOIte1nJIOpI37UeX501O7fDEUGfL+2nbsr4l75qY6RLrB2CADC8IL38
BhVcMF0OiTBSxbWnNyfSkxkaai+NAQ==
=Bb2l
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 23 Mar 2018 10:22
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 30734@debbugs.gnu.org)
87bmffkuxv.fsf@gnu.org
Marius Bakke <mbakke@fastmail.com> skribis:

Toggle quote (2 lines)
> Ludovic Courtès <ludo@gnu.org> writes:

[...]

Toggle quote (14 lines)
>> Sure, either that or rename it to “ifconfig.net-tools” (I think Debian
>> sometimes does things like this.)
>>
>> But, isc-dhcp depends on net-tools, and it might have scripts that
>> depend on its ifconfig, for instance. Same for virtuoso-ose, isc-bind,
>> iodine, and more.
>>
>> So all in all, your suggestion may be safer, though we should check
>> whether these things break.
>
> I like renaming it better than moving to 'sbin'. I'll try out some of
> the dependent packages and see what needs to be done. Would it be okay
> to switch to GNU Inetutils for those that require 'ifconfig'?

Sure. I think we’ll have to actually run the those tools (isc-dhcp,
etc.) to check whether their scripts work well with GNU ifconfig, though.

Ludo’.
L
L
Leo Famulari wrote on 29 Aug 2018 23:24
Re: [bug#30734] [PATCH core-updates 0/3] nologin and ifconfig profile conflicts
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 30734@debbugs.gnu.org)
20180829212413.GA21462@jasmine.lan
On Tue, Mar 06, 2018 at 05:54:38PM +0100, Marius Bakke wrote:
Toggle quote (10 lines)
> These patches aim to fix conflicts in the default profile. The second
> patch is unrelated and not necessarily even accurate.
>
> Feedback wanted!
>
> Marius Bakke (3):
> gnu: util-linux: Don't build 'nologin'.
> gnu: util-linux: Move '.la' files to static output.
> gnu: net-tools: Don't install 'ifconfig'.

What's the status of this third patch? Should we apply it to
core-updates (or core-updates-next)?
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAluHDv0ACgkQJkb6MLrK
fwiPFhAAsdqNq4QSFZIWzdVIlJOkvm+Zk7qAkDQIIdCbPe4r7XCHr+BqP2I9xZBQ
aWW/sPI5URY0iye2rtIatRQVAqm6kX8xCqXoVvL8Pr7jeDyZnK9ejYNiONgrUIFx
33lZm5LavxtsRmlbaE4NdQ9gCdBHp60nojteViFkXOH9LdBCPzWJjBIaZEW6nuh3
6lY0HEg7qqXpdCfUQ1/BHAxs8U8O5Qrgrat7iJmV7uyCDyA++l2MZVa776E2EqKc
JE+qkNQIhG7jiDK1cKC+iWHHu8qUpgjU7+kZHeDEJh7y+GDI2p0Zfk/NoxSc5q1F
q5RuqrN5kg2AedBC40nFhUTLBp/hhzFAQUtis1JG/c6RHy+7TkA9lMv1L13SC4ph
kru7j3gFPVR1RENROI934EjXs9Zv3SxoEqzWrT9FJBuvV3bD46dEQJW/WAauJ/C/
ywF2Nk4z/RMWeHbWrDdV4f0RbW46hd0Yunfd1RFfB29/iKi1/ymyOQGxfdQ3JDF7
kvSxg8CrzHiQYbgWAeWSen/XUCuNTlB5pOjbn7QGInAnZfmQ/XX34VhaC5RCKLoW
1Fk34rTIIb5plI98VxiEjG7eHWxwR6GwpcZltIZy1qUbNYlRlLV5WsoawJu85kxx
C7g4H+CGsikQwFrpQ1EW4r8kTMDmX6KQ2aiyQOsfPtGkGou7s90=
=jdnQ
-----END PGP SIGNATURE-----


Z
Z
zimoun wrote on 23 Mar 2022 16:24
Re: bug#30734: [PATCH core-updates 0/3] nologin and ifconfig profile conflicts
86fsn8zo8e.fsf@gmail.com
Hi,

An old patch [1] which probably fell through the cracks.



On Tue, 06 Mar 2018 at 17:54, Marius Bakke <mbakke@fastmail.com> wrote:

Toggle quote (8 lines)
> These patches aim to fix conflicts in the default profile. The second
> patch is unrelated and not necessarily even accurate.
>
> Feedback wanted!
>
> Marius Bakke (3):
> gnu: util-linux: Don't build 'nologin'.

The first patch got 2 LGTM at the time, so it can be applied, IMHO.
Since the last discussion of the two others is from 4 years ago, I
assume it is not a big deal and could be close as wontfix. WDYT?


Cheers,
simon
Z
Z
zimoun wrote on 23 Mar 2022 17:19
(name . Marius Bakke)(address . mbakke@fastmail.com)
86a6dgzln8.fsf_-_@gmail.com
Hi,

On Wed, 23 Mar 2022 at 16:24, zimoun <zimon.toutoune@gmail.com> wrote:

Toggle quote (2 lines)
> The first patch got 2 LGTM at the time, so it can be applied, IMHO.

It is already applied by 0223db58ef36dbc552f91e12d2bb6e444bcfd7f6.


Toggle quote (3 lines)
> Since the last discussion of the two others is from 4 years ago, I
> assume it is not a big deal and could be close as wontfix. WDYT?

Closing the 2 others? Or what is the next action?


Cheers,
simon
M
M
Marius Bakke wrote on 10 Apr 2022 13:26
(name . zimoun)(address . zimon.toutoune@gmail.com)
875ynhi3gv.fsf@gnu.org
zimoun <zimon.toutoune@gmail.com> skriver:

Toggle quote (5 lines)
>> Since the last discussion of the two others is from 4 years ago, I
>> assume it is not a big deal and could be close as wontfix. WDYT?
>
> Closing the 2 others? Or what is the next action?

The ifconfig patch is obsolete since 58236d301 (system: Drop net-tools
from %BASE-PACKAGES (replaced by iproute2).).

Closing, thanks for the reminder.
-----BEGIN PGP SIGNATURE-----

iIUEARYKAC0WIQRNTknu3zbaMQ2ddzTocYulkRQQdwUCYlK+8A8cbWFyaXVzQGdu
dS5vcmcACgkQ6HGLpZEUEHe2ywEAiFsGaXWSOvVf0Nh0t8OMq1ivaaQ084echJVI
HybScJkA/RXYCDX/b2SJyDhLchwQO+pJnPOyHxsV5HF6kEG5t64C
=3r0u
-----END PGP SIGNATURE-----

Closed
?