Intermittent test failures in 'git'

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Maxim Cournoyer
  • Mark H Weaver
Owner
unassigned
Submitted by
Mark H Weaver
Severity
normal
M
M
Mark H Weaver wrote on 3 Dec 2017 12:47
(address . bug-guix@gnu.org)
87lgikyqwx.fsf@netris.org
On Hydra, the following intermittent test failure in 'git' has occurred
twice in the last two days, and twice about a month ago:

Toggle snippet (16 lines)
not ok 3 - git svn branch tests
#
# test_must_fail git svn branch a &&
# git svn branch --parents a &&
# test_must_fail git svn branch -t tag1 &&
# git svn branch --parents -t tag1 &&
# test_must_fail git svn branch --tag tag2 &&
# git svn branch --parents --tag tag2 &&
# test_must_fail git svn tag tag3 &&
# git svn tag --parents tag3
#
# failed 1 among 3 test(s)
1..3
make[2]: *** [Makefile:49: t9167-git-svn-cmd-branch-subproject.sh] Error 1

The problem is not architecture specific. It has occurred at least once
on all three hydra-supported-systems (x86_64, i686, and armhf). The
collateral damage includes several hundred dependency failures.

The following error also happened once on x86_64 about a month ago:

Toggle snippet (32 lines)
not ok 3 - git svn branch tests
#
# git svn branch a &&
# base=$(git rev-parse HEAD:) &&
# test $base = $(git rev-parse remotes/origin/a:) &&
# git svn branch -m "created branch b blah" b &&
# test $base = $(git rev-parse remotes/origin/b:) &&
# test_must_fail git branch -m "no branchname" &&
# git svn branch -n c &&
# test_must_fail git rev-parse remotes/origin/c &&
# test_must_fail git svn branch a &&
# git svn branch -t tag1 &&
# test $base = $(git rev-parse remotes/origin/tags/tag1:) &&
# git svn branch --tag tag2 &&
# test $base = $(git rev-parse remotes/origin/tags/tag2:) &&
# git svn tag tag3 &&
# test $base = $(git rev-parse remotes/origin/tags/tag3:) &&
# git svn tag -m "created tag4 foo" tag4 &&
# test $base = $(git rev-parse remotes/origin/tags/tag4:) &&
# test_must_fail git svn tag -m "no tagname" &&
# git svn tag -n tag5 &&
# test_must_fail git rev-parse remotes/origin/tags/tag5 &&
# test_must_fail git svn tag tag1
#

[...]

# failed 1 among 4 test(s)
1..4
make[2]: *** [Makefile:49: t9128-git-svn-cmd-branch.sh] Error 1

Mark
L
L
Ludovic Courtès wrote on 4 Dec 2017 10:33
(name . Mark H Weaver)(address . mhw@netris.org)(address . 29546@debbugs.gnu.org)
87efoaq1lw.fsf@gnu.org
Hi Mark,

Mark H Weaver <mhw@netris.org> skribis:

Toggle quote (3 lines)
> On Hydra, the following intermittent test failure in 'git' has occurred
> twice in the last two days, and twice about a month ago:

This was discussed in https://bugs.gnu.org/29512, which led to commit
c03ba83c17c91e34e811a909fae0f63aab701ff9 to run tests sequentially.

Currently that seems to work well:


The ARM build is still running though:


Let’s see if the problem shows up again.

Ludo’.
L
L
Ludovic Courtès wrote on 4 Dec 2017 16:37
(name . Mark H Weaver)(address . mhw@netris.org)(address . 29546@debbugs.gnu.org)
87h8t6mrme.fsf@gnu.org
ludo@gnu.org (Ludovic Courtès) skribis:

Toggle quote (19 lines)
> Hi Mark,
>
> Mark H Weaver <mhw@netris.org> skribis:
>
>> On Hydra, the following intermittent test failure in 'git' has occurred
>> twice in the last two days, and twice about a month ago:
>
> This was discussed in <https://bugs.gnu.org/29512>, which led to commit
> c03ba83c17c91e34e811a909fae0f63aab701ff9 to run tests sequentially.
>
> Currently that seems to work well:
>
> https://hydra.gnu.org/job/gnu/master/git-2.15.1.x86_64-linux
> https://hydra.gnu.org/job/gnu/master/git-2.15.1.i686-linux
>
> The ARM build is still running though:
>
> https://hydra.gnu.org/job/gnu/master/git-2.15.1.armhf-linux

Toggle snippet (19 lines)
*** t9167-git-svn-cmd-branch-subproject.sh ***
ok 1 - initialize svnrepo
ok 2 - import into git
not ok 3 - git svn branch tests
#
# test_must_fail git svn branch a &&
# git svn branch --parents a &&
# test_must_fail git svn branch -t tag1 &&
# git svn branch --parents -t tag1 &&
# test_must_fail git svn branch --tag tag2 &&
# git svn branch --parents --tag tag2 &&
# test_must_fail git svn tag tag3 &&
# git svn tag --parents tag3
#
# failed 1 among 3 test(s)
1..3
make[2]: *** [Makefile:49: t9167-git-svn-cmd-branch-subproject.sh] Error 1

I tried building it for i686 on my laptop and it failed similarly.

This bug report seems to be relevant, and it suggests bugs in the Perl
bindings of Subversion:


For now I’ve disabled three of the git-svn tests that were reported to
fail intermittently in commit c7699ebeb4233d81f294ff7e8b8eb3676119ae4a,
so that we can hopefully build Git more reliably.

Ludo’.
M
M
Maxim Cournoyer wrote on 29 Aug 2023 05:21
(name . Ludovic Courtès)(address . ludo@gnu.org)
87o7iqedp5.fsf@gmail.com
Hi,

I'm closing this old report, as our git packages seems to build reliably
now.

--
Thanks,
Maxim
Closed
?