Test failure in guix (commit 872a6fd98868d345443f04efdfd974d148c57f9d)

  • Done
  • quality assurance status badge
Details
4 participants
  • Konrad Hinsen
  • Leo Famulari
  • Ludovic Courtès
  • Robert Smith
Owner
unassigned
Submitted by
Konrad Hinsen
Severity
minor
K
K
Konrad Hinsen wrote on 18 May 2017 08:38
(address . bug-guix@gnu.org)
4321befc-be71-82c5-20a2-69abdfefdc04@fastmail.net
Dear Guix developers,

I just did ¨make check¨ on guix and got one test failure. The log is
attached.

Konrad.
Attachment: test-suite.log
L
L
Ludovic Courtès wrote on 19 May 2017 10:16
(name . Konrad Hinsen)(address . konrad.hinsen@fastmail.net)(address . 26981@debbugs.gnu.org)
87mva9i7mk.fsf@gnu.org
Hi Konrad,

Konrad Hinsen <konrad.hinsen@fastmail.net> skribis:

Toggle quote (12 lines)
> ==================================================
> GNU Guix 0.12.0.3916-872a6: ./test-suite.log
> ==================================================
>
> # TOTAL: 706
> # PASS: 701
> # SKIP: 4
> # XFAIL: 0
> # FAIL: 1
> # XPASS: 0
> # ERROR: 0

[...]

Toggle quote (37 lines)
> test-name: pivot-root
> location: /home/hinsen/Development/guix/tests/syscalls.scm:154
> source:
> + (test-equal
> + "pivot-root"
> + #t
> + (match (pipe)
> + ((in . out)
> + (match (clone (logior CLONE_NEWUSER CLONE_NEWNS SIGCHLD))
> + (0
> + (dynamic-wind
> + (const #t)
> + (lambda ()
> + (close in)
> + (call-with-temporary-directory
> + (lambda (root)
> + (let ((put-old (string-append root "/real-root")))
> + (mount "none" root "tmpfs")
> + (mkdir put-old)
> + (call-with-output-file
> + (string-append root "/test")
> + (lambda (port) (display "testing\n" port)))
> + (pivot-root root put-old)
> + (write (file-exists? "/test") out)
> + (close out)))))
> + (lambda () (primitive-exit 0))))
> + (pid (close out)
> + (let ((result (read in)))
> + (close in)
> + (and (zero? (match (waitpid pid)
> + ((_ . status)
> + (status:exit-val status))))
> + (eq? #t result))))))))
> expected-value: #t
> actual-value: #f
> result: FAIL

What does “uname -r” report on your system?

This test is known to exercise a kernel bug on recent versions:

;; XXX: Skip this test when running Linux > 4.7.5 to work around
(when (or (not perform-container-tests?)
(version>? (utsname:release (uname)) "4.7.5"))
(test-skip 1))

(This functionality is used only by the container facilities of ‘guix
environment’ and ‘guix system’, so you shouldn’t take it as a blocker.)

Thanks for reporting the issue,
Ludo’.
K
K
Konrad Hinsen wrote on 19 May 2017 11:56
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 26981@debbugs.gnu.org)
b8ae0274-a179-97fb-9342-a7c7029b7458@fastmail.net
Hi Ludo,

Toggle quote (1 lines)
> What does “uname -r” report on your system?
4.4.0-78-generic

It's an up-to-date Ubuntu 16.04 installation.

Toggle quote (3 lines)
> (This functionality is used only by the container facilities of ‘guix
> environment’ and ‘guix system’, so you shouldn’t take it as a blocker.)

OK, then I will just go ahead and switch to "guix from git".

Thanks,
Konrad.
L
L
Ludovic Courtès wrote on 19 May 2017 13:55
control message for bug #26981
(address . control@debbugs.gnu.org)
87pof5f4c8.fsf@gnu.org
severity 26981 minor
R
R
Robert Smith wrote on 3 Dec 2020 07:31
Bug report follow up
C7IXTWIPS039.1QF7TTKX0HP0J@amber
Konrad, is this bug report still relevant? I suspect not, since it
seems to have been solved by switching to a more recent version
of guix 3 years ago.
If I don't hear back I'll assume it's safe to close this.

-Robert
K
K
Konrad Hinsen wrote on 3 Dec 2020 09:11
m1sg8n5my2.fsf@ordinateur-de-catherine--konrad.home
Hi Robert,

Toggle quote (6 lines)
> Konrad, is this bug report still relevant? I suspect not, since it
> seems to have been solved by switching to a more recent version
> of guix 3 years ago.
> The bug: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=26981
> If I don't hear back I'll assume it's safe to close this.

Yes, it is. Thanks for doing a cleanup!

Konrad.
R
R
Robert Smith wrote on 3 Dec 2020 19:23
C7JCZK8KIP6E.2HPS71CSBKJN3@amber
On Thu Dec 3, 2020 at 9:11 AM Konrad Hinsen wrote:
Toggle quote (8 lines)
> > Konrad, is this bug report still relevant? I suspect not, since it
> > seems to have been solved by switching to a more recent version
> > of guix 3 years ago.
> > The bug: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=26981
> > If I don't hear back I'll assume it's safe to close this.
>
> Yes, it is. Thanks for doing a cleanup!

This bug report is still relevant? Or are you saying that it is fixed?
Sorry if my email was a bit ambiguous!

-Robert
K
K
Konrad Hinsen wrote on 4 Dec 2020 09:05
m1k0ty5736.fsf@ordinateur-de-catherine--konrad.home
Hi Robert,

Toggle quote (8 lines)
>> > If I don't hear back I'll assume it's safe to close this.
>>
>> Yes, it is. Thanks for doing a cleanup!
>
> This bug report is still relevant? Or are you saying that it is fixed?
> Sorry if my email was a bit ambiguous!

Right. My full answer is "Yes, it is safe to close this."

Konra.d
L
L
Leo Famulari wrote on 4 Dec 2020 20:14
Re: bug#26981: Bug report follow up
(name . Konrad Hinsen)(address . konrad.hinsen@fastmail.net)
X8qKqexxc24fSl8y@jasmine.lan
On Fri, Dec 04, 2020 at 09:05:49AM +0100, Konrad Hinsen wrote:
Toggle quote (12 lines)
> Hi Robert,
>
> >> > The bug: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=26981
> >> > If I don't hear back I'll assume it's safe to close this.
> >>
> >> Yes, it is. Thanks for doing a cleanup!
> >
> > This bug report is still relevant? Or are you saying that it is fixed?
> > Sorry if my email was a bit ambiguous!
>
> Right. My full answer is "Yes, it is safe to close this."

Closing...
Closed
?