[PATCH] gnu: ecl: Update to 16.1.3.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andy Patterson
  • Leo Famulari
  • Ludovic Courtès
Owner
unassigned
Submitted by
Andy Patterson
Severity
normal
A
A
Andy Patterson wrote on 12 Mar 2017 01:10
(address . guix-patches@gnu.org)
20170311191056.1323a50a@uwaterloo.ca
From 5d01430eb74a0187624d2306d08d32810f3d8c92 Mon Sep 17 00:00:00 2001
From: Andy Patterson <ajpatter@uwaterloo.ca>
Date: Sat, 11 Mar 2017 17:19:20 -0500
Subject: [PATCH] gnu: ecl: Update to 16.1.3.

* gnu/packages/lisp.scm (ecl): Update to 16.1.3.
[arguments]: Use a different method to set the binary used for tests.
---
gnu/packages/lisp.scm | 14 ++++++++------
1 file changed, 8 insertions(+), 6 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 647c64dcc..425c273e0 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -129,7 +129,7 @@ interface to the Tk widget system.")
(define-public ecl
(package
(name "ecl")
- (version "16.1.2")
+ (version "16.1.3")
(source
(origin
(method url-fetch)
@@ -137,7 +137,7 @@ interface to the Tk widget system.")
"https://common-lisp.net/project/ecl/static/files/release/"
name "-" version ".tgz"))
(sha256
- (base32 "16ab8qs3awvdxy8xs8jy82v8r04x4wr70l9l2j45vgag18d2nj1d"))
+ (base32 "0m0j24w5d5a9dwwqyrg0d35c0nys16ijb4r0nyk87yp82v38b9bn"))
(modules '((guix build utils)))
(snippet
;; Add ecl-bundle-systems to 'default-system-source-registry'.
@@ -152,9 +152,6 @@ interface to the Tk widget system.")
("libffi" ,libffi)))
(arguments
'(#:tests? #t
- #:make-flags `(,(string-append "ECL="
- (assoc-ref %outputs "out")
- "/bin/ecl"))
#:parallel-tests? #f
#:phases
(modify-phases %standard-phases
@@ -182,7 +179,12 @@ interface to the Tk widget system.")
`("kernel-headers" ,@libraries)))
`("LIBRARY_PATH" suffix ,library-directories)
`("LD_LIBRARY_PATH" suffix ,library-directories)))))
- (add-after 'wrap 'check (assoc-ref %standard-phases 'check)))))
+ (add-after 'wrap 'check (assoc-ref %standard-phases 'check))
+ (add-before 'check 'fix-path-to-ecl
+ (lambda _
+ (substitute* "build/tests/Makefile"
+ (("\\$\\{exec_prefix\\}/") ""))
+ #t)))))
(native-search-paths
(list (search-path-specification
(variable "XDG_DATA_DIRS")
--
2.11.1
L
L
Leo Famulari wrote on 13 Mar 2017 04:49
(name . Andy Patterson)(address . ajpatter@uwaterloo.ca)(address . 26065@debbugs.gnu.org)
20170313034907.GA20765@jasmine
On Sat, Mar 11, 2017 at 07:10:56PM -0500, Andy Patterson wrote:
Toggle quote (8 lines)
> From 5d01430eb74a0187624d2306d08d32810f3d8c92 Mon Sep 17 00:00:00 2001
> From: Andy Patterson <ajpatter@uwaterloo.ca>
> Date: Sat, 11 Mar 2017 17:19:20 -0500
> Subject: [PATCH] gnu: ecl: Update to 16.1.3.
>
> * gnu/packages/lisp.scm (ecl): Update to 16.1.3.
> [arguments]: Use a different method to set the binary used for tests.

Thanks! Pushed as 108f69c448e91c9c3da314260ec22c931df2e55d
L
L
Ludovic Courtès wrote on 13 Mar 2017 14:07
control message for bug #26065
(address . control@debbugs.gnu.org)
8737ehfhpa.fsf@gnu.org
tags 26065 fixed
close 26065
?