Updating alot (and other collateral updates)

  • Done
  • quality assurance status badge
Details
4 participants
  • Ludovic Courtès
  • Marius Bakke
  • Ricardo Wurmus
  • Troy Sankey
Owner
unassigned
Submitted by
Troy Sankey
Severity
normal
T
T
Troy Sankey wrote on 20 Feb 2017 07:37
(address . guix-patches@gnu.org)
20170220063742.24691-1-sankeytms@gmail.com
My ultimate goal with this patch set was to update alot and all of its
(python) dependency closure.

[PATCH 1/8] gnu: Add python-attrs.
[PATCH 2/8] gnu: Add python-constantly.
[PATCH 3/8] gnu: Add python-m2r.
[PATCH 4/8] gnu: python-setuptools-scm: Update to 1.15.0.
[PATCH 5/8] gnu: Add python-automat.
[PATCH 6/8] gnu: Add python-incremental.
[PATCH 7/8] gnu: python-twisted: Update to 17.1.0.
[PATCH 8/8] gnu: alot: Update to 0.5.1.

Troy
T
T
Troy Sankey wrote on 20 Feb 2017 07:37
[PATCH 6/8] gnu: Add python-incremental.
(address . guix-patches@gnu.org)(name . Troy Sankey)(address . sankeytms@gmail.com)
20170220063742.24691-7-sankeytms@gmail.com
* gnu/packages/python.scm (python-incremental, python2-incremental): New
variables.
---
gnu/packages/python.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e91beff18..575ac67a8 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12709,6 +12709,27 @@ Python. It is based on Parsing Expression Grammars, PEG. With pyPEG you can
parse many formal languages.")
(license license:gpl2)))
+(define-public python-incremental
+ (package
+ (name "python-incremental")
+ (version "16.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "incremental" version))
+ (sha256
+ (base32
+ "0hh382gsj5lfl3fsabblk2djngl4n5yy90xakinasyn41rr6pb8l"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/hawkowl/incremental")
+ (synopsis "Library for versioning Python projects")
+ (description "Incremental is a small library that versions your Python
+projects.")
+ (license license:expat)))
+
+(define-public python2-incremental
+ (package-with-python2 python-incremental))
+
(define-public python-automat
(package
(name "python-automat")
--
2.11.1
T
T
Troy Sankey wrote on 20 Feb 2017 07:37
[PATCH 1/8] gnu: Add python-attrs.
(address . guix-patches@gnu.org)(name . Troy Sankey)(address . sankeytms@gmail.com)
20170220063742.24691-2-sankeytms@gmail.com
* gnu/packages/python.scm (python-attrs, python2-attrs): New variables.
---
gnu/packages/python.scm | 24 +++++++++++++++++++++++-
1 file changed, 23 insertions(+), 1 deletion(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3e59b5892..e3904624c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 Daniel Pimentel <d4n1@d4n1.org>
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
-;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
+;;; Copyright © 2016, 2017 Troy Sankey <sankeytms@gmail.com>
;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
@@ -12708,3 +12708,25 @@ specified to apply on the key before comparison (e.g. @code{string.lower})).")
Python. It is based on Parsing Expression Grammars, PEG. With pyPEG you can
parse many formal languages.")
(license license:gpl2)))
+
+(define-public python-attrs
+ (package
+ (name "python-attrs")
+ (version "16.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "attrs" version))
+ (sha256
+ (base32
+ "1k1w8xg7mbd9r8624irnwnzlf3g8lqymba2sw6xz6diyf9vk2840"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/python-attrs/attrs/")
+ (synopsis "Attributes Without Boilerplate")
+ (description "@code{attrs} is an MIT-licensed Python package with class
+decorators that ease the chores of implementing the most common
+attribute-related object protocols.")
+ (license license:expat)))
+
+(define-public python2-attrs
+ (package-with-python2 python-attrs))
--
2.11.1
T
T
Troy Sankey wrote on 20 Feb 2017 07:37
[PATCH 7/8] gnu: python-twisted: Update to 17.1.0.
(address . guix-patches@gnu.org)(name . Troy Sankey)(address . sankeytms@gmail.com)
20170220063742.24691-8-sankeytms@gmail.com
* gnu/packages/python.scm (python-twisted): Update to 17.1.0.
[propagated-inputs]: Add python-incremental, python-constantly,
python-automat.
---
gnu/packages/python.scm | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 575ac67a8..af67ccff5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10376,16 +10376,19 @@ to provide a high-level synchronous API on top of the libev event loop.")
(define-public python-twisted
(package
(name "python-twisted")
- (version "16.2.0")
+ (version "17.1.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "Twisted" version ".tar.bz2"))
(sha256
(base32
- "0ydxrp9myw1mvsz3qfzx5579y5llmqa82pxvqchgp5syczffi450"))))
+ "1p245mg15hkxp7hy5cyq2fgvlgjkb4cg0gwkwd148nzy1bbi3wnv"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-zope-interface" ,python-zope-interface)))
+ `(("python-zope-interface" ,python-zope-interface)
+ ("python-incremental" ,python-incremental)
+ ("python-constantly" ,python-constantly)
+ ("python-automat" ,python-automat)))
(home-page "https://twistedmatrix.com/")
(synopsis "Asynchronous networking framework written in Python")
(description
--
2.11.1
T
T
Troy Sankey wrote on 20 Feb 2017 07:37
[PATCH 8/8] gnu: alot: Update to 0.5.1.
(address . guix-patches@gnu.org)(name . Troy Sankey)(address . sankeytms@gmail.com)
20170220063742.24691-9-sankeytms@gmail.com
* gnu/packages/mail.scm (alot): Update to 0.5.1.
[arguments]: Enable tests.
[native-inputs]: Add python2-mock.
---
gnu/packages/mail.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index a9b2cb3ec..4e6d3ce90 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
-;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
+;;; Copyright © 2016, 2017 Troy Sankey <sankeytms@gmail.com>
;;; Copyright © 2016, 2017 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
@@ -575,7 +575,7 @@ attachments, create new maildirs, and so on.")
(define-public alot
(package
(name "alot")
- (version "0.4")
+ (version "0.5.1")
(source (origin
(method url-fetch)
;; package author intends on distributing via github rather
@@ -586,13 +586,14 @@ attachments, create new maildirs, and so on.")
(file-name (string-append "alot-" version ".tar.gz"))
(sha256
(base32
- "0sl1kl2fhkv208llnbny4blcvrfdk4vx6bcw5pnyh9ylwb0pipi2"))))
+ "0wax30hjzmkqfml7hig1dqw1v1y63yc0cgbzl96x58b9h2ggqx3a"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ; no tests
- ;; python 3 is currently unsupported, more info:
+ `(;; python 3 is currently unsupported, more info:
;; https://github.com/pazz/alot/blob/master/docs/source/faq.rst
#:python ,python-2))
+ (native-inputs
+ `(("python2-mock" ,python2-mock)))
(inputs
`(("python2-magic" ,python2-magic)
("python2-configobj" ,python2-configobj)
--
2.11.1
T
T
Troy Sankey wrote on 20 Feb 2017 07:50
Updating alot (and other collateral updates)
(address . 25808@debbugs.gnu.org)
148757341791.16320.837888464992826438@what
Debbugs split off half of my patches in this series and created
individual bugs for them. Sorry, I don't understand why. I used
git send-email like I normally would on guix-devel@gnu.org.

Troy
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE0zLJ6STd4Cp+CgbIgs677ofYV8IFAliqkaYACgkQgs677ofY
V8JXFg//fshFpR8SC/MoYrRyf6x7SiBrWJTzbeUlb241lDvn/6AKBxTGeLzQmy+t
NWXpIBsqy5h2jJ6710EFgYLVsc3dkXRp67lBbfDYHGzmd+t4eSY4ckFq0OBPRPPf
R8uTA2qYtTbYp5r/DICQtXl/3DR8hxoFp6W0bD7W0i85vp27lrx4ikD1cCkVNchI
cdUDPzRFH8fg5iI1MRO82Nw35VcdnMlwj3DDQ/w7mFsbc0GF7JqoyGBodlfzUTCe
ojwmOgnNZGCZqUqhjR7r6rry+sOWOZfTz0iWUJoAw+4AKaVpkRLcIqFXhkEdfomH
OnxebhGUNsyA96iY9qPl0AfAWJ9eEfZbHKArjEErwA8s+YkiNl3d2iHZ0rjdI8W7
9CaYTdXC9074UA1D1vYS+kKdiLQeZhT+POdAFsSM0JQr4hTLQi0KD0O59SCaeIp/
lTLC0bg+zz8flLHclckYGKro/hl1crpbWPS2rgETC4QfTBYwT8yKm6kApwl7eVmr
EC2MRds4Aaw/SxiJ2gKDuVTgFq+XImT9WvUYSQI6gFOe5uhHrLdlF5jvoSs5mfk7
5DOJoPFkAiHigZCjowuyOlqFBgcd5DsZ1jM/J2SfUDEUI7fSV7Wl1O8VcljSpTTO
izSgrYmy+JxRuFQ746j7Wx3moavXR+hD/e/c1wPPYv4RzQCubDI=
=0x+O
-----END PGP SIGNATURE-----


T
T
Troy Sankey wrote on 21 Feb 2017 20:16
(no subject)
(address . 25808@debbugs.gnu.org)
148770456564.2401.2701845166680724233@what
I closed the other four bugs containing lone patches. I will re-send
those to this bug now.

Troy
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE0zLJ6STd4Cp+CgbIgs677ofYV8IFAliske8ACgkQgs677ofY
V8LZzA//fBk9lahhrYDLdu6BjCN7pfONvl+aqXJzc0MUo6EbnEeUqlq727ns8AER
wiWVepD41H5Sn994nYUXNb8RFf9WK6KphjP67fEqMXE+Z6QdwxIK7FmqpVCD2eBI
D+flOCr05DeUX13rgHMVd6D1LCY717n3R43FTmgaO0OJ1lLxAi7CLgZcvEyVo3VP
FYOXcFT/EE3ZcvOHmRK2UNFZoT6GFH79lyEY8mWEzPM0UftYqRMhcaC8N470aYr+
CFW/qkt+PBCRfgzG3bFZ47BatdaT/KpoBLVEKarvKrOnJ4vmTyc7jP4GqX4lV55M
nDrCyK+dZGBALHKfoyoeqCG1VFFiNAd+sYAweGiw7BwHsUC0DOj7LfwWC8jWwtWf
DznyreKqDXe7mqyNhCJouaPuV4UfpBDWSgoZjSxj+kVIpYRF48eTA5345x5GxhdU
yn8PgZ4N0kfAqYKmxdR92l2GIpZXvTfIYmCbAMsPNpPo4dWJJRI6zBBFeWvvqVHw
vrXbrnrLmh9nSel4oPHknS0lnQkoklY/Xuqadn3kQBTm+yBt0mGYNNmStrV2/FkO
bVHsjB1yw7Au+TH/oJ1gjMly14I0+rk0ykx1smePm0AwUYHpnnZMEfwtE3iDVjly
37ZFa4DBOef77pvQMLthnLNtbMPSGQSQ3NMHTnyzDUvhubrTC08=
=x6ul
-----END PGP SIGNATURE-----


T
T
Troy Sankey wrote on 21 Feb 2017 20:17
[PATCH 2/8] gnu: Add python-constantly.
(address . 25808@debbugs.gnu.org)(name . Troy Sankey)(address . sankeytms@gmail.com)
20170221191741.19944-1-sankeytms@gmail.com
* gnu/packages/python.scm (python-constantly, python2-constantly): New
variables.
---
gnu/packages/python.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e3904624c..9d2b977a7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12709,6 +12709,29 @@ Python. It is based on Parsing Expression Grammars, PEG. With pyPEG you can
parse many formal languages.")
(license license:gpl2)))
+(define-public python-constantly
+ (package
+ (name "python-constantly")
+ (version "15.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "constantly" version))
+ (sha256
+ (base32
+ "0dgwdla5kfpqz83hfril716inm41hgn9skxskvi77605jbmp4qsq"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/twisted/constantly")
+ (synopsis "Symbolic constants in Python")
+ (description "A library that provides symbolic constant support. It
+includes collections and constants with text, numeric, and bit flag values.
+Originally @code{twisted.python.constants} from the Twisted project.")
+ (license license:expat)))
+
+(define-public python2-constantly
+ (package-with-python2 python-constantly))
+
(define-public python-attrs
(package
(name "python-attrs")
--
2.11.1
T
T
Troy Sankey wrote on 21 Feb 2017 20:18
[PATCH 3/8] gnu: Add python-m2r.
(address . 25808@debbugs.gnu.org)(name . Troy Sankey)(address . sankeytms@gmail.com)
20170221191829.20004-1-sankeytms@gmail.com
* gnu/packages/python.scm (python-m2r, python2-m2r): New variables.
---
gnu/packages/python.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9d2b977a7..4e87e3867 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12709,6 +12709,30 @@ Python. It is based on Parsing Expression Grammars, PEG. With pyPEG you can
parse many formal languages.")
(license license:gpl2)))
+(define-public python-m2r
+ (package
+ (name "python-m2r")
+ (version "0.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "m2r" version))
+ (sha256
+ (base32
+ "08rjn3x1qag60wawjnq95wmgijrn33apr4fhj01s2p6hmrqgfj1l"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-docutils" ,python-docutils)
+ ("python-mistune" ,python-mistune)))
+ (home-page "https://github.com/miyakogi/m2r")
+ (synopsis "Markdown to reStructuredText converter")
+ (description "M2R converts a markdown file including reST markups to a
+valid reST format.")
+ (license license:expat)))
+
+(define-public python2-m2r
+ (package-with-python2 python-m2r))
+
(define-public python-constantly
(package
(name "python-constantly")
--
2.11.1
T
T
Troy Sankey wrote on 21 Feb 2017 20:19
[PATCH 4/8] gnu: python-setuptools-scm: Update to 1.15.0.
(address . 25808@debbugs.gnu.org)(name . Troy Sankey)(address . sankeytms@gmail.com)
20170221191923.20072-1-sankeytms@gmail.com
* gnu/packages/python.scm (python-setuptools-scm): Update to 1.15.0.
---
gnu/packages/python.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4e87e3867..5e2da0b27 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4588,13 +4588,13 @@ child application and control it as if a human were typing commands.")
(define-public python-setuptools-scm
(package
(name "python-setuptools-scm")
- (version "1.11.1")
+ (version "1.15.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "setuptools_scm" version))
(sha256
(base32
- "1gqr73i150yzj3mz32854vj93x07yr52kn8fdckwa41ll8wgficc"))))
+ "0bwyc5markib0i7i2qlyhdzxhiywzxbkfiapldma8m91m82jvwfs"))))
(build-system python-build-system)
(home-page "https://github.com/pypa/setuptools_scm/")
(synopsis "Manage Python package versions in SCM metadata")
--
2.11.1
T
T
Troy Sankey wrote on 21 Feb 2017 20:19
[PATCH 5/8] gnu: Add python-automat.
(address . 25808@debbugs.gnu.org)(name . Troy Sankey)(address . sankeytms@gmail.com)
20170221191952.20125-1-sankeytms@gmail.com
* gnu/packages/python.scm (python-automat, python2-automat): New
variables.
---
gnu/packages/python.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5e2da0b27..e91beff18 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12709,6 +12709,35 @@ Python. It is based on Parsing Expression Grammars, PEG. With pyPEG you can
parse many formal languages.")
(license license:gpl2)))
+(define-public python-automat
+ (package
+ (name "python-automat")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Automat" version))
+ (sha256
+ (base32
+ "1hnpknkqnc2m900kkzrzx9l6g5dy5dassrdj9pn34x1pcdkyr2a8"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-m2r" ,python-m2r)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-attrs" ,python-attrs)))
+ (home-page "https://github.com/glyph/Automat")
+ (synopsis
+ "Self-service finite-state machines for the programmer on the go")
+ (description "Automat is a library for concise, idiomatic Python expression
+of finite-state automata (particularly deterministic finite-state
+transducers).")
+ (license license:expat)))
+
+(define-public python2-automat
+ (package-with-python2 python-automat))
+
(define-public python-m2r
(package
(name "python-m2r")
--
2.11.1
M
M
Marius Bakke wrote on 23 Feb 2017 14:39
Re: bug#25808: Updating alot (and other collateral updates)
87mvddgh6h.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Troy Sankey <sankeytms@gmail.com> writes:

Toggle quote (12 lines)
> My ultimate goal with this patch set was to update alot and all of its
> (python) dependency closure.
>
> [PATCH 1/8] gnu: Add python-attrs.
> [PATCH 2/8] gnu: Add python-constantly.
> [PATCH 3/8] gnu: Add python-m2r.
> [PATCH 4/8] gnu: python-setuptools-scm: Update to 1.15.0.
> [PATCH 5/8] gnu: Add python-automat.
> [PATCH 6/8] gnu: Add python-incremental.
> [PATCH 7/8] gnu: python-twisted: Update to 17.1.0.
> [PATCH 8/8] gnu: alot: Update to 0.5.1.

Hi Troy,

Thanks a lot for these! The series looks good, but since setuptools-scm
causes a rebuild of 89 packages, I would like to delay this until bug
#25177 is solved (so that we actually notice any build failures).

I'll go through these more thoroughly next week, I hope to get the
'python-tests' branch merged this weekend or so.

Thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAliu5gYACgkQoqBt8qM6
VPpbcQf/eVQKzoMv1NoVy1r+FfYapkVdM6PrSSS9mFEf0AENFt9SytHDgm4lc3sm
iW+hEdMGd9GJYR3aebQQYLt6floVsbqsBSBExApigUmpvx/ukku6Ht8K4VFRCLoC
gsheJJ77lZSJ831uIRQZUNyQBbPfbjNdE0LPoQFQkwPIgu2Dz2hKQIJx9+KlwXcj
Yvo/X8xFp+FT1gx5T0WU1LsqECLl03+tpRvVTMImXkXBMIuRId6m1BEvj3ABw8j/
7C6JrHVNyc88wF+nN7mhnQ6osU156jpffQO56T2+X9lBYj5s260YqdNRXyoByFwJ
e7BnduoXXdx3uqosE8bkqkeca6c+sA==
=9mtu
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 6 Mar 2017 13:54
87innm5zwz.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Troy Sankey <sankeytms@gmail.com> writes:

Toggle quote (13 lines)
> My ultimate goal with this patch set was to update alot and all of its
> (python) dependency closure.
>
> [PATCH 1/8] gnu: Add python-attrs.
> [PATCH 2/8] gnu: Add python-constantly.
> [PATCH 3/8] gnu: Add python-m2r.
> [PATCH 4/8] gnu: python-setuptools-scm: Update to 1.15.0.
> [PATCH 5/8] gnu: Add python-automat.
> [PATCH 6/8] gnu: Add python-incremental.
> [PATCH 7/8] gnu: python-twisted: Update to 17.1.0.
> [PATCH 8/8] gnu: alot: Update to 0.5.1.


Hi Troy,

Apologies for the looong delay! :)

Some of these packages are failing the 'check' phase, which went
unnoticed before the mentioned bug 25177 was fixed. Can you look into
it?

I will comment on each patch separately. Thanks again!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAli9W+0ACgkQoqBt8qM6
VPokFggAxPDVRFj3mFa3a0Cr0Fx1/4xRsIxWqTLaJjpkvkb5H+8aZiky6nczgA8l
giRBh5HUKXfUwzu5dtdr5oUEWFU2L8snjX0KM+P+MZf6e1cC1CX5zIzhiZe7DrHZ
/IEWA0Sv2h2wg9ENw4gYZnGqACtHF+xJJ0EfC6S6MbK6jI9doSm/WEniJkYjEG6W
xHR8WFX4BTl3Ll43QoKf9X23pZP+CelEUgAiLEuRWVcQ+s2ehczks3IpZhmrTb37
zbjgXdg6Y14wVznO+/KJRqleuYx5rN2pR/Yp3p6Il/fe002hEHPQL1nC4G4TeDQP
6PLLOZE67E5Xdp8cPZRCc3q1OE1/iw==
=Y3Zt
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 6 Mar 2017 14:00
Re: bug#25808: [PATCH 1/8] gnu: Add python-attrs.
87fuiq5zn2.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Troy Sankey <sankeytms@gmail.com> writes:

Toggle quote (35 lines)
> * gnu/packages/python.scm (python-attrs, python2-attrs): New variables.
> ---
> gnu/packages/python.scm | 24 +++++++++++++++++++++++-
> 1 file changed, 23 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> index 3e59b5892..e3904624c 100644
> --- a/gnu/packages/python.scm
> +++ b/gnu/packages/python.scm
> @@ -22,7 +22,7 @@
> ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
> ;;; Copyright © 2016 Daniel Pimentel <d4n1@d4n1.org>
> ;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
> -;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
> +;;; Copyright © 2016, 2017 Troy Sankey <sankeytms@gmail.com>
> ;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
> ;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
> ;;; Copyright © 2016 David Craven <david@craven.ch>
> @@ -12708,3 +12708,25 @@ specified to apply on the key before comparison (e.g. @code{string.lower})).")
> Python. It is based on Parsing Expression Grammars, PEG. With pyPEG you can
> parse many formal languages.")
> (license license:gpl2)))
> +
> +(define-public python-attrs
> + (package
> + (name "python-attrs")
> + (version "16.3.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "attrs" version))
> + (sha256
> + (base32
> + "1k1w8xg7mbd9r8624irnwnzlf3g8lqymba2sw6xz6diyf9vk2840"))))

Indentation is off in this section.

Toggle quote (3 lines)
> + (build-system python-build-system)
> + (home-page "https://github.com/python-attrs/attrs/")
> + (synopsis "Attributes Without Boilerplate")
^ ^
Lowercase here.

Toggle quote (2 lines)
> + (description "@code{attrs} is an MIT-licensed Python package with class

s/MIT-licensed//

Toggle quote (8 lines)
> +decorators that ease the chores of implementing the most common
> +attribute-related object protocols.")
> + (license license:expat)))
> +
> +(define-public python2-attrs
> + (package-with-python2 python-attrs))
> --
> 2.11.1
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAli9XVEACgkQoqBt8qM6
VPqNXwf/RYvkz+qBhVrjB31gkJUNU69qAVNST0ZEFTRkWa3XT11Wi1fAq1wxU2x/
ThO61qhG/6K5CyPseaQJGdj0DNb31kPFYmWJKVUeazPLHlUJijTqBXao5NnUR0VG
7air4lt5K1GebxPo/nJBscRH28+BM1VUf0FQaEKxxpCJj+BipeCISGRo9/cte5/R
bITRbcNGF0uRCi20RvfadBwzj/3xITfvDaRt9MyURUxQnOrQEdQZyShh2CVUuMq4
zFHQXyGgh8AaTIMQ8bfj6ks1lMc58z7SeUj5sm1F1hi2EfUSgE9giubGe2TBJuyF
2t+/wpSL+nILw3sdsccdNQIBXpzRLw==
=fPZa
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 6 Mar 2017 14:05
Re: bug#25808: [PATCH 6/8] gnu: Add python-incremental.
871sua5zdd.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Troy Sankey <sankeytms@gmail.com> writes:

Toggle quote (3 lines)
> * gnu/packages/python.scm (python-incremental, python2-incremental): New
> variables.

LGTM. It seems all of these packages needs indentation fix, so I won't
nag about it further!

Toggle quote (38 lines)
> ---
> gnu/packages/python.scm | 21 +++++++++++++++++++++
> 1 file changed, 21 insertions(+)
>
> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> index e91beff18..575ac67a8 100644
> --- a/gnu/packages/python.scm
> +++ b/gnu/packages/python.scm
> @@ -12709,6 +12709,27 @@ Python. It is based on Parsing Expression Grammars, PEG. With pyPEG you can
> parse many formal languages.")
> (license license:gpl2)))
>
> +(define-public python-incremental
> + (package
> + (name "python-incremental")
> + (version "16.10.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "incremental" version))
> + (sha256
> + (base32
> + "0hh382gsj5lfl3fsabblk2djngl4n5yy90xakinasyn41rr6pb8l"))))
> + (build-system python-build-system)
> + (home-page "https://github.com/hawkowl/incremental")
> + (synopsis "Library for versioning Python projects")
> + (description "Incremental is a small library that versions your Python
> +projects.")
> + (license license:expat)))
> +
> +(define-public python2-incremental
> + (package-with-python2 python-incremental))
> +
> (define-public python-automat
> (package
> (name "python-automat")
> --
> 2.11.1
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAli9Xq8ACgkQoqBt8qM6
VPo9nwgAqTYuLjdvRS525sOEuXtQwailBDIPvwUa5rIv6iU4LfivXcJO3u0XjcRQ
OFAAS6Hlpxy2jrwibQjrmygpa0Uy1lX2dXAjoxcmI4Suhs9JujWRR3Fry+hV/982
WMnP5rAMpVaz42Cxs7MlMqGjdngq+DgcQdLv7IEpcAlEHVK6J5I/qlO9b5BXccRY
PVZPty9bIQMiyVQfbB2WXWK5xi50Vq8MwN1PiQ2Qo1PfQtNHXjDr3VUpsjQcNQYo
QWmbQruIlQgZBXdIdkHPGoVm+cuAPQDRVn3eaymYS0TgIX8OMwf1cUq4e/20NTvB
zTsZLqbtKciwxWIdaRmO8+hakvYtCA==
=x1xF
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 6 Mar 2017 14:07
Re: bug#25808: [PATCH 7/8] gnu: python-twisted: Update to 17.1.0.
87y3wi4kqw.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Troy Sankey <sankeytms@gmail.com> writes:

Toggle quote (4 lines)
> * gnu/packages/python.scm (python-twisted): Update to 17.1.0.
> [propagated-inputs]: Add python-incremental, python-constantly,
> python-automat.

LGTM!

Toggle quote (33 lines)
> ---
> gnu/packages/python.scm | 9 ++++++---
> 1 file changed, 6 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> index 575ac67a8..af67ccff5 100644
> --- a/gnu/packages/python.scm
> +++ b/gnu/packages/python.scm
> @@ -10376,16 +10376,19 @@ to provide a high-level synchronous API on top of the libev event loop.")
> (define-public python-twisted
> (package
> (name "python-twisted")
> - (version "16.2.0")
> + (version "17.1.0")
> (source (origin
> (method url-fetch)
> (uri (pypi-uri "Twisted" version ".tar.bz2"))
> (sha256
> (base32
> - "0ydxrp9myw1mvsz3qfzx5579y5llmqa82pxvqchgp5syczffi450"))))
> + "1p245mg15hkxp7hy5cyq2fgvlgjkb4cg0gwkwd148nzy1bbi3wnv"))))
> (build-system python-build-system)
> (propagated-inputs
> - `(("python-zope-interface" ,python-zope-interface)))
> + `(("python-zope-interface" ,python-zope-interface)
> + ("python-incremental" ,python-incremental)
> + ("python-constantly" ,python-constantly)
> + ("python-automat" ,python-automat)))
> (home-page "https://twistedmatrix.com/")
> (synopsis "Asynchronous networking framework written in Python")
> (description
> --
> 2.11.1
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAli9XvcACgkQoqBt8qM6
VPqP0gf/bEl/AKeA7CDKTyHc8zMh3iiVBwxIYaWRXs/yUEVxaab+lAq9umTwGeBH
ggeb+YKSm22IbU5SrGuvRHNU9BAPIOLw7boLGRQ9u3pNU/T5sGjtxNZbdVEgdqg5
7VG1vumUXJ7Mi+QaE6tMMZx/xn7T8VHzcam4tFurh2nMpMc0JRcHCWGq7jpFUmaQ
YNFDQrydyRMFDiuxzisQZ5mZNXMXTRxO8YDAm8KwS2iZsRCAGYBJ0wyVMO14ArUu
raayRLWIme6TRXFpYZdHdSkcFC+6i+PirNzJYybiHQODBD5+ko5ts0u5QxnvVmX1
54wYs2NzcHtV6sXb4xpTCqVm/oJQXw==
=0JSj
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 6 Mar 2017 14:07
Re: bug#25808: [PATCH 8/8] gnu: alot: Update to 0.5.1.
87varm4kq4.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Troy Sankey <sankeytms@gmail.com> writes:

Toggle quote (4 lines)
> * gnu/packages/mail.scm (alot): Update to 0.5.1.
> [arguments]: Enable tests.
> [native-inputs]: Add python2-mock.

Yay, LGTM!

Toggle quote (46 lines)
> ---
> gnu/packages/mail.scm | 11 ++++++-----
> 1 file changed, 6 insertions(+), 5 deletions(-)
>
> diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
> index a9b2cb3ec..4e6d3ce90 100644
> --- a/gnu/packages/mail.scm
> +++ b/gnu/packages/mail.scm
> @@ -14,7 +14,7 @@
> ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
> ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
> ;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
> -;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
> +;;; Copyright © 2016, 2017 Troy Sankey <sankeytms@gmail.com>
> ;;; Copyright © 2016, 2017 <contact.ng0@cryptolab.net>
> ;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
> ;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
> @@ -575,7 +575,7 @@ attachments, create new maildirs, and so on.")
> (define-public alot
> (package
> (name "alot")
> - (version "0.4")
> + (version "0.5.1")
> (source (origin
> (method url-fetch)
> ;; package author intends on distributing via github rather
> @@ -586,13 +586,14 @@ attachments, create new maildirs, and so on.")
> (file-name (string-append "alot-" version ".tar.gz"))
> (sha256
> (base32
> - "0sl1kl2fhkv208llnbny4blcvrfdk4vx6bcw5pnyh9ylwb0pipi2"))))
> + "0wax30hjzmkqfml7hig1dqw1v1y63yc0cgbzl96x58b9h2ggqx3a"))))
> (build-system python-build-system)
> (arguments
> - `(#:tests? #f ; no tests
> - ;; python 3 is currently unsupported, more info:
> + `(;; python 3 is currently unsupported, more info:
> ;; https://github.com/pazz/alot/blob/master/docs/source/faq.rst
> #:python ,python-2))
> + (native-inputs
> + `(("python2-mock" ,python2-mock)))
> (inputs
> `(("python2-magic" ,python2-magic)
> ("python2-configobj" ,python2-configobj)
> --
> 2.11.1
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAli9XxMACgkQoqBt8qM6
VPp5sggAnSrCLqxkTyUzHwvkW3+ru1r4kd96M4OeRP6aL822AoFHeb2LP883a7uc
oN44/+BIftfjntLQi9EEpjHLZMi8gsf7EzSpqb4R+9zoK8459VhGdONKXLWXBav3
jtyIMkOpgmhm10AHWM7p6bwEUisa7RkJrrT8502SeEUqFiTn8kun7Y+I5oMvavJB
trzYbvhTEh4Ab4ZbXc/ioCnizNC+j6ZiR27Si2FAQweBTI7Xe3aKV0vx3SdVvWI/
VBG1rZwj71oDZnEpGZnSyEzpsy/NTaFafb8PStXQtTo1Mi6J+9svz8V8/YFa6Gnu
o3JJ3mRd5smjGAtO9n0EU4QmF1YWJA==
=yjkk
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 10 Mar 2017 09:30
control message for bug #25808
(address . control@debbugs.gnu.org)
87r325bkk6.fsf@gnu.org
tags 25808 moreinfo
R
R
Ricardo Wurmus wrote on 7 May 2017 12:13
Re: bug#25808: Updating alot (and other collateral updates)
(name . Troy Sankey)(address . sankeytms@gmail.com)(address . 25808@debbugs.gnu.org)
87k25tgeku.fsf@elephly.net
Troy Sankey <sankeytms@gmail.com> writes:

Toggle quote (4 lines)
> Debbugs split off half of my patches in this series and created
> individual bugs for them. Sorry, I don't understand why. I used
> git send-email like I normally would on guix-devel@gnu.org.

It’s best to send a single email (e.g. the cover letter) to
guix-patches@gnu.org first, wait for confirmation from debbugs, and then
send all the patches to the bug address (e.g. 25808@debbugs.gnu.org).

BTW: I see that these patches have not been pushed yet. Do you plan on
sending updated patches?

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
R
R
Ricardo Wurmus wrote on 10 Oct 2017 23:11
(name . Troy Sankey)(address . sankeytms@gmail.com)(address . 25808-done@debbugs.gnu.org)
87wp42lnd4.fsf@elephly.net
Hi Troy,

Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (14 lines)
> Troy Sankey <sankeytms@gmail.com> writes:
>
>> Debbugs split off half of my patches in this series and created
>> individual bugs for them. Sorry, I don't understand why. I used
>> git send-email like I normally would on guix-devel@gnu.org.
>
> It’s best to send a single email (e.g. the cover letter) to
> guix-patches@gnu.org first, wait for confirmation from debbugs, and then
> send all the patches to the bug address (e.g. 25808@debbugs.gnu.org).
>
> BTW: I see that these patches have not been pushed yet. Do you plan on
> sending updated patches?


I have taken your patches, made the changes suggested by Marius, updated
some of the packages to the latest version and pushed them to master
with commit 3f81ca324.

Thanks again for your contribution!

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
Closed
?