Substitute hash mismatches not properly reported

  • Done
  • quality assurance status badge
Details
One participant
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal
L
L
Ludovic Courtès wrote on 3 Aug 2016 11:50
(address . bug-guix@gnu.org)
87ziou5ggy.fsf@gnu.org
Hello,

When using ‘guix package’, upon a substitute hash mismatch, all we see
is something like this:

Toggle snippet (8 lines)
Found valid signature for /gnu/store/cpw9yca1mcqhqfq450dr3rz2jzr95l69-glib-2.48.0
From https://mirror.hydra.gnu.org/nar/cpw9yca1mcqhqfq450dr3rz2jzr95l69-glib-2.48.0
Downloading cpw9yc...-glib-2.48.0 (13.5MiB installed)...
glib-2.48.0 744KiB/s 00:04 | 2.9MiB transferred
killing process 11821
guix system: error: build failed: some substitutes for the outputs of derivation `/gnu/store/lkvlm17z8qm1v6r4n5ja5vcmsp7d860i-graphviz-2.38.0.drv' failed (usually happens due to networking issues); try `--fallback' to build derivation from source

The error message from build.cc:

Toggle snippet (5 lines)
if (expectedHash != actualHash)
throw SubstError(format("hash mismatch in downloaded path `%1%': expected %2%, got %3%")
% storePath % printHash(expectedHash) % printHash(actualHash));

… is only visible when we set-build-options #:print-build-trace? #t
(like ‘guix build’ does, but ‘guix package’ and others do not.)

The message should always be displayed, regardless of
#:print-build-trace?.

Ludo’.
L
L
Ludovic Courtès wrote on 9 Jul 2020 15:56
(address . 24140-done@debbugs.gnu.org)
878sfsbxlg.fsf@gnu.org
ludo@gnu.org (Ludovic Courtès) skribis:

Toggle quote (23 lines)
> When using ‘guix package’, upon a substitute hash mismatch, all we see
> is something like this:
>
> Found valid signature for /gnu/store/cpw9yca1mcqhqfq450dr3rz2jzr95l69-glib-2.48.0
>>From https://mirror.hydra.gnu.org/nar/cpw9yca1mcqhqfq450dr3rz2jzr95l69-glib-2.48.0
> Downloading cpw9yc...-glib-2.48.0 (13.5MiB installed)...
> glib-2.48.0 744KiB/s 00:04 | 2.9MiB transferred
> killing process 11821
> guix system: error: build failed: some substitutes for the outputs of derivation `/gnu/store/lkvlm17z8qm1v6r4n5ja5vcmsp7d860i-graphviz-2.38.0.drv' failed (usually happens due to networking issues); try `--fallback' to build derivation from source
>
>
> The error message from build.cc:
>
> if (expectedHash != actualHash)
> throw SubstError(format("hash mismatch in downloaded path `%1%': expected %2%, got %3%")
> % storePath % printHash(expectedHash) % printHash(actualHash));
>
> … is only visible when we set-build-options #:print-build-trace? #t
> (like ‘guix build’ does, but ‘guix package’ and others do not.)
>
> The message should always be displayed, regardless of
> #:print-build-trace?.

Fixed long ago, at least with the introduction of (guix status). Closing!
Closed
?