[PATCH 0/4] Rename '/fixed' by '/pinned'

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Ludovic Courtès
  • Simon Tournier
Owner
unassigned
Submitted by
Simon Tournier
Severity
normal
S
S
Simon Tournier wrote on 26 Jan 2023 17:42
(address . guix-patches@gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20230126164238.2462377-1-zimon.toutoune@gmail.com
Hi,

As discussed in this subthread [1] of patch#60042, this series renames the
packages which are 'pinned' (version that rarely changes) to distinguish with
packages which are 'fixed' (mainly the ones with security fixes used as
grafts).

For instance, it was previously 'samba/fixed' and 'samba/fixed-patched' which
can be confusing; especially when other packages are using '/fixed' for
security fixes. Now it becomes: 'samba/pinned' and 'samba/fixed'.

There is no rebuild, if all is going well. :-)

Cheers,
simon


Simon Tournier (4):
gnu: Rename 'git-minimal/fixed' to 'git-minimal/pinned'.
gnu: Rename 'libnftnl/fixed' to 'libnftnl/pinned'.
gnu: Rename 'guile-3.0/fixed' to 'guile-3.0/pinned'.
gnu: Rename 'samba/fixed' to 'samba/pinned'.

etc/release-manifest.scm | 2 +-
gnu/packages/autotools.scm | 2 +-
gnu/packages/commencement.scm | 2 +-
gnu/packages/erlang.scm | 4 ++--
gnu/packages/gnome.scm | 4 ++--
gnu/packages/gtk.scm | 2 +-
gnu/packages/guile.scm | 2 +-
gnu/packages/haskell.scm | 4 ++--
gnu/packages/julia-xyz.scm | 2 +-
gnu/packages/linux.scm | 4 ++--
gnu/packages/ocaml.scm | 4 ++--
gnu/packages/python-xyz.scm | 4 ++--
gnu/packages/samba.scm | 10 +++++-----
gnu/packages/version-control.scm | 2 +-
14 files changed, 24 insertions(+), 24 deletions(-)


base-commit: 0e480ca7b60428a62fc4681d7aca6c7c067add42
--
2.38.1
S
S
Simon Tournier wrote on 26 Jan 2023 17:43
[PATCH 2/4] gnu: Rename 'libnftnl/fixed' to 'libnftnl/pinned'.
(address . 61078@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20230126164347.2462817-2-zimon.toutoune@gmail.com
* gnu/packages/linux.scm: Rename variable 'libnftnl/fixed' to
'libnftnl/pinned'.
(iptables)[native-inputs]: Replace 'libnftnl/fixed' with 'libnftnl/pinned'.
---
gnu/packages/linux.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c90fbf396f..bcdf004350 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2848,7 +2848,7 @@ (define-public iptables
(native-inputs
(list pkg-config flex bison))
(inputs
- (list libmnl libnftnl/fixed))
+ (list libmnl libnftnl/pinned))
(arguments
(list #:tests? #f ; no test suite
#:configure-flags ; add $libdir to the RUNPATH of executables
@@ -7656,7 +7656,7 @@ (define-public libnftnl
;; This is used in iptables, which contributes to rust. We're pinning this
;; variant to avoid accidental rebuilds of rust.
-(define-public libnftnl/fixed
+(define-public libnftnl/pinned
(package (inherit libnftnl)
(version "1.2.0")
(source
--
2.38.1
S
S
Simon Tournier wrote on 26 Jan 2023 17:43
[PATCH 1/4] gnu: Rename 'git-minimal/fixed' to 'git-minimal/pinned'.
(address . 61078@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20230126164347.2462817-1-zimon.toutoune@gmail.com
* gnu/packages/version-control.scm: Rename variable 'git-minimal/fixed' to
'git-minimal/pinned'.
* gnu/packages/erlang.scm (erlang-erlware-commons)[native-inputs]: Replace
'git-minimal/fixed' with 'git-minimal/pinned'.
(rebar3-git-vsn)[inputs]: Idem.
* gnu/packages/gnome.scm (gnome-photos)[native-inputs]: Idem.
* gnu/packages/gtk.scm (graphene)[native-inputs]: Idem.
* gnu/packages/haskell.scm (ghc-8.8)[native-inputs]: Idem
(ghc-8.10)[native-inputs]: Idem.
* gnu/packages/julia-xyz.scm (julia-documenter)[native-inputs]: Idem.
* gnu/packages/ocaml.scm (opam)[native-inputs]: Idem.
(ocamlformat)[native-inputs]: Idem.
* gnu/packages/python-xyz.scm (python-check-manifest)[native-inputs]: Idem.
(python-scikit-build)[native-inputs]: Idem.
---
gnu/packages/erlang.scm | 4 ++--
gnu/packages/gnome.scm | 2 +-
gnu/packages/gtk.scm | 2 +-
gnu/packages/haskell.scm | 4 ++--
gnu/packages/julia-xyz.scm | 2 +-
gnu/packages/ocaml.scm | 4 ++--
gnu/packages/python-xyz.scm | 4 ++--
gnu/packages/version-control.scm | 2 +-
8 files changed, 12 insertions(+), 12 deletions(-)

Toggle diff (142 lines)
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index cfada5a619..dc9a932aec 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -376,7 +376,7 @@ (define-public erlang-erlware-commons
(propagated-inputs
(list erlang-cf))
(native-inputs
- (list git-minimal/fixed)) ;; Required for tests
+ (list git-minimal/pinned)) ;; Required for tests
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -701,7 +701,7 @@ (define-public rebar3-git-vsn
(base32 "1dfz56034pa25axly9vqdzv3phkn8ll0qwrkws96pbgcprhky1hx"))))
(build-system rebar-build-system)
(inputs
- (list git-minimal/fixed))
+ (list git-minimal/pinned))
(arguments
`(;; Running the tests require binary artifact (tar-file containing
;; samples git repos) TODO: remove these from the source
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index de5b5df450..10945ff457 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -909,7 +909,7 @@ (define-public gnome-photos
(list dbus
desktop-file-utils
gettext-minimal
- git-minimal/fixed
+ git-minimal/pinned
`(,glib "bin")
gobject-introspection
gsettings-desktop-schemas
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 5024455368..f575194c73 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2519,7 +2519,7 @@ (define-public graphene
'("-Dintrospection=false")
'()))))
(native-inputs
- `(("git" ,git-minimal/fixed)
+ `(("git" ,git-minimal/pinned)
("gobject-introspection" ,gobject-introspection)
("mutest" ,mutest)
("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 91610a1f2e..4eb13f76d7 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1143,7 +1143,7 @@ (define-public ghc-8.8
(sha256
(base32
"0c55pj2820q26rikhpf636sn4mjgqsxjrl94vsywrh79dxp3k14z"))))
- ("git" ,git-minimal/fixed) ; invoked during tests
+ ("git" ,git-minimal/pinned) ; invoked during tests
,@(filter (match-lambda
(("ghc-bootstrap" . _) #f)
(("ghc-testsuite" . _) #f)
@@ -1195,7 +1195,7 @@ (define-public ghc-8.10
(sha256
(base32
"1zl25gg6bpx5601k8h3cqnns1xfc0nqgwnh8jvn2s65ra3f2g1nz"))))
- ("git" ,git-minimal/fixed) ; invoked during tests
+ ("git" ,git-minimal/pinned) ; invoked during tests
,@(filter (match-lambda
(("ghc-bootstrap" . _) #f)
(("ghc-testsuite" . _) #f)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 414aba03f0..b831b41db2 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1614,7 +1614,7 @@ (define-public julia-documenter
(inputs
(list python-wrapper))
(native-inputs
- (list git-minimal/fixed ;needed for the "Utilities" test
+ (list git-minimal/pinned ;needed for the "Utilities" test
julia-documentermarkdown
julia-documentertools))
(home-page "https://juliadocs.github.io/Documenter.jl")
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3458c87818..0cc92c3e85 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -938,7 +938,7 @@ (define-public opam
("ocaml-cppo" ,ocaml-cppo)
;; For tests.
- ("git" ,git-minimal/fixed)
+ ("git" ,git-minimal/pinned)
("openssl" ,openssl)
("python" ,python-wrapper)
("rsync" ,rsync)
@@ -8656,7 +8656,7 @@ (define-public ocamlformat
ocaml-uuseg
ocaml-uutf))
(native-inputs
- (list git-minimal/fixed ;for tests
+ (list git-minimal/pinned ;for tests
ocaml-alcotest ocaml-ocp-indent ocaml-bisect-ppx))
(home-page "https://github.com/ocaml-ppx/ocamlformat")
(synopsis "Auto-formatter for OCaml code")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b14c4ff0f3..66fc1064dc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25933,7 +25933,7 @@ (define-public python-check-manifest
(invoke "git" "config" "--global"
"protocol.file.allow" "always"))))))
(native-inputs
- (list git-minimal/fixed python-pytest))
+ (list git-minimal/pinned python-pytest))
(propagated-inputs
(list python-pypa-build python-setuptools python-tomli))
(home-page "https://github.com/mgedmin/check-manifest")
@@ -28578,7 +28578,7 @@ (define-public python-scikit-build
(native-inputs
(list cmake-minimal
gfortran
- git-minimal/fixed ;for tests
+ git-minimal/pinned ;for tests
ninja
python-coverage
python-cython
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 78a89cfd5b..502260fa43 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -670,7 +670,7 @@ (define-public git-minimal
perl
zlib))))
-(define-public git-minimal/fixed
+(define-public git-minimal/pinned
;; Version that rarely changes, depended on by Graphene/GTK+.
(package/inherit git-minimal
(version "2.33.1")
--
2.38.1
S
S
Simon Tournier wrote on 26 Jan 2023 17:43
[PATCH 3/4] gnu: Rename 'guile-3.0/fixed' to 'guile-3.0/pinned'.
(address . 61078@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20230126164347.2462817-3-zimon.toutoune@gmail.com
* gnu/packages/guile.scm: Rename variable 'guile-3.0/fixed' to
'guile-3.0/pinned'.
* etc/release-manifest.scm (%packages-to-cross-build): Replace
'guile-3.0/fixed' with 'guile-3.0/pinned'.
* gnu/packages/autotools.scm (make-autoconf-wrapper)[inputs]: Idem.
* gnu/packages/commencement.scm (guile-final): Idem.
---
etc/release-manifest.scm | 2 +-
gnu/packages/autotools.scm | 2 +-
gnu/packages/commencement.scm | 2 +-
gnu/packages/guile.scm | 2 +-
4 files changed, 4 insertions(+), 4 deletions(-)

Toggle diff (54 lines)
diff --git a/etc/release-manifest.scm b/etc/release-manifest.scm
index 3ef3483300..83983c0738 100644
--- a/etc/release-manifest.scm
+++ b/etc/release-manifest.scm
@@ -82,7 +82,7 @@ (define %packages-to-cross-build
;; Packages that must be cross-buildable from x86_64-linux.
;; FIXME: Add (@ (gnu packages gcc) gcc) when <https://bugs.gnu.org/40463>
;; is fixed.
- (append (list (@ (gnu packages guile) guile-3.0/fixed))
+ (append (list (@ (gnu packages guile) guile-3.0/pinned))
(map specification->package
'("coreutils" "grep" "sed" "findutils" "diffutils" "patch"
"gawk" "gettext" "gzip" "xz"
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 118f25ba09..006a9e202b 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -209,7 +209,7 @@ (define (make-autoconf-wrapper autoconf)
(inputs `(("guile"
;; XXX: Kludge to hide the circular dependency.
,(module-ref (resolve-interface '(gnu packages guile))
- 'guile-3.0/fixed))
+ 'guile-3.0/pinned))
("autoconf" ,autoconf)
("bash" ,bash-minimal)))
(arguments
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index b4566b41cc..7335aedec2 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3623,7 +3623,7 @@ (define-public guile-final
;; This package must be public because other modules refer to it. However,
;; mark it as hidden so that 'fold-packages' ignores it.
(with-boot4 (hidden-package
- (package-with-bootstrap-guile guile-3.0/fixed))))
+ (package-with-bootstrap-guile guile-3.0/pinned))))
(define-public glibc-utf8-locales-final
;; Now that we have GUILE-FINAL, build the UTF-8 locales. They are needed
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index edf289e574..f529e57a50 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -419,7 +419,7 @@ (define-public guile-3.0-latest
"GUILE_OPTIMIZATIONS = -O1 -Oresolve-primitives -Ocps\n")))))
'())))))))
-(define-public guile-3.0/fixed
+(define-public guile-3.0/pinned
;; A package of Guile that's rarely changed. It is the one used in the
;; `base' module, and thus changing it entails a full rebuild.
(package
--
2.38.1
S
S
Simon Tournier wrote on 26 Jan 2023 17:43
[PATCH 4/4] gnu: Rename 'samba/fixed' to 'samba/pinned'.
(address . 61078@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20230126164347.2462817-4-zimon.toutoune@gmail.com
* gnu/packages/samba.scm: Rename variable 'samba/fixed' to 'samba/pinned' and
'samba/fixed-patched' to 'samba/fixed'.
* gnu/packages/gnome.scm (libsoup-minimal)[inputs]: Replace 'samba/fixed' with
'samba/pinned'.
---
gnu/packages/gnome.scm | 2 +-
gnu/packages/samba.scm | 10 +++++-----
2 files changed, 6 insertions(+), 6 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 10945ff457..9d79055289 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5190,7 +5190,7 @@ (define-public libsoup-minimal
sqlite
zlib))
(inputs
- (list mit-krb5 samba/fixed)) ; For ntlm_auth support
+ (list mit-krb5 samba/pinned)) ; For ntlm_auth support
(home-page "https://wiki.gnome.org/Projects/libsoup")
(synopsis "GLib-based HTTP Library")
(description
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 00442d9645..da103ed839 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -275,14 +275,14 @@ (define-public samba
Desktops into Active Directory environments using the winbind daemon.")
(license license:gpl3+)))
-;;; FIXME: Invert inheritance relationship; the "fixed" package shouldn't be
+;;; FIXME: Invert inheritance relationship; the "pinned" package shouldn't be
;;; susceptible to changes in the free one.
-(define-public samba/fixed
+(define-public samba/pinned
;; Version that rarely changes, depended on by libsoup.
(hidden-package
(package
(inherit samba)
- (replacement samba/fixed-patched)
+ (replacement samba/fixed)
(version "4.15.3")
(source
(origin
@@ -306,9 +306,9 @@ (define-public samba/fixed
libxslt
libxml2)))))
-(define-public samba/fixed-patched
+(define-public samba/fixed
(package
- (inherit samba/fixed)
+ (inherit samba/pinned)
;; This is 4.15.13, but we need to trim the store file name to have
;; the same length as the one we are grafting above.
(version "4.15.A")
--
2.38.1
L
L
Ludovic Courtès wrote on 31 Jan 2023 23:46
Re: bug#61078: [PATCH 0/4] Rename '/fixed' by '/pinned'
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)(address . 61078@debbugs.gnu.org)
87357qs4o2.fsf_-_@gnu.org
Hi Simon,

Overall the 4 patches LGTM, thanks for doing this!

One thing came to mind though:

Simon Tournier <zimon.toutoune@gmail.com> skribis:

Toggle quote (3 lines)
> -(define-public git-minimal/fixed
> +(define-public git-minimal/pinned

Should we also add:

(define-deprecated/public-alias git-minimal/fixed git-minimal/pinned)

and similarly for the other patches?

Seems like it would be safer and we can remove it later (a couple of
months may be enough).

Ludo’.
S
S
Simon Tournier wrote on 1 Feb 2023 10:36
[PATCH v2 1/4] gnu: Rename 'git-minimal/fixed' to 'git-minimal/pinned'.
(address . 61078@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20230201093603.1432036-1-zimon.toutoune@gmail.com
* gnu/packages/version-control.scm: Rename variable 'git-minimal/fixed' to
'git-minimal/pinned', add depreciation.
* gnu/packages/erlang.scm (erlang-erlware-commons)[native-inputs]: Replace
'git-minimal/fixed' with 'git-minimal/pinned'.
(rebar3-git-vsn)[inputs]: Idem.
* gnu/packages/gnome.scm (gnome-photos)[native-inputs]: Idem.
* gnu/packages/gtk.scm (graphene)[native-inputs]: Idem.
* gnu/packages/haskell.scm (ghc-8.8)[native-inputs]: Idem
(ghc-8.10)[native-inputs]: Idem.
* gnu/packages/julia-xyz.scm (julia-documenter)[native-inputs]: Idem.
* gnu/packages/ocaml.scm (opam)[native-inputs]: Idem.
(ocamlformat)[native-inputs]: Idem.
* gnu/packages/python-xyz.scm (python-check-manifest)[native-inputs]: Idem.
(python-scikit-build)[native-inputs]: Idem.
---
gnu/packages/erlang.scm | 4 ++--
gnu/packages/gnome.scm | 2 +-
gnu/packages/gtk.scm | 2 +-
gnu/packages/haskell.scm | 4 ++--
gnu/packages/julia-xyz.scm | 2 +-
gnu/packages/ocaml.scm | 4 ++--
gnu/packages/python-xyz.scm | 4 ++--
gnu/packages/version-control.scm | 7 ++++++-
8 files changed, 17 insertions(+), 12 deletions(-)

Toggle diff (156 lines)
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index cfada5a619..dc9a932aec 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -376,7 +376,7 @@ (define-public erlang-erlware-commons
(propagated-inputs
(list erlang-cf))
(native-inputs
- (list git-minimal/fixed)) ;; Required for tests
+ (list git-minimal/pinned)) ;; Required for tests
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -701,7 +701,7 @@ (define-public rebar3-git-vsn
(base32 "1dfz56034pa25axly9vqdzv3phkn8ll0qwrkws96pbgcprhky1hx"))))
(build-system rebar-build-system)
(inputs
- (list git-minimal/fixed))
+ (list git-minimal/pinned))
(arguments
`(;; Running the tests require binary artifact (tar-file containing
;; samples git repos) TODO: remove these from the source
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f8b02670f7..937f26e172 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -909,7 +909,7 @@ (define-public gnome-photos
(list dbus
desktop-file-utils
gettext-minimal
- git-minimal/fixed
+ git-minimal/pinned
`(,glib "bin")
gobject-introspection
gsettings-desktop-schemas
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 5024455368..f575194c73 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2519,7 +2519,7 @@ (define-public graphene
'("-Dintrospection=false")
'()))))
(native-inputs
- `(("git" ,git-minimal/fixed)
+ `(("git" ,git-minimal/pinned)
("gobject-introspection" ,gobject-introspection)
("mutest" ,mutest)
("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 91610a1f2e..4eb13f76d7 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1143,7 +1143,7 @@ (define-public ghc-8.8
(sha256
(base32
"0c55pj2820q26rikhpf636sn4mjgqsxjrl94vsywrh79dxp3k14z"))))
- ("git" ,git-minimal/fixed) ; invoked during tests
+ ("git" ,git-minimal/pinned) ; invoked during tests
,@(filter (match-lambda
(("ghc-bootstrap" . _) #f)
(("ghc-testsuite" . _) #f)
@@ -1195,7 +1195,7 @@ (define-public ghc-8.10
(sha256
(base32
"1zl25gg6bpx5601k8h3cqnns1xfc0nqgwnh8jvn2s65ra3f2g1nz"))))
- ("git" ,git-minimal/fixed) ; invoked during tests
+ ("git" ,git-minimal/pinned) ; invoked during tests
,@(filter (match-lambda
(("ghc-bootstrap" . _) #f)
(("ghc-testsuite" . _) #f)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 414aba03f0..b831b41db2 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1614,7 +1614,7 @@ (define-public julia-documenter
(inputs
(list python-wrapper))
(native-inputs
- (list git-minimal/fixed ;needed for the "Utilities" test
+ (list git-minimal/pinned ;needed for the "Utilities" test
julia-documentermarkdown
julia-documentertools))
(home-page "https://juliadocs.github.io/Documenter.jl")
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3458c87818..0cc92c3e85 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -938,7 +938,7 @@ (define-public opam
("ocaml-cppo" ,ocaml-cppo)
;; For tests.
- ("git" ,git-minimal/fixed)
+ ("git" ,git-minimal/pinned)
("openssl" ,openssl)
("python" ,python-wrapper)
("rsync" ,rsync)
@@ -8656,7 +8656,7 @@ (define-public ocamlformat
ocaml-uuseg
ocaml-uutf))
(native-inputs
- (list git-minimal/fixed ;for tests
+ (list git-minimal/pinned ;for tests
ocaml-alcotest ocaml-ocp-indent ocaml-bisect-ppx))
(home-page "https://github.com/ocaml-ppx/ocamlformat")
(synopsis "Auto-formatter for OCaml code")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b14c4ff0f3..66fc1064dc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25933,7 +25933,7 @@ (define-public python-check-manifest
(invoke "git" "config" "--global"
"protocol.file.allow" "always"))))))
(native-inputs
- (list git-minimal/fixed python-pytest))
+ (list git-minimal/pinned python-pytest))
(propagated-inputs
(list python-pypa-build python-setuptools python-tomli))
(home-page "https://github.com/mgedmin/check-manifest")
@@ -28578,7 +28578,7 @@ (define-public python-scikit-build
(native-inputs
(list cmake-minimal
gfortran
- git-minimal/fixed ;for tests
+ git-minimal/pinned ;for tests
ninja
python-coverage
python-cython
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 78a89cfd5b..12e21336ce 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -67,6 +67,7 @@ (define-module (gnu packages version-control)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils)
#:use-module (guix packages)
+ #:use-module (guix deprecation)
#:use-module (guix gexp)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -670,7 +671,11 @@ (define-public git-minimal
perl
zlib))))
-(define-public git-minimal/fixed
+;;; The symbol git-minimal/fixed should be used when git-minimal needs fixes
+;;; (security or else) and this deprecation could be removed.
+(define-deprecated/public-alias git-minimal/fixed git-minimal/pinned)
+
+(define-public git-minimal/pinned
;; Version that rarely changes, depended on by Graphene/GTK+.
(package/inherit git-minimal
(version "2.33.1")

base-commit: 14323edcc37d9efaae2491cf5f57ea0621412d7e
--
2.38.1
S
S
Simon Tournier wrote on 1 Feb 2023 10:36
[PATCH v2 4/4] gnu: Rename 'samba/fixed' to 'samba/pinned'.
(address . 61078@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20230201093603.1432036-4-zimon.toutoune@gmail.com
* gnu/packages/samba.scm: Rename variable 'samba/fixed' to 'samba/pinned' and
'samba/fixed-patched' to 'samba/fixed'.
* gnu/packages/gnome.scm (libsoup-minimal)[inputs]: Replace 'samba/fixed' with
'samba/pinned'.
---
gnu/packages/gnome.scm | 2 +-
gnu/packages/samba.scm | 10 +++++-----
2 files changed, 6 insertions(+), 6 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 937f26e172..b1f0615702 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5199,7 +5199,7 @@ (define-public libsoup-minimal
sqlite
zlib))
(inputs
- (list mit-krb5 samba/fixed)) ; For ntlm_auth support
+ (list mit-krb5 samba/pinned)) ; For ntlm_auth support
(home-page "https://wiki.gnome.org/Projects/libsoup")
(synopsis "GLib-based HTTP Library")
(description
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 00442d9645..da103ed839 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -275,14 +275,14 @@ (define-public samba
Desktops into Active Directory environments using the winbind daemon.")
(license license:gpl3+)))
-;;; FIXME: Invert inheritance relationship; the "fixed" package shouldn't be
+;;; FIXME: Invert inheritance relationship; the "pinned" package shouldn't be
;;; susceptible to changes in the free one.
-(define-public samba/fixed
+(define-public samba/pinned
;; Version that rarely changes, depended on by libsoup.
(hidden-package
(package
(inherit samba)
- (replacement samba/fixed-patched)
+ (replacement samba/fixed)
(version "4.15.3")
(source
(origin
@@ -306,9 +306,9 @@ (define-public samba/fixed
libxslt
libxml2)))))
-(define-public samba/fixed-patched
+(define-public samba/fixed
(package
- (inherit samba/fixed)
+ (inherit samba/pinned)
;; This is 4.15.13, but we need to trim the store file name to have
;; the same length as the one we are grafting above.
(version "4.15.A")
--
2.38.1
S
S
Simon Tournier wrote on 1 Feb 2023 10:36
[PATCH v2 3/4] gnu: Rename 'guile-3.0/fixed' to 'guile-3.0/pinned'.
(address . 61078@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20230201093603.1432036-3-zimon.toutoune@gmail.com
* gnu/packages/guile.scm: Rename variable 'guile-3.0/fixed' to
'guile-3.0/pinned', add deprecation.
* etc/release-manifest.scm (%packages-to-cross-build): Replace
'guile-3.0/fixed' with 'guile-3.0/pinned'.
* gnu/packages/autotools.scm (make-autoconf-wrapper)[inputs]: Idem.
* gnu/packages/commencement.scm (guile-final): Idem.
---
etc/release-manifest.scm | 2 +-
gnu/packages/autotools.scm | 2 +-
gnu/packages/commencement.scm | 2 +-
gnu/packages/guile.scm | 6 +++++-
4 files changed, 8 insertions(+), 4 deletions(-)

Toggle diff (58 lines)
diff --git a/etc/release-manifest.scm b/etc/release-manifest.scm
index 3ef3483300..83983c0738 100644
--- a/etc/release-manifest.scm
+++ b/etc/release-manifest.scm
@@ -82,7 +82,7 @@ (define %packages-to-cross-build
;; Packages that must be cross-buildable from x86_64-linux.
;; FIXME: Add (@ (gnu packages gcc) gcc) when <https://bugs.gnu.org/40463>
;; is fixed.
- (append (list (@ (gnu packages guile) guile-3.0/fixed))
+ (append (list (@ (gnu packages guile) guile-3.0/pinned))
(map specification->package
'("coreutils" "grep" "sed" "findutils" "diffutils" "patch"
"gawk" "gettext" "gzip" "xz"
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 118f25ba09..006a9e202b 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -209,7 +209,7 @@ (define (make-autoconf-wrapper autoconf)
(inputs `(("guile"
;; XXX: Kludge to hide the circular dependency.
,(module-ref (resolve-interface '(gnu packages guile))
- 'guile-3.0/fixed))
+ 'guile-3.0/pinned))
("autoconf" ,autoconf)
("bash" ,bash-minimal)))
(arguments
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index b4566b41cc..7335aedec2 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3623,7 +3623,7 @@ (define-public guile-final
;; This package must be public because other modules refer to it. However,
;; mark it as hidden so that 'fold-packages' ignores it.
(with-boot4 (hidden-package
- (package-with-bootstrap-guile guile-3.0/fixed))))
+ (package-with-bootstrap-guile guile-3.0/pinned))))
(define-public glibc-utf8-locales-final
;; Now that we have GUILE-FINAL, build the UTF-8 locales. They are needed
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index edf289e574..2fd9b711ce 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -419,7 +419,11 @@ (define-public guile-3.0-latest
"GUILE_OPTIMIZATIONS = -O1 -Oresolve-primitives -Ocps\n")))))
'())))))))
-(define-public guile-3.0/fixed
+;;; The symbol guile-3.0/fixed should be used when guile-3.0 needs fixes
+;;; (security or else) and this deprecation could be removed.
+(define-deprecated/public-alias guile-3.0/fixed guile-3.0/pinned)
+
+(define-public guile-3.0/pinned
;; A package of Guile that's rarely changed. It is the one used in the
;; `base' module, and thus changing it entails a full rebuild.
(package
--
2.38.1
S
S
Simon Tournier wrote on 1 Feb 2023 10:36
[PATCH v2 2/4] gnu: Rename 'libnftnl/fixed' to 'libnftnl/pinned'.
(address . 61078@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20230201093603.1432036-2-zimon.toutoune@gmail.com
* gnu/packages/linux.scm: Rename variable 'libnftnl/fixed' to
'libnftnl/pinned', add deprecation.
(iptables)[native-inputs]: Replace 'libnftnl/fixed' with 'libnftnl/pinned'.
---
gnu/packages/linux.scm | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5a776168cc..25c831ac48 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2848,7 +2848,7 @@ (define-public iptables
(native-inputs
(list pkg-config flex bison))
(inputs
- (list libmnl libnftnl/fixed))
+ (list libmnl libnftnl/pinned))
(arguments
(list #:tests? #f ; no test suite
#:configure-flags ; add $libdir to the RUNPATH of executables
@@ -7654,9 +7654,13 @@ (define-public libnftnl
used by nftables.")
(license license:gpl2+)))
+;;; The symbol libnftl/fixed should be used when libnftnl needs fixes
+;;; (security or else) and this deprecation could be removed.
+(define-deprecated/public-alias libnftnl/fixed libnftnl/pinned)
+
;; This is used in iptables, which contributes to rust. We're pinning this
;; variant to avoid accidental rebuilds of rust.
-(define-public libnftnl/fixed
+(define-public libnftnl/pinned
(package (inherit libnftnl)
(version "1.2.0")
(source
--
2.38.1
Z
Z
zimoun wrote on 1 Feb 2023 10:28
Re: [bug#61078] [PATCH 0/4] Rename '/fixed' by '/pinned'
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 61078@debbugs.gnu.org)
86edr9vinn.fsf@gmail.com
On Tue, 31 Jan 2023 at 23:46, Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (6 lines)
> Should we also add:
>
> (define-deprecated/public-alias git-minimal/fixed git-minimal/pinned)
>
> and similarly for the other patches?

Done in v2 except for samba. The rename reads,

samba/fixed -> samba-pinned
samba/fixed-patched -> samba/fixed

Well, the symbol samba/fixed still exists so I do not know how to
deprecate it. At worse, people relying on the symbol samba/fixed will
get an newer version of Samba (v4.15.13 instead of v4.15.3). It appears
fine to me.


Toggle quote (3 lines)
> Seems like it would be safer and we can remove it later (a couple of
> months may be enough).

Well, couple of months or early if something needs a graft – I added a
comment.


Cheers,
simon
L
L
Liliana Marie Prikler wrote on 1 Feb 2023 18:43
Re: [PATCH v2 1/4] gnu: Rename 'git-minimal/fixed' to 'git-minimal/pinned'.
d5143d83275138f2e1a0ec42255dc6b49f695740.camel@gmail.com
Am Mittwoch, dem 01.02.2023 um 10:36 +0100 schrieb Simon Tournier:
Toggle quote (7 lines)
> * gnu/packages/version-control.scm: Rename variable 'git-
> minimal/fixed' to
> 'git-minimal/pinned', add depreciation.
> * gnu/packages/erlang.scm (erlang-erlware-commons)[native-inputs]:
> Replace
> 'git-minimal/fixed' with 'git-minimal/pinned'.
> (rebar3-git-vsn)[inputs]: Idem.
I personally prefer "Likewise", so I'll reword it to that unless you
have a strong objection.
Toggle quote (3 lines)
> * gnu/packages/gnome.scm (gnome-photos)[native-inputs]: Idem.
> * gnu/packages/gtk.scm (graphene)[native-inputs]: Idem.
> * gnu/packages/haskell.scm (ghc-8.8)[native-inputs]: Idem
Note the missing dot.
Toggle quote (1 lines)
> (ghc-8.10)[native-inputs]: Idem.
I think this could be shortened to (ghc-8.8, ghc-8.10)[native-inputs].
WDYT?
Toggle quote (7 lines)
> * gnu/packages/julia-xyz.scm (julia-documenter)[native-inputs]: Idem.
> * gnu/packages/ocaml.scm (opam)[native-inputs]: Idem.
> (ocamlformat)[native-inputs]: Idem.
> * gnu/packages/python-xyz.scm (python-check-manifest)[native-inputs]:
> Idem.
> (python-scikit-build)[native-inputs]: Idem.

Cheers
Z
Z
zimoun wrote on 1 Feb 2023 21:29
Re: [bug#61078] [PATCH v2 1/4] gnu: Rename 'git-minimal/fixed' to 'git-minimal/pinned'.
86edr9w2m9.fsf@gmail.com
Hi Liliana,

Thanks for double checking. :-)

On Wed, 01 Feb 2023 at 18:43, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:
Toggle quote (11 lines)
> Am Mittwoch, dem 01.02.2023 um 10:36 +0100 schrieb Simon Tournier:
>> * gnu/packages/version-control.scm: Rename variable 'git-
>> minimal/fixed' to
>> 'git-minimal/pinned', add depreciation.
>> * gnu/packages/erlang.scm (erlang-erlware-commons)[native-inputs]:
>> Replace
>> 'git-minimal/fixed' with 'git-minimal/pinned'.
>> (rebar3-git-vsn)[inputs]: Idem.
> I personally prefer "Likewise", so I'll reword it to that unless you
> have a strong objection.

No objection.

Toggle quote (4 lines)
>> (ghc-8.10)[native-inputs]: Idem.
> I think this could be shortened to (ghc-8.8, ghc-8.10)[native-inputs].
> WDYT?

Feel free. :-)

Cheers,
simon
L
L
Liliana Marie Prikler wrote on 5 Feb 2023 07:14
6f48e2b1c7fcdf8571ce20b2c708e4c0cc79aa7f.camel@gmail.com
Am Mittwoch, dem 01.02.2023 um 21:29 +0100 schrieb zimoun:
Toggle quote (27 lines)
> Hi Liliana,
>
> Thanks for double checking. :-)
>
> On Wed, 01 Feb 2023 at 18:43, Liliana Marie Prikler
> <liliana.prikler@gmail.com> wrote:
> > Am Mittwoch, dem 01.02.2023 um 10:36 +0100 schrieb Simon Tournier:
> > > * gnu/packages/version-control.scm: Rename variable 'git-
> > > minimal/fixed' to
> > > 'git-minimal/pinned', add depreciation.
> > > * gnu/packages/erlang.scm (erlang-erlware-commons)[native-
> > > inputs]:
> > > Replace
> > > 'git-minimal/fixed' with 'git-minimal/pinned'.
> > > (rebar3-git-vsn)[inputs]: Idem.
> > I personally prefer "Likewise", so I'll reword it to that unless
> > you
> > have a strong objection.
>
> No objection.
>
> > > (ghc-8.10)[native-inputs]: Idem.
> > I think this could be shortened to (ghc-8.8, ghc-8.10)[native-
> > inputs].
> > WDYT?
>
> Feel free. :-)
Done and pushed with the rest of the series.

Cheers
Closed
S
S
Simon Tournier wrote on 6 Feb 2023 18:02
Re: bug#61078: [PATCH v2 1/4] gnu: Rename 'git-minimal/fixed' to 'git-minimal/pinned'.
877cwuk9rb.fsf@gmail.com
Hi,

On dim., 05 févr. 2023 at 07:14, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:

Toggle quote (2 lines)
> Done and pushed with the rest of the series.

Thank you.

Cheers,
simon
Closed
?