(address . guix-patches@gnu.org)
* gnu/packages/plotutils.scm (asymptote): Update to 2.84.
[native-inputs]: Add BISON and FLEX.
---
gnu/packages/plotutils.scm | 10 +++++++---
1 file changed, 7 insertions(+), 3 deletions(-)
Toggle diff (59 lines)
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 678963575e..3244d861c3 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2016-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2016-2023 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
@@ -30,10 +30,12 @@ (define-module (gnu packages plotutils)
#:use-module (guix build-system gnu)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages bison)
#:use-module (gnu packages bdw-gc)
#:use-module (gnu packages boost)
#:use-module (gnu packages cmake)
#:use-module (gnu packages emacs)
+ #:use-module (gnu packages flex)
#:use-module (gnu packages xorg)
#:use-module (gnu packages image)
#:use-module (gnu packages ghostscript)
@@ -269,14 +271,14 @@ (define-public ploticus
(define-public asymptote
(package
(name "asymptote")
- (version "2.83")
+ (version "2.84")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/asymptote/"
version "/asymptote-" version ".src.tgz"))
(sha256
- (base32 "18w8nf0p1b3h74sk1b7w96kq5gcaq09idi4771ini7p594gsfg7y"))
+ (base32 "1nycdmlhs3r1qj5miww19683qqjf4hihsjwzwjj1q4mq0hnp0rb7"))
(modules '((guix build utils)))
(snippet
;; Remove bundled RapidJSON.
@@ -289,9 +291,11 @@ (define-public asymptote
(native-inputs
(list autoconf
automake
+ bison
boost
cmake
emacs-minimal
+ flex
ghostscript ;for tests
perl
rapidjson
base-commit: bd55412fc297b07b5cbe4e22abdec0419ef23010
--
2.38.1