(address . bug-guix@gnu.org)
Hi,
The manual provides [1] the example:
Toggle snippet (10 lines)
(build-machine
(name "armeight.example.org")
(systems (list "aarch64-linux"))
(host-key "ssh-rsa AAAAB3Nza…")
(user "alice")
(private-key
(string-append (getenv "HOME")
"/.ssh/identity-for-guix")))
but what is not clear is 'getenv' from who. Concretly, adding 'pk' it
reads:
Toggle snippet (6 lines)
$ guix offload test
;;; ("/home/simon")
guix offload: testing 2 build machines defined in '/etc/guix/machines.scm'...
however, when really building with offload:
Toggle snippet (11 lines)
$ guix build -L /tmp/mine r-cipr
The following derivation will be built:
/gnu/store/mzixy5hhx79xx33k03acaasml87c0knc-r-cipr-0.1.0-1.4b01bb8.drv
;;; ("/root")
process 6815 acquired build slot '/var/guix/offload/x.x.x.x:22/0'
process 6815 acquired build slot '/var/guix/offload/x.x.x.x:22/0'
normalized load on machine 'x.x.x.x' is 0.00
"guix offload tes" does the correct thing, not "guix build".
Cheers,
simon